Riepilogo
Una curva a campana è un grafico della distribuzione normale di un dato set di dati. Questo articolo descrive come creare un grafico di una curva a campana in Microsoft Excel.
Altre informazioni
Nell'esempio seguente è possibile creare una curva a campana di dati generati da Excel utilizzando lo strumento Generazione numeri casuali in Strumenti di analisi. Dopo che Microsoft Excel ha generato un set di numeri casuali, è possibile creare un istogramma usando tali numeri casuali e lo strumento Istogramma di Strumenti di analisi. Dall'istogramma è possibile creare un grafico per rappresentare una curva a campana.
Per creare una curva a campana di esempio, effettuate le seguenti operazioni:
Avviare Excel.
Immettere le intestazioni di colonna seguenti in un nuovo foglio di lavoro:
A1:Original B1:Average C1:Bin D1:Random E1:Histogram G1:HistogramNello stesso foglio di lavoro immettere i dati seguenti:
A2: 23 B2: A3: 25 B3: STDEV A4: 12 B4: A5: 24 A6: 27 A7: 57 A8: 45 A9: 19Immettere le formule seguenti nello stesso foglio di lavoro:
B2: =AVERAGE(A2:A9) B3: B4: =STDEV(A2:A9)Queste formule genereranno rispettivamente la media (media) e la deviazione standard dei dati originali.
Per generare l'intervallo di contenitori per l'istogramma, immettere le formule seguenti:
C2: =$B$2-3*$B4In questo modo viene generato il limite inferiore dell'intervallo dei contenitori. Questo numero rappresenta tre deviazioni standard in meno rispetto alla media.
C3: =C2+$B$4Questa formula aggiunge una deviazione standard al numero calcolato nella cella precedente.
Selezionare la cella C3, selezionare il quadratino di riempimento e quindi ricopiare la formula dalla cella C3 alla cella C8.
Per generare i dati casuali che costituiranno la base per la curva a campana, attenersi alla seguente procedura:
Scegliere Analisi dati dal menu Strumenti.
Nella finestra di dialogo Strumenti analisi fare clic su Generazione numeri casuali e quindi su OK.
Nella casella Numero di variabili digitare 1.
Nella casella Numero di numeri casuali digitare 2000.
Nota
La variazione di questo numero aumenterà o diminuirà la precisione della curva a campana.
Nella casella Distribuzione selezionare Normale.
Nel riquadro Parametri immettere il numero calcolato nella cella B2 (29 nell'esempio) nella casella Media.
Nella casella Standard Deviazione immettere il numero calcolato nella cella B4 (14,68722).
Lascia vuota la casella Semi casuali.
Nel riquadro Opzioni di output, fare clic su Intervallo di output.
Digitare D2 nella casella Intervallo di output.
Questo genererà 2.000 numeri casuali che rientrano in una distribuzione normale.Fare clic su OK.
Per creare un istogramma per i dati casuali, seguire questa procedura:
- Scegliere Analisi dati dal menu Strumenti.
- Nella finestra di dialogo Strumenti analisi selezionare Istogramma e quindi fare clic su OK.
- Nella casella Intervallo di input digitare D2:D2001.
- Nella casella Intervallo contenitori digitare C2:C8.
- Nel riquadro Opzioni di output, fare clic su Intervallo di output.
- Digitare E2 nella casella Intervallo di output.
- Fare clic su OK.
Per creare un istogramma per i dati originali, seguire questa procedura:
- Scegliere Analisi dati dal menu Strumenti.
- Fare clic su Istogramma e quindi su OK.
- Nella casella Intervallo di input digitare A2:A9.
- Nella casella Intervallo contenitori digitare C2:C8.
- Nel riquadro Opzioni di output, fare clic su Intervallo di output.
- Digitare G2 nella casella Intervallo di output.
- Fare clic su OK.
Creare etichette per la legenda nel grafico immettendo quanto segue:
E14: =G1&"-"&G2 E15: =E1&"-"&F2 E16: =G1&"-"&H2Selezionare l'intervallo di celle, E2:H10, nel foglio di lavoro.
Scegliere Grafico dal menu Inserisci.
In Tipo di grafico fare clic su XY (a dispersione).
Nella riga centrale del sottotipo Grafico fare clic sul grafico a destra.
Nota
Appena sotto questi 5 sottotipi, la descrizione dirà "A dispersione con punti dati collegati da linee smussate senza indicatori".
Fare clic su Avanti.
Fare clic sulla scheda Serie.
Nella casella Nome eliminare il riferimento di cella e quindi selezionare la cella E15.
Nella casella Valori X eliminare il riferimento all'intervallo e quindi selezionare l'intervallo E3:E10.
Nella casella Valori Y eliminare il riferimento all'intervallo e quindi selezionare l'intervallo F3:F10.
Fare clic su Aggiungi per aggiungere un'altra serie.
Fare clic sulla casella Nome e quindi selezionare la cella E14.
Fare clic sulla casella Valori X e quindi selezionare l'intervallo E3:E10.
Nella casella Valori Y eliminare il valore presente e quindi selezionare l'intervallo G3:G10.
Fare clic su Aggiungi per aggiungere un'altra serie.
Fare clic sulla casella Nome e quindi selezionare la cella E16.
Fare clic sulla casella Valori X e quindi selezionare l'intervallo E3:E10.
Fare clic sulla casella Valori Y, eliminare il valore presente e quindi selezionare l'intervallo H3:H10.
Fare clic su Fine.
Il grafico avrà due serie curve e una serie piatta lungo l'asse x.
Fare doppio clic sulla seconda serie; dovrebbe essere etichettato come "- Cestino" nella legenda.
Nella finestra di dialogo Formato serie di dati, fare clic sulla scheda Asse.
Fate clic su Asse secondario (Secondary Axis), quindi su OK.
È ora disponibile un grafico che confronta un determinato set di dati con una curva a campana.
Riferimenti
Per altre informazioni sulla creazione di grafici, scegliere "Guida di Microsoft Excel" dal menu Guida, digitare "crea un grafico" nell'Assistente di Office o nella Ricerca e quindi fare clic su Cerca per visualizzare l'argomento.