Dati Pivot in una tabella pivot o in un grafico pivot

Si applica a
Excel per Microsoft 365 Excel per Microsoft 365 per Mac Excel 2024 Excel 2024 per Mac Excel 2021 Excel 2021 per Mac Excel 2019 Excel 2016

In Excel è possibile trasformare i dati di una tabella pivot o in un grafico pivot modificando il layout dei campi dei dati. L'elenco campi della tabella pivot consente di aggiungere, riorganizzare o rimuovere campi in modo da visualizzare i dati di una tabella pivot o di un grafico pivot esattamente nel modo desiderato.

Per impostazione predefinita, le modifiche apportate nell'elenco campi della tabella pivot vengono aggiornate automaticamente nel layout del rapporto. Per migliorare le prestazioni quando si accede a una grande quantità di dati esterni, è possibile passare temporaneamente all'aggiornamento manuale.

Uso dell'elenco campi della tabella pivot

Quando si crea una tabella pivot, Excel visualizza l'elenco campi della tabella pivot in modo che sia possibile aggiungere campi alla tabella pivot, riorganizzarli e riposizionarli in base alle esigenze o rimuoverli dalla tabella pivot. Per impostazione predefinita, nell'elenco campi della tabella pivot sono visualizzate due sezioni:

  • Sezione campi nella parte superiore per l'aggiunta e la rimozione di campi dalla tabella pivot
  • Una sezione di layout nella parte inferiore per riorganizzare e riposizionare i campi
    Finestra di dialogo Nuovo elemento grafico dati che contiene due campi dati e una forma con un elemento grafico dati che contiene questi campi come callout

È possibile ancorare l'elenco di campi della tabella pivot a due lati della finestra di Excel e ridimensionarlo orizzontalmente. È anche possibile disancorare l'elenco campi della tabella pivot, nel qual caso è possibile ridimensionarlo sia verticalmente che orizzontalmente.

Se l'elenco campi della tabella pivot non è visibile, fare clic in un punto qualsiasi della tabella pivot.

Se si chiude l'elenco campi della tabella pivot, è possibile visualizzarlo di nuovo. Fare clic con il pulsante destro del mouse sulla tabella pivot e quindi scegliere Mostra elenco campi. È anche possibile fare clic su Elenco campi sulla barra multifunzione (gruppo Strumenti tabella pivot, scheda Opzioni , Mostra per una tabella pivot; Strumenti grafico pivot, scheda Analizza , gruppo Mostra/Nascondi per un grafico pivot).

Se nell'elenco dei campi della tabella pivot non compaiono i campi che si vogliono usare, aggiornare la tabella pivot o il grafico pivot per visualizzare eventuali nuovi campi, campi calcolati, misure, misure calcolate o dimensioni aggiunte dall'ultima operazione (Strumenti tabella pivot, scheda Opzioni , gruppo Dati ).

Modifica riquadro di Domande e risposte

È importante conoscere il funzionamento dell'elenco campi di una tabella pivot e i modi in cui è possibile disporre i diversi tipi di campi in modo da ottenere i risultati desiderati quando si crea il layout campo di una tabella pivot o di un grafico pivot.

Modifica riquadro di Domande e risposte

1. Un'origine dati esterna contiene dati strutturati organizzati in uno o più campi (denominati anche colonne) visualizzati nell'elenco dei campi.

2. Spostare un campo nell'area Filtro rapporto dell'Elenco campi per spostarlo contemporaneamente nell'area Filtro rapporto della tabella pivot.

3. Spostare un campo nell'area Etichetta di colonna dell'Elenco campi per spostarlo contemporaneamente nell'area Etichetta di colonna della tabella pivot.

4. Spostare un campo nell'area Etichette di riga dell'Elenco campi per spostarlo contemporaneamente nell'area Etichette di riga della tabella pivot.

5. Spostare un campo nell'area Valori dell'Elenco campi per spostarlo contemporaneamente nell'area Valori della tabella pivot.

Linee guida per lo spostamento dei campi nell'elenco campi di una tabella pivot

Per creare un layout di campo, utilizzare le linee guida seguenti per spostare i campi Valore, Nome e Dimensione dalla sezione dei campi alle quattro aree del report nella sezione del layout.

  • Campi valore Se si seleziona una casella di controllo solo per un campo numerico, per impostazione predefinita viene spostata nell'area Valori.
  • Campi riga e colonna Un campo può essere aggiunto una sola volta nell'area Filtro rapporto, Etichette di riga o Etichette di colonna , indipendentemente dal fatto che i dati siano di tipo numerico o non numerico. Se si prova ad aggiungere più volte lo stesso campo, ad esempio alle aree Etichette di riga ed Etichette di colonna nella sezione layout, il campo viene automaticamente rimosso dall'area originale e posizionato nella nuova area.
  • Misure In un'origine dati OLAP (Online Analytical Processing) sono spesso presenti molti campi (o misure) organizzati in una gerarchia di dimensioni, gerarchie e livelli diversi. Fare clic sulla casella Espandi più e Comprimi la casella Meno fino a trovare i campi desiderati.
    Nelle aree Etichette di riga, Etichette di colonna e Filtri rapporto è possibile spostare solo gerarchie, attributi e gruppi denominati.
    È possibile spostare solo le misure, le misure calcolate e gli indicatori di prestazioni chiave (KPI) nell'area dei valori.

Modifica della visualizzazione elenco campi tabella pivot

L'elenco campi della tabella pivot include cinque visualizzazioni diverse, progettate e ottimizzate per tipi diversi di attività relative alle tabelle pivot.

  1. Per modificare la visualizzazione, fare clic sul pulsante Visualizzazioni elenco campi nella parte superiore dell'elenco campi della tabella pivot.
    PivotTable Field List View button
  2. Nell'elenco selezionare una delle visualizzazioni seguenti:
   
Sezione Campi e sezione Aree in pila Questa è la visualizzazione predefinita ed è progettata per un numero limitato di campi.
Sezione Campi e sezione aree affiancate Questa visualizzazione è progettata per aggiungere e rimuovere campi quando sono presenti più di quattro campi in ogni area.
Solo sezione Campi Questa visualizzazione è progettata semplicemente per aggiungere e rimuovere molti campi.
Solo sezione aree (2 per 2) Questa vista è progettata solo per riorganizzare molti campi.
Solo sezione aree (1 per 4) Questa vista è progettata solo per riorganizzare molti campi.

Suggerimento Nelle visualizzazioni affiancate della sezione Campi e delle aree in pila e della sezione Campi e delle aree , è possibile regolare la larghezza e l'altezza di ogni sezione posizionando il puntatore sul divisore di sezione fino a quando il puntatore non assume la forma di una freccia doppia verticale Freccia doppia verticale o freccia doppia orizzontale Freccia doppia orizzontale , trascinando la doppia freccia verso l'alto o verso il basso o verso sinistra o destra nella posizione desiderata, e quindi facendo clic sulla doppia freccia o premendo INVIO.

Aggiungere campi a una tabella pivot o a un grafico pivot

Dopo aver creato una tabella pivot o un grafico pivot, è possibile aggiungere i campi contenenti i dati che si desidera visualizzare nel rapporto. In genere si seleziona un campo per ogni area nella sezione layout. Tuttavia, per visualizzare valori diversi per un campo specifico, è anche possibile aggiungere più copie di un campo all'area Valori .

Se la tabella pivot è connessa a un'origine dati esterna contenente molti dati, è possibile filtrare uno o più campi prima di aggiungerli al rapporto, in modo da ridurre il tempo necessario per aggiornare il rapporto.

Aggiungere i campi da visualizzare

Nell'elenco campi della tabella pivot è possibile aggiungere campi alla tabella pivot o al grafico pivot eseguendo una o più delle operazioni seguenti:

  • Per posizionare un campo in un'area designata della sezione layout, nella casella Scegli i campi da aggiungere al rapporto selezionare la casella di controllo del campo desiderato. Se si vuole, è possibile ridisporre i campi in un secondo momento.
    Avvertenza Per impostazione predefinita, i campi non numerici vengono aggiunti all'area Etichette di riga , i campi numerici vengono aggiunti all'area Valori e le gerarchie di data e ora OLAP (Online Analytical Processing) vengono aggiunte all'area Etichette di colonna .
  • Per posizionare un campo in un'area specifica della sezione del layout, nella casella Scegli campi da aggiungere al rapporto fare clic con il pulsante destro del mouse sul nome del campo e quindi scegliere Aggiungi a filtro rapporto, Aggiungi a etichetta di colonna, Aggiungi a etichetta di riga o Aggiungi a valori.
  • Per trascinare un campo in un'area della sezione layout, nella casella Scegliere i campi da aggiungere al report fare clic e tenere premuto su un campo e quindi trascinarlo dalla sezione dei campi alla sezione del layout desiderata.

Aggiungere più copie di un campo nell'area dei valori

In una tabella pivot basata su dati di un foglio di lavoro di Excel o su dati esterni provenienti da un'origine dati OLAP (Non-Online Analytical Processing), è possibile aggiungere più volte uno stesso campo all'area Valori . È possibile indipendentemente dal fatto che i dati siano di tipo numerico o non numerico. Ad esempio, può essere utile confrontare calcoli affiancati, quali margini di profitto lordi e netti, vendite minime e massime o numero di clienti e percentuale di clienti totali.

  1. Nell'elenco campi della tabella pivot, nella casella Scegli campi da aggiungere al report , fare clic e tenere premuto il pulsante del mouse su un campo e quindi trascinarlo nell'area Valori nella sezione layout.
  2. Ripetere il passaggio 1 per creare il numero di copie del campo da visualizzare nell'area Valore .
  3. Nella tabella pivot modificare la funzione di riepilogo o il calcolo personalizzato nel modo desiderato in ogni copia del campo.
    SuggerimentoÈ anche possibile modificare il nome dei campi copiati nella tabella pivot stessa.

Note 

  • Quando si aggiungono due o più campi all'area Valori, indipendentemente dal fatto che siano copie dello stesso campo o campi diversi, l'elenco campi aggiunge automaticamente un'etichetta Colonna valori all'area Valori . Si può usare questo campo per spostare verso l'alto o verso il basso i campi nell'area dei valori. È anche possibile spostare l'etichetta di colonna dei valori nell'area Etichette di colonna o Etichette di riga . Tuttavia, non è possibile spostare l'etichetta Colonna valori nell'area Filtri dei rapporti .
  • Un campo può essere aggiunto una sola volta nell'area Filtro rapporto, Etichette di riga o Etichette di colonna, indipendentemente dal fatto che i dati siano di tipo numerico o non numerico. Se si prova ad aggiungere più volte lo stesso campo, ad esempio alle aree Etichette di riga ed Etichette di colonna nella sezione layout, il campo viene automaticamente rimosso dall'area originale e posizionato nella nuova area.
  • Un altro modo per aggiungere lo stesso campo all'area Valori consiste nell'uso di una formula (detta anche campo calcolato) in cui viene usato lo stesso campo.

Filtrare i dati prima di aggiungere campi

  • Nell'elenco campi della tabella pivot, nella casella Scegli campi da aggiungere al report , posizionare il puntatore del mouse sul nome di un campo e quindi fare clic sulla freccia a discesa del filtro accanto al nome del campo.
    Nel menu Filtro selezionare le opzioni di filtro desiderate.

Ridisporre i campi nella tabella pivot o nel grafico pivot

Nell'elenco campi della tabella pivot è possibile ridisporre o riposizionare i campi esistenti usando una delle quattro aree nella parte inferiore della sezione layout:

Tabella pivot Descrizione
Valori Usare per visualizzare dati numerici di riepilogo.
Etichette di riga Usare per visualizzare dati numerici di riepilogo.
Etichette di colonna Usare per visualizzare i campi come colonne nella parte superiore del rapporto. Una colonna in una posizione inferiore viene annidata all'interno di un'altra colonna immediatamente superiore.
Filtro rapporto Usare per filtrare l'intero rapporto in base all'elemento selezionato nel filtro per il rapporto.
Grafico pivot Descrizione
Valori Usare per visualizzare dati numerici di riepilogo.
Campo Asse (categorie) Usare per visualizzare i campi come un asse nel grafico.
Campi legenda (serie) Usare per visualizzare i campi nella legenda del grafico.
Filtro rapporto Usare per filtrare l'intero rapporto in base all'elemento selezionato nel filtro per il rapporto.

Per ridisporre i campi in una tabella pivot, fare clic sul nome del campo in una delle aree e quindi selezionare uno dei comandi seguenti:

   
Sposta su Sposta il campo una posizione più in alto nell'area.
Sposta giù Sposta il campo una posizione più in basso nell'area.
Sposta all'inizio Sposta il campo all'inizio dell'area.
Sposta alla fine Sposta il campo alla fine dell'area.
Sposta nel filtro per il rapporto Sposta il campo nell'area Filtro rapporto.
Sposta nelle etichette di riga Sposta il campo nell'area Etichette di riga.
Sposta nelle etichette di colonna Sposta il campo nell'area Etichette di colonna.
Sposta nei valori Sposta il campo nell'area Valori.
Impostazioni campo valore, Impostazioni campo Visualizza la finestra di dialogo Impostazioni campo o Impostazioni campo valore . Per altre informazioni su ogni impostazione, fare clic sull'icona del pulsante Guida nella parte superiore della finestra di dialogo.

Suggerimento È anche possibile fare clic e tenere premuto il pulsante del mouse su un nome di campo e quindi trascinare il campo tra le sezioni campo e layout e tra le diverse aree.

Rimuovere campi dalla tabella pivot o dal grafico pivot

Per rimuovere un campo, nell'elenco campi della tabella pivot eseguire una delle operazioni seguenti:

  • Nella casella Scegliere i campi da aggiungere al report deselezionare la casella di controllo del campo che si desidera rimuovere.
    Avvertenza Se si deseleziona una casella di controllo, verranno rimosse dal rapporto tutte le istanze del campo.
  • In un'area layout fare clic sul campo che si desidera rimuovere e quindi su Rimuovi campo.
  • In un'area layout fare clic e tenere premuto il pulsante del mouse sul campo che si desidera rimuovere e quindi trascinarlo al di fuori dell'elenco campi della tabella pivot.

Passare dall'aggiornamento automatico a quello manuale del layout del report

Per impostazione predefinita, le modifiche apportate nell'elenco campi della tabella pivot vengono aggiornate automaticamente nel layout del rapporto. Per migliorare le prestazioni quando si accede a una grande quantità di dati esterni, è possibile passare temporaneamente alla modalità di aggiornamento manuale. La modalità di aggiornamento manuale consente di aggiungere, spostare e rimuovere rapidamente campi nell'elenco campi della tabella pivot. Tuttavia, non puoi usare il report finché non torni in modalità di aggiornamento automatico.

  1. Per abilitare l'aggiornamento manuale della tabella pivot, selezionare la casella di controllo Rinvia aggiornamento layout nella parte inferiore dell'elenco campi della tabella pivot.
    Attenzione Dopo aver impostato il layout del rapporto su aggiornamento manuale, chiudendo l'elenco campi della tabella pivot o passando alla visualizzazione Solo campi o uscendo da Excel, tutte le modifiche apportate al layout della tabella pivot verranno ignorate senza conferma.
  2. Nell'elenco campi della tabella pivot apportare le modifiche al layout dei campi e quindi fare clic su Aggiorna per aggiornare manualmente il layout nella tabella pivot.
  3. Per ripristinare l'aggiornamento automatico dopo aver modificato il layout del report nell'elenco dei campi, deselezionare la casella di controllo Rinvia aggiornamento layout .

Avvertenza Una tabella pivot inizia con l'aggiornamento automatico ogni volta che si apre la cartella di lavoro.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto della Tech Community di Excel o ottenere supporto nelle Community.

Vedere anche

Creare una tabella pivot

Usare l'Elenco campi per disporre i campi in una tabella pivot

Creare un grafico pivot

Usare i filtri dei dati per filtrare i dati

Creare la sequenza temporale di una tabella pivot per filtrare le date