FAST Search Server 2010’s Content Distributor may fail to start

Symptoms

FAST Search Server 2010’s Content Distributor may fail to start, and the following errors can be found in the %FASTSearch%\var\log\syslog\all.log log file:

[2010-05-11 16:35:56] INFO      : nodecontroller@fastsearchtest:13260: systemmsg: Starting contentdistributor

[2010-05-11 16:35:56] ERROR     : contentdistributor@fastsearchtest.red.contoso.com:13391:syystemmsgsystemmsg: Failed to initialize content distributor: Failed to contact config server. No collection cache file found.

[2010-05-11 16:35:56] INFO      : contentdistributor@fastsearchtest.red.contoso.com:13391: systemmsg: Shutdown completed (PID: 3900)

[2010-05-11 16:35:57] ERROR     : nodecontroller@fastsearchtest:13260: systemmsg: Process contentdistributor terminated shortly after starting

Cause

The content distributor can fail due to an internal Proxy server setting preventing communications from being properly established. Note: the Windows operating system’s underlying WinHTTP proxy settings are not the same settings used by Internet Explorer.

To verify the Proxy is causing the issue. Run the following

netsh winhttp show proxy

Review the output, for example:
C:\Windows\system32>netsh winhttp show proxy
Current WinHTTP proxy settings:
    Direct access (no proxy server).

In a failing system it might show the following:
 
C:\Windows\System32>netsh winhttp show proxy
Current WinHTTP proxy settings:
  Proxy Server(s) : yourproxy.contoso.com
    Bypass List     :  https://corprights.contoso.com;STMPSSCOMR2-A;<local>

Resolution

The FAST Search Server Administrator can reset WinHTTP’s proxy settings by issuing the following command from an elevated command prompt:

netsh winhttp reset proxy

To remove the proxy:

netsh winhttp set proxy yourproxy.contoso.com bypass-list="https://corprights.contoso.com;TSTMPSSCOMR2-A;*.contoso.com;<local>"
Proprietà

ID articolo: 2028987 - Ultima revisione: 28 dic 2012 - Revisione: 1

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