Non termina il programma RemoteApp scadere il limite di tempo di inattività della sessione in un computer che esegue Windows Server 2008 R2

Sintomi

Si consideri lo scenario seguente:
  • Si dispone di un computer che esegue Windows Server 2008 R2.
  • Si aggiunge il computer a un dominio.
  • Installare i servizi ruolo Servizi Desktop remoto del computer.
  • Attivare le seguenti impostazioni di criteri di gruppo nel dominio:
    Computer Configurazione computer\Modelli amministrativi\Componenti Windows\Servizi Desktop remoto\Host Desktop sessione Host\Session tempo Limits\Set tempo limite per le sessioni di Servizi Desktop remoto attive ma in attesa

    Sessione di Configurazione computer\Modelli amministrativi\Componenti Windows\Servizi Desktop remoto\Host Desktop sessione Host\Session tempo Limits\Terminate computer quando si raggiungono i limiti di tempo
  • L'impostazione Limite sessione inattiva è impostata su un valore maggiore o uguale a cinque minuti. Il limite sessione inattiva è l'impostazione Imposta limite di tempo per sessione di Servizi Desktop remoto attiva ma in attesa .
  • Applicare le impostazioni di criteri di gruppo al computer.
  • Si esegue un programma RemoteApp per avviare una sessione di Servizi Desktop remoto del computer.
  • La sessione è inattiva per un periodo di tempo che supera il limite di tempo di inattività della sessione.
  • Nella sessione di Servizi Desktop remoto dopo la sessione è inattiva per un periodo di tempo che supera il limite di tempo di inattività della sessione è stato visualizzato il seguente messaggio:
    Sessione è rimasta inattiva superato il limite di tempo. Verrà terminata in 2 minuti. Premere un tasto per continuare la sessione.

In questo scenario, il programma RemoteApp non termina dopo la sessione rimane inattiva per ulteriori due minuti.

Causa

Questo problema si verifica perché i Servizi Desktop remoto gestisce erroneamente alcuni messaggi e gli eventi generati automaticamente come input dell'utente. Pertanto, i Servizi Desktop remoto non viene terminato il programma RemoteApp.

Nota: Questi eventi venga generato automaticamente e i messaggi dall'utilità di connessione Desktop remoto.

Risoluzione

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:Nota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, è necessario eseguire Windows Server 2008 R2. Inoltre, i servizi ruolo Servizi Desktop remoto devono essere installati.

Informazioni del Registro di sistema

Per utilizzare l'hotfix in questo pacchetto, non è necessario apportare modifiche al Registro di sistema.

Richiesta di riavvio

Potrebbe essere necessario riavviare il computer dopo avere applicato questo hotfix.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.

Informazioni sui file

La versione inglese (Stati Uniti) di questo hotfix consente di installare file con gli attributi elencati nelle tabelle seguenti. Le date e ore per questi file sono elencate nel tempo universale coordinato (UTC). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale (DST). Inoltre, le date e gli orari possono cambiare quando si eseguono determinate operazioni sui file.
Note di informazioni file di Windows Server 2008 R2
Importante Aggiornamenti rapidi di Windows 7 e aggiornamenti rapidi di Windows Server 2008 R2 sono inclusi nel pacchetto stesso. Tuttavia, gli aggiornamenti rapidi nella pagina richiesta Hotfix sono elencati in entrambi i sistemi operativi. Per richiedere il pacchetto di hotfix che si applica a uno o entrambi i sistemi operativi, selezionare l'hotfix elencato nella pagina in "Windows 7 e Windows Server 2008 R2". Fare sempre riferimento alla sezione "Si applica a" negli articoli per determinare il sistema operativo effettivo a cui si applica ogni aggiornamento rapido .
  • I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono elencati separatamente nella sezione "Ulteriori informazioni sui file per Windows Server 2008 R2". MUM e file MANIFEST e i file di catalogo (CAT) di protezione associato, sono estremamente importanti per mantenere lo stato dei componenti aggiornati. I file catalogo di protezione elencati senza attributi sono firmati con firma digitale Microsoft.
Per tutte le versioni basate su x64 supportate di Windows Server 2008 R2
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Termsrv.dll6.1.7600.20757711,68017-Jul-201008:06x64

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Ulteriori informazioni sui file

Ulteriori informazioni sui file per Windows Server 2008 R2

File aggiuntivi per tutte le versioni basate su x64 supportate di Windows Server 2008 R2
Nome del fileAmd64_microsoft-windows-t..teconnectionmanager_31bf3856ad364e35_6.1.7600.20757_none_eb40464486f89423.manifest
Versione del fileNon applicabile
Dimensione del file29,203
Data (UTC)17-Jul-2010
Ora (UTC)08:52
PiattaformaNon applicabile
Nome del fileUpdate.mum
Versione del fileNon applicabile
Dimensione del file24,725
Data (UTC)17-Jul-2010
Ora (UTC)14:45
PiattaformaNon applicabile
Nome del fileWow64_microsoft-windows-t..teconnectionmanager_31bf3856ad364e35_6.1.7600.20757_none_f594f096bb59561e.manifest
Versione del fileNon applicabile
Dimensione del file10,688
Data (UTC)17-Jul-2010
Ora (UTC)07:59
PiattaformaNon applicabile
Proprietà

ID articolo: 2287493 - Ultima revisione: 29 gen 2017 - Revisione: 1

Feedback