Errore "il nome sul certificato di protezione non è valido o non corrisponde al nome del sito" in Outlook in un oggetto dedicato o ambiente ITAR Office 365

Si applica a: Microsoft Business Productivity Online DedicatedMicrosoft Business Productivity Online Suite Federal

Sintomi


In un oggetto dedicato o traffico internazionale in ambiente armi regolamentari (ITAR) Microsoft Office 365, un utente viene richiesto da una finestra di dialogo Avviso di protezione che include il seguente messaggio di errore: 
Il nome sul certificato di protezione non è valido o non corrisponde al nome del sito.
Ad esempio, la finestra di dialogo Avviso di protezione simile al seguente:Questo problema può verificarsi nelle seguenti circostanze:
  • L'utente tenta di creare un nuovo profilo in Microsoft Office Outlook.
  • L'utente tenta di avviare un client di Outlook.
  • Il problema si verifica in modo intermittente quando il client di Outlook è in fase di esecuzione.
Se si sceglie , l'utente può continuare l'operazione. Tuttavia, se si sceglie No, ricerca individuazione automatica ha esito negativo. La mancata ricerca individuazione automatica impedisce le seguenti funzionalità di funzionamento come previsto:
  • Creazione automatica di un profilo di Outlook utilizzando l'individuazione automatica
  • Fuori sede (OOF)
  • Informazioni disponibilità

Causa


In genere, questo problema si verifica quando l'URL che si sta tentando di accedere non è presente nell'oggetto o il nome alternativo soggetto (SAN) del certificato Secure Sockets Layer (SSL) per il sito Web. Sebbene le configurazioni di organizzazioni diverse possono differire leggermente, questo problema si verifica in genere perché il record di individuazione automatica del sistema DNS (Nome Dominio) dell'organizzazione non è configurato correttamente.

Risoluzione


Per risolvere questo problema, potrebbe essere necessario modificare i record DNS di Autodiscover (interni, esterni o entrambi). Tuttavia, tali modifiche non dovrebbero essere prese cura, poiché la funzionalità di individuazione automatica potrebbe non funzionare se i record DNS sono configurati correttamente.Prima di modificare i record DNS di Autodiscover, è necessario comprendere come il client Outlook tenta di individuare il servizio Autodiscover. Il client Outlook tenta di individuare il servizio di individuazione automatica utilizzando il seguente ordine fondamentale delle operazioni. Tuttavia, il passaggio in cui si trova il servizio di individuazione automatica varia da una distribuzione di distribuzione. Questa posizione dipende dal fatto che una soluzione locale in coesistenza e cosa specifici on-premise e-mail ambiente (ad esempio, un di Microsoft Exchange Server locale, un locale di Lotus Notes o un altro ambiente).Nella tabella seguente viene visualizzato l'ordine fondamentale delle operazioni per modalità di individuazione del servizio di individuazione automatica del client di Outlook:
1
  1. L'oggetto punto di connessione del servizio (SCP) - le connessioni interne.
  2. Client Outlook tenta di individuare un Record per l'URL restituito dall'oggetto SCP.
2
  1. Dominio SMTP dell'utente. (Ad esempio, https://proseware.com)
  2. Client Outlook tenta di individuare un Record per dominio SMTP dell'utente.
3
  1. Il dominio SMTP dell'utente è preceduto da individuazione automatica. (Ad esempio, https://autodiscover.proseware.com)
  2. Client Outlook tenta di individuare un Record per l'URL che viene aggiunto con individuazione automatica.
4
  1. Outlook client tenta di individuare i server DNS del servizio (SRV) per il servizio di individuazione automatica nella zona DNS corrispondente al dominio SMTP dell'utente. (Ad esempio, _autodiscover._tcp.proseware.com)
  2. Il record SRV restituisce quindi un altro URL, per cui deve essere presente un qualche tipo di record risolvibile, ad esempio un record o un record CNAME.
5 Risultato Se il servizio di individuazione automatica non viene trovato da uno di questi metodi, l'individuazione automatica ha esito negativo.
In sintesi, il servizio di individuazione automatica può essere risolto mediante l'utilizzo di un record, un record CNAME o un record SRV. Per determinare quali record vengono utilizzati attualmente, eseguire i seguenti comandi al prompt dei comandi o in Windows PowerShell:
  1. Per individuare un record, eseguire i seguenti comandi. Assicurarsi che SMTPDomain.com di sotto si sostituire con il dominio con il valore all'inizio dell'errore del certificato.
nslookup 
set type=A 
Autodiscover.SMTPDomain.com 
  1. Per individuare un record SRV, eseguire i seguenti comandi:
nslookup 
set type=SRV 
_autodiscover._tcp.SMTPDomain.com 
Nell'esempio seguente, il client di Outlook è possibile individuare il servizio di individuazione automatica tramite il record per l'URL di individuazione automatica, come descritto nel passaggio 3 nella tabella precedente: 
autodiscover.proseware.com
Tuttavia, come indicato nella sezione "Cause", questo URL non è elencato nella SAN del certificato SSL utilizzato dal servizio di individuazione automatica. Ad esempio, vedere la seguente schermata riportata di seguito:Per risolvere questo problema, utilizzare il metodo seguente. 

Sostituire il record esistente utilizzando un record SRV che punta a uno spazio dei nomi è già nella rete SAN del certificato SSL

Questo è il metodo di risoluzione preferita nella struttura del servizio corrente perché il certificato SSL esistente non devono essere aggiornati e distribuiti. In base all'ordine fondamentale delle operazioni elencate in precedenza in questa sezione, l'organizzazione può implementare il nuovo record utilizzando un metodo controllato e testato per evitare interruzioni del servizio di individuazione automatica.Per risolvere il problema, attenersi alla seguente procedura:
  1. Creare un nuovo record SRV. Deve essere creato il record SRV nella zona DNS corrispondente al dominio SMTP dell'utente. Il record SRV deve avere le seguenti proprietà:
    • Servizio: _autodiscover
    • Protocollo: TCP
    • Porta: 443
    • Ospite: L'URL per il reindirizzamento. Questo URL potrebbe essere l'URL di Outlook Web Access (OWA) perché la risoluzione IP deve corrispondere al servizio di individuazione automatica. Inoltre, questa può variare da una distribuzione di distribuzione.
  2. Prima di rimuovere il record esistente, è opportuno sottoporre il nuovo record SRV modificando il file host dell'utente per reindirizzare corrente un record per un IP non valido. Questo test è possibile verificare che il nuovo record SRV funziona come previsto prima di distribuire i nuovi record DNS a tutta l'organizzazione. Nota Quando il record SRV è utilizzato da un client di Outlook, l'utente venga visualizzato il seguente messaggio che informa l'utente che sta per verificarsi il reindirizzamento di. È consigliabile che l'utente seleziona la casella di controllo non visualizzare più informazioni su questo sito Web nuovo in modo che non viene nuovamente visualizzato il messaggio.  
  3. Quando il record SRV funziona come previsto, è possibile rimuovere il record dal DNS esistente.

Ulteriori informazioni


Per ulteriori informazioni sul servizio di individuazione automatica, visitare il seguente sito Web Microsoft TechNet: