Distribuzione non riesce durante la distribuzione di Enterprise Portal per Microsoft Dynamics AX 2012 R2

In questo articolo si applica a Microsoft Dynamics AX per tutte le regioni.

Sintomi

Quando si distribuisce Enterprise Portal per Microsoft Dynamics AX 2012 R2 in un ambiente che è la rappresentazione di ASP.NET e il basata sulle attestazioni attivata l'autenticazione, la distribuzione avrà esito negativo. Inoltre, viene visualizzato il seguente messaggio di errore:
Microsoft.Dynamics.Framework.BusinessConnector.Session.Exceptions.NoKernelSessionException

Causa

Questo problema si verifica perché Microsoft prodotti e tecnologie SharePoint non possono rappresentare l'account proxy di Microsoft .NET Business Connector (BC) o un account registrato in Microsoft Dynamics AX. Per impostazione predefinita, il processo di lavoro di SharePoint viene eseguito come account utente NT Authority\IUSR quando è attivata l'autenticazione basata sulle attestazioni. Inoltre, l'applicazione web di SharePoint è le seguenti impostazioni di configurazione nel file Web. config:
AllowAnonymousImpersonation = True
Di conseguenza, il server oggetti applicativi di Microsoft Dynamics AX (AOS) rifiuta la richiesta per accedere all'AOS.

Risoluzione

Per risolvere questo problema, installare l'hotfix descritto nella sezione "Informazioni sull'aggiornamento rapido". Inoltre, è necessario distribuire siti Enterprise Portal basata sulle attestazioni che utilizzano l'autenticazione basata su form come descritto nel seguente sito Web Microsoft:

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. È una "download dell'Hotfix disponibile" nella parte superiore di questo articolo della Knowledge Base. Se si è verificato un problema il download, installare questa correzione, o hanno altre domande di supporto tecnico, contattare il partner o, se iscritto un piano di supporto direttamente con Microsoft, è possibile contattare il supporto tecnico per Microsoft Dynamics e creare una nuova richiesta di supporto. A tale scopo, visitare il seguente sito Web Microsoft:È inoltre possibile contattare il supporto tecnico per Microsoft Dynamics tramite telefono utilizzando questi collegamenti per i numeri di telefono specifico paese. A tale scopo, passare a uno dei seguenti siti Web Microsoft:

PartnerClientiIn casi particolari, le spese normalmente addebitate per le chiamate potrebbero essere annullate qualora un aggiornamento del supporto tecnico di Microsoft Dynamics e prodotti correlati di supporto determina che uno specifico aggiornamento risolverà il problema. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

Informazioni sull'installazione

In caso di personalizzazioni per uno o più dei metodi o le tabelle interessate da questo hotfix, è necessario applicare queste modifiche in un ambiente di test prima di applicare l'hotfix descritto in un ambiente di produzione.

Per ulteriori informazioni su come installare questo hotfix, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:
893082 come installare un hotfix Microsoft Dynamics AX

Prerequisiti

È necessario avere installato questo hotfix di Microsoft Dynamics AX 2012 R2.

Richiesta di riavvio

Dopo avere applicato l'hotfix, è necessario riavviare il servizio Server oggetti applicativi (AOS).
Informazioni sui file

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".
Nota: Si tratta di un articolo a "Pubblicazione Veloce" creato direttamente all'interno dell'organizzazione di supporto Microsoft. Le informazioni contenute nel presente documento sono fornite così come sono in risposta a problemi urgenti. Per la velocità in rendendo disponibili, i materiali possono includere errori tipografici e possono essere modificati in qualsiasi momento senza preavviso. Per altre considerazioni, vedere Condizioni di utilizzo .
Proprietà

ID articolo: 2824690 - Ultima revisione: 18 feb 2017 - Revisione: 3

Microsoft Dynamics AX 2012 R2, Enterprise Portal Framework

Feedback