Ripristino immagini di sistema non riesce con un errore di 0x80070002

Questo articolo descrive un problema di ripristino delle immagini di sistema che si verifica in Windows 8.1 quando si tenta di eseguire il ripristino da un backup archiviato in una partizione nel disco di sistema. Viene fornita una soluzione al problema.

Si applica a: Windows 8.1
Numero KB originale: 2989057

Sintomi

Considerare lo scenario descritto di seguito:

  • Si sta eseguendo Windows 8.1 e l'aggiornamento Windows 8.1 (KB2919355) è installato.
  • È stato eseguito un backup dell'immagine di sistema e l'è stato salvato in una partizione nello stesso disco dell'unità C.
  • La partizione in cui è stato salvato il backup è molto più piccola dell'unità C.

Quando si tenta di eseguire il ripristino dal backup usando Ripristino immagini di sistema, ha esito negativo e restituisce l'errore seguente:

Ripristino dell'immagine di sistema non riuscito.
Dettagli dell'errore: il sistema non riesce a trovare il file specificato. (0x80070002)

Inoltre, non è possibile avviare Windows dopo questo errore.

Causa

L'errore si verifica perché l'immagine di backup viene smontata prematuramente durante il processo di ripristino.

Soluzione alternativa

Quando si avvia il sistema dopo questo errore, in genere passa alla modalità ripristino automatico. Tuttavia, questo processo ha esito negativo. Per eseguire il ripristino, seguire questa procedura:

  1. Fare clic su Opzioni avanzate.

  2. In Scegliere un'opzione fare clic su Risoluzione dei problemi, scegliere Opzioni avanzate e quindi fare clic su Prompt dei comandi.

  3. Usando DISKPART, individuare il volume in cui è stato installato il sistema operativo. Dopo il problema, il volume verrà riconosciuto come volume RAW (unità C nell'esempio seguente).

    X:\Windows\System32>diskpart
    
    Microsoft DiskPart version 6.3.9600
    
    Copyright (C) 1999-2013 Microsoft Corporation.
    On computer: MININT-NS2UFF8
    
    DISKPART> list volume
    
     Volume ###  Ltr Label       Fs    Type        Size   Status    Info
     ---------- --- ----------- ----- ---------- ------- --------- --------
     Volume 0 E DVD-ROM 0 B No Media
     Volume 1 C RAW Partition 2970 GB Healthy
     Volume 2 D New Volume NTFS Partition 29 GB Healthy
     Volume 3 Recovery NTFS Partition 300 MB Healthy Hidden
    
    

    Nota

    Le lettere di unità possono differire nell'installazione di Windows.

  4. Formattare il volume RAW:

    DISKPART> select volume 1
    
    Volume 1 is the selected volume.
    
    DISKPART> format fs=NTFS quick
    
    100 percent completed
    
  5. Uscire da DISKPART e quindi chiudere il prompt dei comandi:

    DISKPART> exit
    
    Leaving DiskPart...
    
  6. In Scegliere un'opzione fare clic su Risoluzione dei problemi, fare clic su Opzioni avanzate e quindi su Ripristino immagini di sistema.

  7. Per completare il ripristino dal backup salvato, seguire la procedura descritta nella Procedura guidata Riprotezione guidata computer.

Stato

Microsoft ha confermato che questo problema si verifica nei prodotti elencati nella sezione "Si applica a".

Microsoft rilascia regolarmente aggiornamenti software per risolvere bug specifici. Se Microsoft rilascia un aggiornamento software per risolvere questo bug, questo articolo verrà aggiornato con informazioni aggiuntive.