Problemi di connessione di Outlook con le cassette postali di Exchange causati dai requisiti di crittografia RPC

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L'articolo si applica solo ai problemi di connessione di Microsoft Outlook causati dai requisiti di crittografia RPC.

Screenshot relativo all'opzione di crittografia R P C.

Sintomi

Quando si avvia Microsoft Office Outlook utilizzando un profilo che include una cassetta postale su un server che esegue Microsoft Exchange Server 2010, Exchange Server 2013 o Exchange Server 2016, è possibile che vengano visualizzati i messaggi di errore seguenti:

Impossibile avviare Microsoft Office Outlook. Impossibile aprire la finestra di Outlook. Impossibile aprire il gruppo di cartelle.

Impossibile aprire le cartelle di posta elettronica predefinite. Il computer che esegue Microsoft Exchange Server non è disponibile. È possibile che vi siano problemi di rete o che il computer che esegue Microsoft Exchange Server sia inattivo per manutenzione.

La connessione a Microsoft Exchange Server non è disponibile. Per completare questa azione, Outlook deve essere online o connesso.

Impossibile aprire le cartelle di posta elettronica predefinite. Impossibile aprire l'archivio informazioni.

Outlook non ha potuto accedere. Verificare di essere connessi alla rete e il nome del server e della cassetta postale. La connessione a Microsoft Exchange Server non è disponibile. Per completare questa azione, Outlook deve essere online o connesso.

Tuttavia, se si utilizza un profilo in modalità cache, Outlook non visualizza alcun errore. È possibile che si verifichi uno qualsiasi dei seguenti sintomi:

  • Outlook si avvia nello stato Disconnesso. Nell'angolo inferiore destro della finestra di Outlook viene visualizzato "Disconnesso", vedere lo screenshot dello stato visualizzato di seguito.

    Screenshot dell'errore nell'angolo inferiore destro della finestra di Outlook.

  • Outlook si avvia ed è possibile inviare e ricevere messaggi di posta elettronica. Tuttavia, vengono visualizzate solo due connessioni all'interno di "Stato di connessione di Microsoft Exchange" e lo stato di Tipo/Directory potrebbe risultare come Disconnesso/Connessione in corso.

    Screenshot di questo sintomo.

Durante il tentativo di creazione di un nuovo profilo Outlook per una cassetta postale su un server che esegue Exchange 2010 o Exchange Server 2013, è possibile che vengano visualizzati i seguenti messaggi di errore:

Impossibile completare l'operazione. La connessione a Microsoft Exchange Server non è disponibile. Per completare questa azione, Outlook deve essere online o connesso.

Impossibile risolvere il nome. La connessione a Microsoft Exchange Server non è disponibile. Per completare questa azione, Outlook deve essere online o connesso.

Outlook non ha potuto accedere. Verificare di essere connessi alla rete e il nome del server e della cassetta postale. La connessione a Microsoft Exchange Server non è disponibile. Per completare questa azione, Outlook deve essere online o connesso.

Impossibile risolvere il nome. Impossibile completare l'operazione.

Impossibile risolvere i nomi del server o della cassetta postale.

Risoluzione

Nota

Se si utilizza uno dei metodi automatizzati (Criteri di gruppo o un file prf), verificare completamente il metodo prima di distribuirlo su larga scala.

Metodo 1: aggiornare o creare il profilo Outlook con crittografia RPC

Aggiornare manualmente un profilo esistente

Per aggiornare manualmente un profilo Outlook esistente in modo che utilizzi la crittografia RPC, attenersi alla seguente procedura:

  1. Nel Pannello di controllo aprire l'elemento Posta elettronica.

  2. Selezionare Mostra profili.

  3. Selezionare il profilo in uso, quindi fare clic su Proprietà.

  4. Fare clic su Account di posta elettronica.

  5. Selezionare account Microsoft Exchange (invio da questo account per impostazione predefinita)>Modifica.

  6. Nella finestra di dialogo che contiene il server cassette postali e il nome utente, selezionare Altre impostazioni.

  7. Nella finestra di dialogo Microsoft Exchange, scegliere la scheda Sicurezza.

  8. Selezionare Crittografa i dati tra Microsoft Office Outlook e Microsoft Exchange>OK. Lo screenshot di questo passaggio è visualizzato qui di seguito.

    Screenshot con selezionato Crittografa i dati tra Microsoft Office Outlook e Microsoft Exchange.

  9. Selezionare Avanti>Fine.

  10. Selezionare Chiudi>Chiudi>OK.

Distribuire un'impostazione di Criteri di gruppo per aggiornare i profili Outlook esistenti con la crittografia RPC

Dalla prospettiva del client, la distribuzione dell'impostazione di crittografia per Outlook-Exchange è probabilmente la soluzione più semplice per le organizzazioni con numerosi client Outlook. Questa soluzione implica una singola modifica su un server (controller di dominio) e i client vengono aggiornati automaticamente dopo il download del criterio nel client.

Outlook 2010

Per impostazione predefinita, l'impostazione di crittografia RPC è abilitata in Outlook 2010. È consigliabile distribuire questa impostazione utilizzando Criteri di gruppo solo per uno dei motivi seguenti:

  • La distribuzione originale di Outlook 2010 ha disabilitato la crittografia RPC tra Outlook ed Exchange.
  • Si desidera impedire agli utenti di modificare l'impostazione di crittografia RPC nel profilo Outlook.

Il modello Criteri di gruppo predefinito per Outlook 2010 contiene l'impostazione di Criteri di gruppo che controlla la crittografia RPC di Outlook-Exchange. Per aggiornare i profili Outlook 2010 esistenti utilizzando Criteri di gruppo, attenersi alla seguente procedura:

  1. Scaricare la versione più recente del modello Criteri di gruppo Outlk14.adm.

  2. Aggiungere il file con estensione adm al controller di dominio.

    Nota

    La procedura per aggiungere il file con estensione adm a un controller di dominio varia in base alla versione di Windows in esecuzione. Inoltre, poiché il criterio può essere applicato a un'unità organizzativa e non al dominio, i passaggi possono variare anche per l'aspetto relativo all'applicazione dei criteri. Per informazioni dettagliate, consultare la documentazione di Windows.

    Andare al passaggio 3 dopo aver aggiunto il modello adm all'Editor Criteri di gruppo locali.

  3. In Configurazione utente, espandere Modelli amministrativi (ADM) per individuare il nodo di criteri per il modello. Utilizzando il modello Outlk14.adm, il nodo verrà denominato Microsoft Outlook 2010.

  4. In Impostazioni account, selezionare il nodo Exchange. Di seguito è possibile visualizzare uno screenshot di questo passaggio.

    Screenshot con il nodo Exchange di Outlook 2010 selezionato.

  5. Fare doppio clic sull'impostazione criterio Attivazione crittografia RPC.

  6. Nella scheda Impostazione selezionare Abilitato.

  7. Selezionare OK.

A questo punto l'impostazione criterio verrà applicata sulle workstation con client Outlook quando viene replicato l'aggiornamento di Criteri di gruppo. Per testare la modifica, eseguire il comando seguente:

 gpupdate /force

Dopo aver eseguito il comando, avviare l'editor del Registro di sistema sulla workstation per verificare che nel client siano presenti i dati del Registro di sistema seguenti:

Key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\RPC
DWORD: EnableRPCEncryption
Value: 1

Se è possibile visualizzare tali dati del Registro di sistema nel registro, l'impostazione di Criteri di gruppo è stata applicata correttamente al client. Avviare Outlook per verificare se la modifica ha risolto il problema.

Outlook 2013

Per impostazione predefinita, l'impostazione di crittografia RPC è abilitata in Outlook 2013. È consigliabile distribuire questa impostazione utilizzando Criteri di gruppo solo per uno dei motivi seguenti:

  • La distribuzione originale di Outlook 2013 ha disabilitato la crittografia RPC tra Outlook ed Exchange.
  • Si desidera impedire agli utenti di modificare l'impostazione di crittografia RPC nel profilo Outlook.

Il modello Criteri di gruppo predefinito per Outlook 2013 contiene l'impostazione di Criteri di gruppo che controlla la crittografia RPC di Outlook-Exchange. Per aggiornare i profili Outlook 2013 esistenti utilizzando Criteri di gruppo, attenersi alla seguente procedura:

  1. Scaricare i modelli ADM di Office 2013.

  2. Aggiungere i file con estensione admx e adml al controller di dominio. Verrà aggiunto il modello ADM di Outlook per renderlo disponibile nell'Editor Criteri di gruppo locali.

    Nota

    La procedura per aggiungere i file con estensione admx e adml a un controller di dominio varia in base alla versione di Windows in esecuzione. Inoltre, poiché il criterio può essere applicato a un'unità organizzativa e non al dominio, i passaggi possono variare anche per l'aspetto relativo all'applicazione dei criteri. Per informazioni dettagliate, consultare la documentazione di Windows. (Questo articolo è stato redatto per Office 2010. Tuttavia, si applica anche a Office 2013.)

  3. Avviare l'Editor Criteri di gruppo locali.

  4. In Configurazione utente, espandere Modelli amministrativi (ADM) per individuare il nodo di criteri per il modello. Quando si utilizza il modello Outlk15.admx, il nodo verrà denominato Microsoft Outlook 2013.

  5. In Impostazioni account, selezionare il nodo Exchange. Di seguito è possibile visualizzare uno screenshot di questo passaggio.

    Screenshot con il nodo Exchange di Outlook 2013 selezionato.

  6. Fare doppio clic sull'impostazione criterio Attivazione crittografia RPC.

  7. Nella scheda Impostazione selezionare Abilitato.

  8. Selezionare OK.

A questo punto l'impostazione criterio verrà applicata sulle workstation con client Outlook quando viene replicato l'aggiornamento di Criteri di gruppo. Per testare la modifica, eseguire il comando seguente su una workstation:

 gpupdate /force

Dopo aver eseguito il comando, avviare l'editor del Registro di sistema sulla workstation per verificare che nel client siano presenti i dati del Registro di sistema seguenti:

Key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\Outlook\RPC
 DWORD: EnableRPCEncryption
 Value: 1

Se è possibile visualizzare tali dati del Registro di sistema nel registro, l'impostazione di Criteri di gruppo è stata applicata correttamente al client. Avviare Outlook per verificare se la modifica ha risolto il problema.

Metodo 2: disabilitare i requisiti di crittografia su tutti i server CAS

Importante

Microsoft consiglia di lasciare abilitati i requisiti di crittografia sul server e di utilizzare uno degli altri metodi elencati in questo articolo. Il metodo 2 viene fornito in questo articolo solo per le situazioni in cui non è possibile distribuire immediatamente le impostazioni di crittografia RPC necessarie sui client Outlook. Se si utilizza il metodo 2 per consentire ai client Outlook di connettersi senza la crittografia RPC, riabilitare i requisiti di crittografia RPC sui server CAS il più rapidamente possibile per mantenere il massimo livello di comunicazione da client a server.

Per disabilitare la crittografia necessaria tra Outlook ed Exchange, attenersi alla seguente procedura:

  1. Eseguire il comando riportato di seguito in Exchange Management Shell:

     Set-RpcClientAccess -Server <Exchange server name> -EncryptionRequired:$False
    

    Nota

    Il segnaposto Exchange_server_name rappresenta il nome di un Exchange Server con ruolo di server Accesso client.

    È necessario eseguire questo cmdlet per tutti i server Accesso client che eseguono Exchange Server 2010 o versione successiva.

  2. Eseguire nuovamente il comando per tutti gli Exchange server con il ruolo di server Accesso client. Il comando deve inoltre essere eseguito su ciascun ruolo del server Cassette postali contenente un Archivio delle cartelle pubbliche. Le connessioni alle cartelle pubbliche dal client MAPI passano direttamente al servizio Accesso client RPC sul server Cassette postali.

  3. Al termine dell'aggiornamento dei client Outlook con l'impostazione per abilitare la comunicazione RPC crittografata con Exchange (vedere la procedura seguente), è possibile riabilitare i requisiti di crittografia RPC sui server Exchange che hanno il ruolo di server Accesso client.

    Per riabilitare i requisiti di crittografia RPC sui server Exchange che hanno il ruolo di server Accesso client, eseguire il comando seguente in Exchange Management Shell:

     Set-RpcClientAccess -Server <Exchange server name> -EncryptionRequired:$True
    

    Nota

    Il segnaposto Exchange_server_name rappresenta il nome di un Exchange server con ruolo di server Accesso client.

    È necessario eseguire questo cmdlet per tutti i server Accesso client che eseguono Exchange Server 2010 o versione successiva.

Causa

L'errore può essere dovuto all'utilizzo di Outlook avendo disabilitato l'impostazione profilo Crittografa i dati tra Microsoft Office Outlook e Microsoft Exchange. La configurazione predefinita per Exchange Server 2013 richiede la crittografia RPC dal client Outlook. In questo modo si impedisce al client di connettersi.

Nota

La configurazione predefinita di Exchange Server 2010 Release to Manufacturing (RTM) richiede la crittografia RPC. Questo comportamento è una modifica rispetto a Exchange Server 2010 Service Pack 1 in cui i requisiti di crittografia RPC sono disabilitati per impostazione predefinita. Tuttavia qualsiasi server Accesso client (CAS) distribuito prima del Service Pack 1 o aggiornato al Service Pack 1 manterrà l'impostazione dei requisiti di crittografia RPC esistente, che potrebbe comunque impedire al client di connettersi.