Messaggi di errore quando si tenta di accedere a un volume NTFS

In questo articolo si applica a Windows 2000. Supporto per Windows 2000 termina il 13 luglio 2010. Il Centro fine del supporto di Windows 2000 è un punto di partenza per la pianificazione della strategia di migrazione da Windows 2000. Per ulteriori informazioni, vedere Microsoft Support Lifecycle Policy.

Sintomi

Quando si tenta di accedere a un volume di sistema file NTFS, venga visualizzato uno dei seguenti messaggi di errore al prompt dei comandi o in Microsoft Internet Explorer.
  • Il prompt dei comandi

    Messaggio 1
    C:\ > f:
    La struttura del disco è danneggiato e illeggibile.
    Messaggio 2
    C:\ > f:
    Non c'è spazio sufficiente sul disco.
  • Internet Explorer

    Messaggio 1
    F:\is non è accessibile.
    La struttura del disco è danneggiato e illeggibile.
    Messaggio 2
    F:\is non è accessibile.
    Non c'è spazio sufficiente sul disco.
Se il volume danneggiato è anche il volume di sistema o di avvio, si può anche ricevere il seguente messaggio di errore quando si avvia il computer (dove il secondo parametro è 0xC0000032 DISK_CORRUPTION_ERROR):
Stop 0x0000007B (0x00000000, 0xC0000032, 0x00000000, 0x00000000)
Inaccessible_boot_device
Quando si tenta di installare Windows 2000 nel volume NTFS, è che venga visualizzato il seguente messaggio:
Windows 2000 riconosce la partizione selezionata, ma la partizione è formattata o è danneggiata. Per installare Windows 2000 in questa partizione, occorre formattarla.
Se si tenta di utilizzare il comando dir per visualizzare il contenuto del volume di avvio nella console di ripristino di Windows 2000, è che venga visualizzato il seguente messaggio di errore:
Directory di F:\
Si è verificato un errore durante l'enumerazione directory.
Quando si esegue lo strumento Chkdsk sul volume, termine della routine, non vengono rilevati errori e non le correzioni vengono effettuate. Tuttavia, sarà possibile ottenere l'accesso o l'avvio dal volume e viene visualizzato il messaggio di errore. Inoltre, se si esegue il comando chkdsk
volume_drive_letter: comando della Console di ripristino per quel volume /p (dove
volume_drive_letter è la lettera dell'unità di volume), non vengono rilevati errori.

Causa

Questo problema si verifica perché il volume NTFS è un oggetto non valido o danneggiato record nel file $UsnJrnl o il file $LogFile. Entrambi questi file sono file interni utilizzati solo da NTFS. CHKDSK non verifica l'integrità di questi due file. CHKDSK garantisce solo che la tabella File Master (MFT) include voci relative a questi file e che le voci siano validi.

Risoluzione

Per risolvere questo problema se viene visualizzato un messaggio di errore "stop 0x0000007b" quando si avvia il computer, utilizzare uno dei metodi descritti di seguito.

Metodo 1

Utilizzare la Console di ripristino di Microsoft Windows Server 2003 o di Microsoft Windows XP per ripristinare il file $UsnJrnl. Windows XP e Windows Server 2003 contiene le modifiche apportate in NTFS. sys che ignora le voci nel file $UsnJrnl danneggiate e montare automaticamente e correggere i file di flusso di dati danneggiati durante l'installazione.
  1. Riavviare il computer basato su Windows 2000 per la Console di ripristino utilizzando Windows XP o un CD del sistema operativo Windows Server 2003. Assicurarsi che è stato caricato il driver di periferica di archiviazione di massa di terze parti corretto.
    Per ulteriori informazioni su come ottenere i dischi di installazione di Windows XP per riavviare la Console di ripristino, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:

    310994 come ottenere i dischi di avvio di installazione di Windows XP

  2. Fare clic su Start, scegliere Esegui, digitare Chkdsk.exe /r e quindi fare clic su OK.
  3. Riavviare il computer basato su Windows 2000.

Metodo 2

Utilizzare lo strumento Fsutil.exe dal CD di Windows XP per il diario USN di modifica/elimina:
  1. Copiare il file Fsutil.exe dal CD di Windows XP nel computer in cui si desidera eliminare le registrazioni di modifica/USN su.
  2. Fare clic su Start, scegliere Esegui, digitare cmd e quindi fare clic su OK.
  3. Passare alla directory che è stato copiato il file Fsutil.exe nel passaggio 1. Ad esempio, se è stato copiato il file Fsutil.exe nella cartella principale dell'unità C, digitare cd c:\e quindi premere INVIO.
  4. Al prompt dei comandi, digitare fsutil usn deletejournal /D LetteraUnitàe quindi premere INVIO, dove LetteraUnità corrisponde all'unità contenente il giornale di registrazione/USN di modifica che si desidera eliminare.
  5. Se si desidera creare un nuovo giornale di modifica/USN, eseguire il
    comando chkdsk /f sull'unità che è stato eliminato da giornale di registrazione.

Metodo 3

Spostare l'unità in un altro computer che esegue Windows 2000 per eseguire operazioni di ripristino.

Inoltre, è possibile utilizzare Chkdsk per reinizializzare il file $LogFile, ma non il file $UsnJrnl perché non tutti i volumi NTFS contengono un file $UsnJrnl. Viene creato un file di $UsnJrnl in un volume solo quando un programma che utilizza il file esegue la prima richiesta di scrittura.

Chkdsk solo reinizializza il file $LogFile quando si modifica la dimensione del file di log utilizzando il di chkdsk volume_drive_letter: /l:new_size /f comando. Ad esempio, se si digita chkdsk /f: /f /l:65536.

Se il problema persiste anche dopo aver modificato le dimensioni del file $LogFile, contattare il servizio supporto tecnico clienti Microsoft per ulteriori informazioni su questo problema. Per un elenco completo dei numeri di telefono servizio supporto tecnico clienti Microsoft e informazioni sui costi dell'assistenza, visitare il seguente sito Web Microsoft:

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

Se Chkdsk viene eseguito e non viene trovato alcun problema ma viene visualizzato un messaggio di errore "accesso negato" quando si tenta di accedere al volume, sono disponibili le autorizzazioni NTFS non corrette. È possibile utilizzare il comando riportato di seguito mentre si è connessi come amministratore per concedere a tutti "Controllo completo" della cartella radice e delle sottocartelle. In questo modo anche il volume sia accessibile.
c:\>cacls  volume_drive_letter :\ /g everyone:F /c /t 
Proprietà

ID articolo: 311724 - Ultima revisione: 30 gen 2017 - Revisione: 1

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