Come utilizzare l'aggiornamento guidato Visual Basic

Riepilogo

In questo articolo viene spiegato come creare una semplice applicazione Visual Basic 6.0 e quindi aggiornare l'applicazione di Visual Basic .NET o Visual Basic 2005 tramite l'aggiornamento guidato Visual Basic in Visual Studio .NET o Visual Studio 2005.

Nota: L'aggiornamento guidato Visual Basic .NET è incluso in Visual Studio .NET Professional.

Nota: L'aggiornamento guidato di Visual Basic 2005 è stato migliorato rispetto alle versioni precedenti di Visual Basic.

Requisiti

Gli elementi seguenti descrivono il hardware consigliati, software, infrastruttura di rete, competenze, conoscenze e service pack, che sarà necessario:
  • Microsoft Windows 2000 Professional o Server o Microsoft Windows XP Professional (o Server) con il.NET Framework installata
  • Microsoft Visual Basic 6.0
  • Microsoft SQL Server 7.0 o versione successiva con il database Northwind, i valori di ID utente e Password e autorizzazioni appropriate
Conoscenza necessaria:
  • Conoscenza generale di come creare applicazioni utilizzando Visual Basic 6.0

Utilizzare l'aggiornamento guidato Visual Basic

La procedura seguente viene illustrato come creare una semplice applicazione Visual Basic 6.0 e quindi eseguire l'aggiornamento all'applicazione di Visual Basic .NET o Visual Basic 2005 tramite l'aggiornamento guidato Visual Basic in Visual Studio .NET o Visual Studio 2005:
  1. Menu di avvio , scegliere programmi, scegliere Microsoft Visual Studio 6.0e quindi fare clic su Microsoft Visual Basic 6.0.
  2. Nella finestra di dialogo Nuovo progetto , fare clic su EXE Standarde quindi fare clic su Apri.
  3. Il primo modulo in questa applicazione utilizza ADO per recuperare un oggetto recordset e quindi Visualizza il recordset in un controllo Microsoft Hierarchical FlexGrid. Nel campo nome della finestra di dialogo proprietà per Form1, digitare
    frmADO.
  4. Se la casella degli strumenti non è aperto, scegliere casella degli strumentidal menu Visualizza .
  5. Dalla casella degli strumenti, posizionare un MSHFlexGrid del form in modo da occupare la maggior parte del modulo. Lasciare spazio sufficiente nella parte inferiore del form per inserire un pulsante.

    Nota: se non viene visualizzata l'icona di MSHFlexGrid nella casella degli strumenti, aggiungerlo alla casella degli strumenti. Destro della casella degli strumenti e quindi fare clic su componenti. Nella finestra di dialogo componenti , fare clic per selezionare Microsoft Hierarchical FlexGrid controllo 6.0 (OLEDB) dall'elenco dei componenti disponibili e quindi fare clic su OK.
  6. Dalla casella degli strumenti, inserire un controllo CommandButton nel form sotto il MSHFlexGrid. Nel campo didascalia della finestra di dialogo proprietà digitare OK.
  7. MADOdi mouse e quindi scegliere Visualizza codice. Aggiungere il codice seguente, che crea una connessione di database e restituisce un recordset che contiene tutti i dati della tabella Products del database Northwind.

    Nota: nell'esempio di codice seguente, è necessario modificare id utente =< nomeutente > e
    password =< password complessa > con i valori corretti. Assicurarsi che l'ID utente disponga delle autorizzazioni appropriate per eseguire questa operazione sul database.
    Private Sub Command1_Click()    Unload Me
    End Sub

    Private Sub Form_Load()
    Dim cn As Connection
    Set cn = New Connection
    cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"
    cn.Open

    Dim rs As Recordset
    Set rs = New Recordset
    rs.CursorLocation = adUseClient
    rs.Open "select * from products", cn

    Set MSHFlexGrid1.DataSource = rs
    End Sub

  8. Premere CTRL + S per salvare il modulo. Scegliere Salva con nome dal menu File . Nella finestra di dialogo Salva con nome , fare clic su Salva.
  9. In Esplora progetti destro Progetto1, fare clic su Aggiungie quindi fare clic su modulo. Fare clic su Apri.
  10. Nel campo nome della finestra di dialogo proprietà , digitare frmClipboard.
  11. Dalla casella degli strumenti, inserire un controllo Textbox nel form. Nel campo di testo , digitare passato Cantami o Diva del pelide Achille.
  12. Inserire un controllo CommandButton di sotto della casella di testo. Nel campo didascalia della finestra di dialogo proprietà , digitare Copia.
  13. Inserire un secondo controllo CommandButton nel form. Nel campo didascalia della finestra di dialogo proprietà digitare Incolla.
  14. Destro frmClipboarde quindi scegliere Visualizza codice. Incolla il seguente codice per il controllo CommandButton eventi click. Questo codice viene utilizzato negli Appunti dell'oggetto a GET e Incolla il testo:
    Private Sub Command1_Click()    Clipboard.SetText Text1.SelText
    End Sub

    Private Sub Command2_Click()
    Text1.SelText = Clipboard.GetText
    End Sub

  15. Premere CTRL + S per salvare il modulo.
  16. L'ultimo modulo che è necessario è il form principale dell'applicazione. In Esplora progetti destro Progetto1, fare clic su Aggiungi, fare clic su moduloe quindi fare clic su Apri.
  17. Nel campo nome della finestra di dialogo proprietà digitare frmMain.
  18. Dalla casella degli strumenti, inserire un controllo CommandButton nel form frmMain. Nel campo didascalia della finestra di dialogo proprietà digitare ADO.
  19. Inserire un secondo controllo CommandButton nel form. Nel campo didascalia della finestra di dialogo proprietà digitare Appunti.
  20. Destro frmMaine quindi scegliere Visualizza codice. Incolla il seguente codice per il controllo CommandButton di fare clic su eventi, per visualizzare le altre due forme:
    Private Sub Command1_Click()    frmADO.Show
    End Sub

    Private Sub Command2_Click()
    frmClipboard.Show
    End Sub

  21. Premere CTRL + S per salvare il modulo.
  22. In Esplora soluzioni, fare Progetto1e quindi scegliere Proprietà Progetto1. Nel campo Oggetto di avvio , fare clic su frmMaine quindi fare clic su OK.
  23. Per aggiungere un riferimento al componente di ADO, dal menu progetto , fare clic su riferimenti. Nell'elenco dei riferimenti disponibili, fare clic per selezionare Libreria di oggetti dati ActiveX (esegue qualsiasi versione 2.0 o successiva). Fare clic su OK.
  24. Per compilare il progetto, dal menu File , fare clic su Creare Project1.exe. Fare clic su OK nella finestra di dialogo Crea progetto (accettare il nome di file predefinito).
  25. Premere F5 per eseguire l'applicazione in modalità di debug.

    Nota: non è necessario verificare che l'applicazione di Visual Basic legacy viene eseguita senza problemi, prima dell'aggiornamento.
  26. Chiudere l'ambiente di sviluppo di Visual Basic. Alla richiesta di salvare le modifiche apportate al progetto, fare clic su . Utilizzare il nome predefinito e salvare il progetto.
  27. Menu di avvio , scegliere programmi, scegliere Microsoft Visual Studio.NETe quindi fare clic su Microsoft Visual Studio.NET.
  28. Nella pagina iniziale, fare clic su Apri progetto. Individuare la cartella contenente il file di progetto di Visual Basic 6.0 che avete appena creato (generalmente C:\Program Files\Microsoft Visual Studio\VB98). Fare clic su Project1.vdpe quindi fare clic su Apri.
  29. Visual Studio .NET rileva che si tratta di un progetto di Visual Basic legacy e si avvia l'aggiornamento guidato Visual Basic. La procedura guidata visualizza una descrizione di ogni passaggio mentre si procede attraverso le fasi, la seguente sequenza:
    • Creare un nuovo progetto in cui viene aggiornato il progetto esistente.
    • Copiare il file di modulo e classe nel nuovo progetto.
    • Fornire un rapporto di aggiornamento che elenca i componenti del progetto aggiornato correttamente e i componenti che non aggiornato correttamente.

  30. Fare clic su Avanti attraverso tutti i passaggi fino a quando non inizia il processo di aggiornamento. L'aggiornamento richiederà circa 30-60 secondi.
  31. In Esplora soluzioni, fare doppio clic su UpgradeReport. htm. Questo report vengono visualizzati i risultati dell'aggiornamento. Si noti che tutti i moduli tranne frmClipboard aggiornato senza problemi.
  32. Espandere frmClipboard.vb per visualizzare i problemi. Clipboard.SetText e GetText non aggiornati correttamente. Fare clic sui collegamenti nella Descrizione per visualizzare come correggere i problemi.
  33. In Esplora soluzioni, si noti che tutti i moduli mantenuto il nome originale, ma l'estensione del file viene modificato da frm in. vb.
  34. Espandere i riferimenti. Si noti che fa riferimento a tutti i componenti necessari per l'utilizzo di Visual Basic legacy e i componenti ADO sono stati aggiunti automaticamente.
  35. Destro di una delle forme e quindi scegliere Visualizza codice. Espandere l'area di Supporto per l'aggiornamento . Questa area Visualizza come Visual Studio .NET o Visual Studio 2005 configurato diverse proprietà e variabili per supportare il codice aggiornato.
  36. In Esplora soluzioni, fare frmClipboard.vbe quindi scegliere Visualizza codice. Notare che ci sono commenti inseriti prima delle righe che non l'aggiornamento.
  37. Modificare gli eventi Command1_Click e Command2_Click nel modo seguente:
    Private Sub Command1_Click(ByVal eventSender As System.Object, _    ByVal eventArgs As System.EventArgs) Handles Command1.Click
    Clipboard.SetDataObject(Text1.Text)
    End Sub

    Private Sub Command2_Click(ByVal eventSender As System.Object, _
    ByVal eventArgs As System.EventArgs) Handles Command2.Click
    Text1.SelectedText = _
    Clipboard.GetDataObject().GetData(GetType(System.String))
    End Sub

Esempi di codice completo

Completamento codice (frmADO.frm)

Private Sub Command1_Click()    Unload Me
End Sub

Private Sub Form_Load()
Dim cn As Connection
Set cn = New Connection
cn.ConnectionString = "Provider=sqloledb;Data Source=localhost;database=northwind;user id=<username>;password=<strong password>"
cn.Open

Dim rs As Recordset
Set rs = New Recordset
rs.CursorLocation = adUseClient
rs.Open "select * from products", cn

Set MSHFlexGrid1.DataSource = rs
End Sub

Completamento codice (frmClipboard.frm)

Private Sub Command1_Click()    Clipboard.SetText Text1.SelText
End Sub

Private Sub Command2_Click()
Text1.SelText = Clipboard.GetText
End Sub

Complete Code Listing (frmMain.frm)
Private Sub Command1_Click()
frmADO.Show
End Sub

Private Sub Command2_Click()
frmClipboard.Show
End Sub

Verificare il corretto funzionamento dell'applicazione

  1. Premere F5 per avviare l'applicazione.
  2. Alla richiesta di salvare il progetto, fare clic su OK.
  3. In Form1, fare clic su ADO. Viene visualizzato un form che contiene i dati in una griglia. Chiudere il modulo.
  4. In Form1, fare clic su Appunti.
  5. Fare clic su Copia.
  6. Posizionare il cursore nella casella di testo all'inizio del testo e quindi fare clic su Incolla. Verrà visualizzato il testo incollato.

Risoluzione dei problemi

Visual Basic .NET è un cambiamento importante rispetto alle versioni precedenti di Visual Basic. Per molti progetti, un lavoro di preparazione completo si consiglia prima di aggiornare. Fare riferimento al documento per le informazioni che possono risultare utili per eseguire più facilmente l'aggiornamento seguente:

RIFERIMENTI

Per ulteriori informazioni, vedere i seguenti articoli della Microsoft Developer Network (MSDN):
Proprietà

ID articolo: 317885 - Ultima revisione: 30 gen 2017 - Revisione: 1

Feedback