Come utilizzare la funzionalità Stampa unione in Word per creare e stampare lettere tipo in cui utilizzare i dati di un foglio di lavoro di Excel


Riepilogo


In questo articolo viene illustrato come utilizzare la funzionalità Stampa unione in Microsoft Word per creare e stampare lettere tipo utilizzando i dati da un foglio di lavoro di Microsoft Excel.

Quando si utilizza la funzionalità di stampa unione di Word, Word unisce un documento principale con un elenco di destinatari per generare un set di documenti di output:
  • Il documento principale contiene il testo di base che è lo stesso in tutti i documenti di output. Esso può contenere una carta intestata, testo e le istruzioni in campi unione per l'inserimento di testo, quali i nomi dei destinatari e gli indirizzi, che variano da un documento di output a altro.
  • L'elenco dei destinatari è un database che contiene i dati da unire nei documenti di output. Ad esempio, l'elenco dei destinatari è un file di database di Microsoft Access o un foglio di lavoro di Excel.

    Il database è in genere un elenco di nomi, indirizzi, numeri di telefono e altre categorie di informazioni personali.
  • I documenti di output sono il risultato della stampa unione. Il testo in un documento di output può essere uguale in tutti i documenti di output, ma è possibile applicare la formattazione a documenti specifici.

Passaggio 1: Impostare il File di dati di Excel

Prima di procedere con la creazione guidata stampa unione, assicurarsi che il foglio di lavoro di Excel sia ben strutturato a tale scopo. Tenere presente i seguenti requisiti per la tabella di dati:
  • La prima riga deve contenere i nomi dei campi per ciascuna colonna, ad esempio, titolo, formula di apertura, nome, secondo nome, cognome, Indirizzo1 e Indirizzo2.
  • Ogni nome di campo deve essere univoco.
  • Ogni riga deve fornire informazioni su un particolare elemento. In un elenco di indirizzi, ad esempio, ogni riga può includere informazioni su un determinato destinatario.
  • La tabella non deve contenere alcuna riga vuota.
Creare il file di dati di Excel e adattarlo utilizzando i campi che si desidera utilizzare per la lettera, come illustrato nel file di dati di esempio seguente.

Dopo aver creato il file di dati di Excel, salvarlo e quindi chiudere il file di dati.

Per ulteriori informazioni su come creare un elenco di indirizzi di stampa unione, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:

294688 come progettare e impostare un elenco di indirizzi di stampa unione in Word 2002 e nelle versioni successive di Word

Passaggio 2: Impostare il documento principale

  1. In Microsoft Office Word 2003 e nelle versioni precedenti di Word, scegliere lettere e indirizzi dal menu Strumenti e quindi fare clic su Creazione guidata stampa unione.

    In Microsoft Office Word 2007, fare clic su Inizia stampa unione nel gruppo Inizia stampa unione della scheda lettere e quindi fare clic su Step by Step dalla creazione guidata stampa unione.
  2. In Selezionare il tipo di documento, fare clic su lettere.

    Il documento attivo diventa il documento principale. Il documento principale contiene il testo e grafica che è gli stessi per ogni versione del documento unito. Ad esempio, l'indirizzo del mittente e la formula in forma di lettera sono uguali per ciascuna versione.
  3. Fare clic su successivo: documento di partenza.
  4. Utilizzare uno dei seguenti metodi:
    • Iniziare con il documento attualmente visualizzato nella finestra del documento. A tale scopo, fare clic su Usa il documento corrente.

      Quindi digitare la lettera nella finestra del documento oppure attendere che la procedura guidata viene chiesto di farlo in un passaggio successivo.
    • Iniziare con un modello. A tale scopo, attenersi alla seguente procedura:
      1. Fare clic su inizia da un modello.
      2. Fare clic su Seleziona modello.
      3. Nella scheda Stampa unione , selezionare il modello desiderato nella finestra di dialogo Seleziona modello e quindi fare clic su OK.
    • Iniziare con un documento esistente. A tale scopo, attenersi alla seguente procedura:
      1. Fare clic su inizia da un documento esistente.
      2. Nella casella Comincia da esistente selezionare il documento desiderato e quindi fare clic su Apri.
      3. Se il documento non visibile, fare clic su più filee quindi fare clic su Apri. Nella finestra di dialogo Apri , individuare il documento desiderato e quindi fare clic su Apri.
  5. Fare clic su successivo: selezione destinatari.

Passaggio 3: Specificare l'origine dati di Excel

  1. Nella casella Selezionare i destinatari, fare clic su Usa elenco esistente.
  2. Fare clic su Sfoglia.
  3. Nella finestra di dialogo Seleziona origine dati , individuare e selezionare il foglio di lavoro di Excel che si desidera utilizzare.

    Per impostazione predefinita, Word apre la cartella "Origini dati utente".
  4. Fare clic su Apri.
  5. Se il foglio di lavoro di Excel contiene informazioni su più schede, selezionare la scheda che contiene le informazioni desiderate e quindi fare clic su OK.
  6. Tutte le voci dell'origine dati vengono visualizzati nella finestra di dialogo Destinatari stampa unione . In questo caso, è possibile ridefinire l'elenco dei destinatari da includere nella stampa unione.

Passaggio 4: Selezionare i destinatari

  1. Nella finestra di dialogo Destinatari stampa unione , selezionare i destinatari che si desidera includere. A tale scopo, utilizzare uno dei seguenti metodi:
    • Utilizzare le caselle di controllo per specificare i destinatari.

      Questo metodo è particolarmente utile se l'elenco è breve. Fare clic per selezionare le caselle di controllo accanto ai destinatari che si desidera includere e quindi fare clic per deselezionare le caselle di controllo accanto ai destinatari che si desidera escludere.

      Nota: Se si conosce che si desidera includere la maggior parte dell'elenco nella stampa unione, fare clic su Seleziona tuttoe quindi fare clic per deselezionare i record. Analogamente, se si desidera includere solo alcuni record nell'elenco, fare clic su Cancella tuttoe quindi selezionare i record che si desidera.
    • Ordinare gli elementi dell'elenco.

      Questo metodo è utile se si desidera visualizzare gli elementi in ordine alfabetico o numerico. Fare clic sull'intestazione di colonna dell'elemento in base al quale si desidera ordinare. Ad esempio, se si desidera visualizzare l'elenco in ordine alfabetico per cognome, fare clic sull'intestazione di colonna Cognome .
    • Filtrare gli elementi dell'elenco.

      Questo metodo è utile se l'elenco contiene record che si desidera visualizzare o includere nell'unione. Dopo avere filtrato l'elenco, è possibile utilizzare le caselle di controllo per includere o escludere alcuni record, come descritto in precedenza. Per filtrare l'elenco, attenersi alla seguente procedura:
      1. Fare clic sulla freccia accanto all'intestazione di colonna dell'elemento che si desidera filtrare.
      2. Fare clic su uno dei seguenti:
        • (Vuote): questa opzione consente di visualizzare tutti i record in cui il campo corrispondente è vuoto.
        • (NonVuote): questa opzione consente di visualizzare tutti i record in cui il campo corrispondente contiene informazioni.
        • Se l'origine dati contiene record che condividono le stesse informazioni e se vi sono 10 o meno valori univoci nella colonna, è possibile filtrare in base a informazioni specifiche. Ad esempio, se sono presenti più indirizzi che elencano l'Australia come paese, è possibile filtrare dall'Australia.
    • La finestra di dialogo Destinatari stampa unione consente di visualizzare solo i record specificati. Per visualizzare nuovamente tutti i record, fare clic su (tutto).
    Note
    • Per filtro e ordinamento avanzato, fare clic sulla freccia accanto a un nome di colonna e quindi fare clic su (avanzate). Utilizzare le schede Filtra i record e Ordina i record per impostare l'ordinamento e il filtro di query che si desidera.
    • Se è stato installato un software di convalida, fare clic su convalida nella finestra di dialogo Destinatari stampa unione per convalidare gli indirizzi dei destinatari.
  2. Fare clic su OK per tornare alla creazione guidata stampa unione.

    Word utilizza destinatari designati per l'unione.
  3. Fare clic su successivo: composizione lettera.

Passaggio 5: Completamento della lettera e aggiungere i campi unione

Se non è stato già fatto, digitare il testo che si desidera visualizzare in ogni lettera nel documento principale.

Inserisci campi unione

Inserire campi unione in cui si desidera unire nomi, indirizzi e altre informazioni dall'origine dati. Per inserire campi unione, attenersi alla seguente procedura:
  1. Nel documento principale, fare clic su cui si desidera inserire il campo.
  2. Inserire le seguenti:
    • Blocco di indirizzi con nome, indirizzo e altre informazioni:
      1. Fare clic su blocco di indirizzi.
      2. Nella finestra di dialogo Inserisci blocco di indirizzi , selezionare gli elementi dell'indirizzo che si desidera includere e i formati desiderati e quindi fare clic su OK. Per informazioni su un'opzione, fare clic sul punto interrogativo e quindi fare clic sull'opzione.

      3. Per informazioni su un'opzione, fare clic sul punto interrogativo e quindi fare clic sull'opzione. Se viene visualizzata la finestra di dialogo Corrispondenza campi , Word potrebbe essere Impossibile trovare alcune delle informazioni che necessarie per il blocco di indirizzi. Fare clic sulla freccia accanto a
        (non disponibile)e quindi selezionare il campo dell'origine dati che corrisponde al campo richiesto per la stampa unione.
    • Formula di apertura:
      1. Fare clic su esordio.
      2. Selezionare il formato che include il saluto, il formato del nome e la punteggiatura successiva.
      3. Selezionare il testo che si desidera visualizzare nei casi in cui Word non è in grado di interpretare il nome del destinatario. Ad esempio, Word non possono interpretare il nome quando l'origine dati non contiene alcun nome o il cognome di un destinatario, ma solo il nome di una società.
      4. Fare clic su OK.
      5. Se viene visualizzata la finestra di dialogo Corrispondenza campi , Word potrebbe essere Impossibile trovare alcune delle informazioni che necessarie per la formula di apertura. Fare clic sulla freccia accanto a (non disponibile)e quindi selezionare il campo dell'origine dati che corrisponde al campo richiesto per la stampa unione.
    • Altri campi di informazioni:
      1. Fare clic su altro.
      2. Utilizzare uno dei seguenti metodi:
        • Fare clic su Campi indirizzo per selezionare campi indirizzo che verranno automaticamente associati ai campi corrispondenti nell'origine dati, anche se i campi dell'origine dati non hanno lo stesso nome dei campi.
        • Fare clic su Campi Database per selezionare i campi che ricavano sempre i dati direttamente da una colonna in un database.
      3. Nella casella campi , fare clic sul campo desiderato.
      4. Fare clic su Inseriscie quindi fare clic su Chiudi.
      5. Se viene visualizzata la finestra di dialogo Corrispondenza campi , Word potrebbe non essere possibile trovare alcune delle informazioni necessarie per inserire il campo. Fare clic sulla freccia accanto a (non disponibile)e quindi selezionare il campo dell'origine dati che corrisponde al campo richiesto per la stampa unione.

        Nota: Se si inserisce un campo dall'elenco Campi di Database e se si passa in seguito a un'origine dati che non dispone di una colonna con lo stesso nome, Impossibile inserire le informazioni di campo nel documento unito.
    • Affrancatura elettronica:

      Per aggiungere un'affrancatura elettronica, è innanzitutto necessario installare un programma di affrancatura elettronica, come quello che è possibile acquistare da un provider di terze parti sul Web. Per utilizzare l'affrancatura elettronica, attenersi alla seguente procedura:
      1. Fare clic su un'affrancatura elettronica.

        Se non è installato un programma di affrancatura elettronica, Word viene richiesto di installarne uno e consentirà di connettersi al sito Web di Microsoft Office seguente:
      2. Inserire l'affrancatura in base alle istruzioni del programma.
    • Per aggiungere un'affrancatura elettronica, è innanzitutto necessario installare un programma di affrancatura elettronica, come quello che è possibile acquistare da un provider di terze parti sul Web. Per utilizzare l'affrancatura elettronica, attenersi alla seguente procedura: codice postale a barre: È necessario selezionare un tipo di lettera o busta che supporti il codice a barre POSTNET. Per utilizzare il codice postale a barre, attenersi alla seguente procedura:
      1. Fare clic su codice postale a barre.
      2. Nella finestra di dialogo Inserisci codice postale a barre , selezionare i campi indirizzo appropriati.

        Nota: L'opzione codice postale a barre viene visualizzata solo se si utilizza la versione di lingua negli Stati Uniti di Word.
      3. Ripetere i passaggi da una a e b per tutti i campi che si desidera inserire. Note:
        • Non è possibile digitare i caratteri del campo unione ("") o inserirli utilizzando il comando simbolo dal menu Inserisci .
        • Se i campi unione appaiono tra parentesi graffe, ad esempio {MERGEFIELD Città}, vengono visualizzati i codici di campo invece dei risultati. Ciò non influisce sull'unione, ma se si desidera visualizzare i risultati, destro del mouse sul codice di campo e quindi scegliere Attiva o disattiva codici di campo dal menu di scelta rapida.
      Ad esempio, utilizzando il database di esempio illustrato in precedenza, la lettera potrebbe contenere i campi AddressBlock e GreetingLine e pertanto la prima pagina è simile al seguente:
      26 febbraio 2002

      Blocco di indirizzi

      GreetingLine

      Digitare qui la lettera.

      Distinti saluti,

      Digitare il nome qui

    Nota: È anche possibile utilizzare la barra degli strumenti Stampa unione per inserire campi unione, lavorare con il documento principale di stampa unione o eseguire una stampa unione. Per visualizzare la barra degli strumenti Stampa unione , scegliere lettere e indirizzi dal menu Strumenti e quindi fare clic su Mostra barra degli strumenti Stampa unione.


    La barra degli strumenti Stampa unione fornisce ulteriori comandi non inclusi nei riquadri attività di creazione guidata stampa unione. Ad esempio, è possibile utilizzare il menu Inserisci campo Word sulla barra degli strumenti Stampa unione per inserire i campi di Word per controllare il processo di unione. Ad esempio, è possibile inserire un campo IF che inserisce il testo solo se un determinato campo unione presenta un valore specificato.

    In alternativa, è possibile scegliere Per errori di Word per eseguire la stampa unione e il rapporto degli errori che sono contenuti nel documento principale.

Modificare il formato dei dati uniti

Per formattare i dati uniti è necessario formattare i campi unione nel documento principale. Non formattare i dati nell'origine dati, in quanto la formattazione non viene mantenuta quando si uniscono i dati nel documento. Per modificare il formato dei dati uniti, attenersi alla seguente procedura:
  1. Nel documento principale, selezionare il campo che contiene le informazioni che si desidera formattare, inclusi i caratteri del campo unione (<> <>) che lo contiene.
  2. In Word 2003 e nelle versioni precedenti di Word, scegliere carattere dal menu formato e quindi selezionare le opzioni desiderate.

    In Word 2007, fare clic sull'opzione desiderata nella casella Tipi di carattere tema nel gruppo carattere della scheda Home .

Formattare tramite codici di campo

Per controllare altri aspetti della formattazione, premere ALT + F9 per visualizzare i codici di campo e quindi aggiungere i parametri ai campi unione. Quando utilizzano i campi, uno switch è un'istruzione speciale che fa sì che si verifichi una determinata azione. In genere, viene aggiunta un'opzione a un campo per modificarne il risultato.

Esempi di come utilizzare le opzioni sono le seguenti:
  • Per visualizzare il numero 34987,89 come $34,987.89, aggiungere il parametro numerico (\ #).
  • Per stampare i nomi dei clienti in lettere maiuscole, aggiungere il parametro di formato (\ *).
  • Per assicurarsi che le informazioni unite abbiano stesso carattere e dimensione in punti che applica al campo unione, aggiungere il parametro formatocar (\ *).

Passaggio 6: Salvare il documento

Dopo avere completato il documento principale e avere inserito tutti i campi unione, assicurarsi di salvare il documento prima di procedere. A tale scopo, attenersi alla seguente procedura:
  1. In Word 2003 e nelle versioni precedenti di Word, fare clic su Salva con nome dal menu File .

    In Word 2007, fare clic sul Pulsante Microsoft Officee quindi fare clic su Salva con nome.
  2. Nome del documento e quindi fare clic su Salva.
  3. Fare clic su successivo: anteprima lettere.

Passaggio 7: Anteprima lettere e perfezionamento dell'elenco dei destinatari

Quando viene visualizzato il riquadro attività di "passaggio 5 stampa unione", la procedura guidata sostituisce tutti i campi unione nel documento principale che contiene il testo effettivo della prima voce dell'elenco di destinatari. Pertanto, è possibile visualizzare l'aspetto del primo documento di output.

Ad esempio, se si dovesse continuare a utilizzare il database di esempio illustrato in precedenza, la prima pagina dovrebbe essere simile la seguente pagina dopo aver fatto clic successivo: anteprima lettere:
26 febbraio 2002

Paolo Fazio
Modo di capitale 908 W.
98401 Torino

Egregio Andrea Giudici,

Digitare qui la lettera.

Distinti saluti,

Digitare il nome qui
Per visualizzare altre voci, utilizzare uno dei seguenti metodi:
  • Per visualizzare in anteprima gli elementi in ordine, fare clic sul pulsante freccia sinistra o destra.
  • Per individuare e visualizzare l'anteprima di un elemento specifico, fare clic su Trova destinatarioe quindi immettere i criteri di ricerca nella finestra di dialogo Trova voce .
Se si desidera, perfezionare l'elenco dei destinatari. A tale scopo, utilizzare uno dei seguenti metodi:
  • Per escludere un determinato destinatario dall'operazione di unione, fare clic su Escludi destinatario.
  • Per modificare l'elenco dei destinatari, fare clic su Modifica elenco destinatarie quindi apportare le modifiche desiderate nella finestra di dialogo Destinatari stampa unione .

Passaggio 8: Completamento unione

Per completare l'unione, utilizzare uno dei metodi descritti di seguito.

Personalizzare le singole lettere

Per personalizzare singoli elementi, completare effettivamente l'unione e quindi modificare le informazioni desiderate nel documento unito risultante. A tale scopo, attenersi alla seguente procedura:
  1. Fare clic su Modifica singole lettere.
  2. Nella finestra di dialogo Unisci in nuovo documento , selezionare i record che si desidera unire.
  3. Fare clic su OK.

    Verrà creato e aperto un nuovo documento unito. Anche il documento principale rimarrà aperto ed è possibile tornarvi in qualunque momento se si desidera modificare tutti i documenti.
  4. Selezionare le informazioni che si desidera modificare e quindi apportare le modifiche.
  5. Stampare o salvare il documento, esattamente come qualsiasi altro documento.

Stampare le lettere

Per stampare le lettere, utilizzare uno dei seguenti metodi:
  • Se è stata personalizzata gli elementi e il documento unito è attivo, procedere come segue:
    1. In Word 2003 e nelle versioni precedenti di Word, scegliere Stampa dal menu File .

      In Word 2007, fare clic sul Pulsante Microsoft Officee quindi fare clic su Stampa.
    2. Selezionare le opzioni desiderate.
  • Se si desidera stampare direttamente dalla creazione guidata stampa unione, attenersi alla seguente procedura:
    1. Nel passaggio 6 della creazione guidata stampa unione (completamento unione), fare clic su Stampa.
    2. Nella finestra di dialogo Unisci alla stampante , utilizzare uno dei metodi seguenti e quindi fare clic su OK:
      • Per stampare tutti i documenti, fare clic su tutto.
      • Per stampare il documento visualizzato nella finestra del documento, fare clic su record corrente.
      • Per stampare un intervallo di documenti, fare clic sue quindi digitare i numeri dei record nelle caselle da e a .
    3. Nella finestra di dialogo Stampa , selezionare le opzioni desiderate.

Salvare le lettere unite per un uso successivo

Se si desidera modificare le lettere unite o salvarle per utilizzarle, è possibile raccoglierle in un unico documento. A tale scopo, attenersi alla seguente procedura:
  1. Fare clic su Modifica singole lettere.
  2. Nella finestra di dialogo Unisci in un nuovo documento , utilizzare uno dei metodi seguenti e quindi fare clic su OK:
    • Per unire tutti i documenti, fare clic su tutto.
    • Per unire solo il documento visualizzato nella finestra del documento, fare clic su record corrente.
    • Per unire un intervallo di documenti, fare clic sue quindi digitare i numeri dei record nelle caselle da e a .
  3. Verrà aperto un nuovo documento contenente tutte le singole lettere. È quindi possibile salvare il documento per uso successivo, esattamente come qualsiasi altro documento.

Riferimenti


Per ulteriori informazioni, fare clic sui numeri per visualizzare gli articoli della Microsoft Knowledge Base:

318117 come utilizzare gli indirizzi di un foglio di lavoro di Excel per creare le etichette in Word

318115 come creare una lettera utilizzando le informazioni da un database di Access in Word 2002

318112 come utilizzare gli indirizzi da un database di Access 2002 per creare etichette in Word 2002

294686 come utilizzare la stampa unione per creare un elenco ordinato per categoria in Word 2002 e nelle versioni successive di Word

290408 domande frequenti sulla stampa unione in Word 2002

294688 come progettare e impostare un elenco di indirizzi di stampa unione in Word 2002 e nelle versioni successive di Word

294683 come utilizzare la stampa unione per creare lettere tipo in Word 2002 e nelle versioni successive di Word