Avviso "Un programma sta provando a inviare un messaggio per conto dell'utente" in Outlook

Numero originale della Knowledge Base: 3189806

Sintomi

In Microsoft Outlook LTSC 2021, Outlook 2019, Outlook per Microsoft 365, Outlook 2016 e Outlook 2013, quando si invia un messaggio di posta elettronica da un altro programma, ad esempio Microsoft Excel, viene visualizzato il messaggio di avviso seguente:

Un programma sta provando a inviare un messaggio per conto dell'utente. Se l'operazione è imprevista, fare clic su Nega e verificare che il software antivirus sia aggiornato.

Causa

Questo messaggio di avviso viene visualizzato quando un programma tenta di accedere al client Outlook per inviare un messaggio per conto dell'utente e viene rilevato che il software antivirus è inattivo o non aggiornato.

Metodo di risoluzione 1: abilitare o aggiornare l'applicazione antivirus

Per scoprire come Outlook rileva lo stato dell'antivirus, attenersi alla seguente procedura:

  1. In Outlook, selezionare File e quindi fare clic su Opzioni.

  2. Selezionare Centro protezione, quindi selezionare Impostazioni del Centro protezione.

  3. Selezionare Accesso programmatico.

  4. Visualizzare le informazioni relative allo Stato dell'antivirus elencate nella finestra. Se lo stato è diverso da Valido, attenersi alla procedura appropriata per abilitare il programma antivirus o aggiornarlo in base alle esigenze.

    Screenshot della finestra di dialogo Centro protezione, in cui lo stato antivirus valido è evidenziato nella voce Accesso programmatico.

Metodo di risoluzione 2: modificare l'impostazione Sicurezza accesso programmatico nel Registro di sistema

  1. Selezionare Start e quindi digitare regedit. Fare clic con il pulsante destro del mouse su Editor del Registro di sistema nei risultati della ricerca, quindi selezionare Esegui come amministratore.

  2. Nell'editor del Registro di sistema passare alla sottochiave del Registro di sistema appropriata, come indicato di seguito:

    • Numero di bit diverso (Office a 32 bit in esecuzione su Windows a 64 bit): HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office<x.0>\Outlook\Security
    • Stesso numero di bit (Office a 32 bit in esecuzione su Windows a 32 bit o Office a 64 bit in esecuzione su Windows a 64 bit): HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office<x.0>\Outlook\Security

    Note:

    • In queste sottochiavi, il segnaposto <x.0> rappresenta la versione di Office in uso (16.0 = Office 2016, Office 2019, Office LTSC 2021 o Outlook per Microsoft 365 e 15.0 = Office 2013).
    • Se la sottochiave del Registro di sistema indicata non è presente, fare clic con il pulsante destro del mouse sull'ultima sottochiave nel percorso, selezionare Nuova>Chiave e quindi creare la sottochiave necessaria.
  3. Fare clic con il pulsante destro del mouse sulla sottochiave del Registro di sistema e quindi scegliere Nuova>DWORD.

  4. Denominare DWORD come ObjectModelGuard.

  5. Impostare il valore di DWORD sul comportamento desiderato:

    • DWORD: ObjectModelGuard

    • Valori:

      0 = Segnala attività sospette se il software antivirus è inattivo o non aggiornato (scelta consigliata)

      1 = Segnala sempre attività sospette

      2 = Non segnalare mai attività sospette (scelta non consigliata)

  6. Uscire dall'editor del Registro di sistema.

Dopo aver aggiornato il Registro di sistema, controllare Outlook per assicurarsi che la modifica venga visualizzata correttamente nelle impostazioni di Accesso programmatico:

  1. In Outlook, selezionare File e quindi fare clic su Opzioni.

  2. Selezionare Centro protezione, quindi selezionare Impostazioni del Centro protezione.

  3. Selezionare Accesso programmatico.

    Screenshot che mostra la selezione dell'opzione Non segnalare mai attività sospette (scelta non consigliata) nell'area Sicurezza accesso programmatico.