Viene visualizzato un messaggio di errore "Accesso negato" quando si eliminano cartelle da un'unità montata

Sintomi

Se si tenta di eliminare le cartelle che vengono archiviate in un'unità montata e inviarle al Cestino, è che venga visualizzato il seguente messaggio di errore:

Impossibile eliminare nomecartella: accesso negato. Il file di origine potrebbe essere in uso.

Causa

Questo problema si verifica perché il Cestino non riconosce i volumi montati. Ad esempio, si supponga che la seguente configurazione dell'unità in uso:

L'unità C è un'unità di 1 gigabyte (1 GB) che utilizza il file system NTFS.
C:\Host-dir è il punto di montaggio per un'unità da 9 GB separata.
Se si tenta di eliminare una cartella con percorso C:\Host-dir\Mydir, Windows Explorer interpreta la cartella come unità C e tenta inutilmente di inserirla nel Cestino sull'unità C.

Risoluzione

Per risolvere questo problema, utilizzare uno dei seguenti metodi:
  • Quando si eliminano file o cartelle utilizzando Esplora risorse, utilizzare la combinazione di tasti MAIUSC + CANC. Ciò consente di ignorare il Cestino.
  • Aprire una finestra del prompt dei comandi e utilizzare il comando rd /s /q per eliminare i file o cartelle.
Nota: entrambi questi metodi consentono di eliminare definitivamente i dati. È possibile recuperare i dati se non si dispone di un backup corrente.

Stato

Microsoft ha confermato che si tratta di un problema nei prodotti Microsoft elencati all'inizio di questo articolo.
Proprietà

ID articolo: 319368 - Ultima revisione: 30 gen 2017 - Revisione: 2

Feedback