Le prestazioni sono scarse quando si usa il profilo utente predefinito personalizzato in Windows

Questo articolo fornisce una soluzione ai problemi che si verificano quando si usano i profili utente predefiniti personalizzati.

Si applica a: Windows 10: tutte le edizioni, Windows Server 2019, Windows Server 2016
Numero KB originale: 4056823

Sintomo

Considerare lo scenario descritto di seguito:

  • È possibile creare un nuovo profilo utente predefinito e abilitarlo.
  • Un nuovo utente accede usando un profilo creato dal profilo predefinito in un computer basato su Windows 10, Windows Server 2016 o Windows Server 2019.

In questo scenario si verificano uno o più dei problemi seguenti:

  • La visualizzazione delle icone del desktop richiede molto tempo.

  • Le prestazioni sono scarse quando si avvia o si esplora Internet Explorer o Microsoft Edge.

  • Nel registro eventi vengono registrati errori ESENT come i seguenti:

    EventLogID: 454
    TaskHostW: (pid)
    WebCacheLocal: "Ripristino/ripristino del database non riuscito con errore imprevisto -1907"

    Nota

    Il messaggio completo del registro eventi può anche indicare un'associazione con un percorso di cartella utente diverso, ad esempio C:\Users\Administrator.

Causa

Questi problemi si verificano perché il profilo utente predefinito include una copia bloccata del database della cache di un altro utente.

Quando un nuovo utente accede al computer, il contenuto del profilo utente predefinito viene incorporato nel nuovo profilo. Quando la shell e il desktop di Windows iniziano a essere caricati, il database non può essere inizializzato completamente per l'uso. Le applicazioni che usano il database presentano prestazioni negative o segnalano errori.

Risoluzione

Per risolvere il problema, seguire questa procedura:

  1. Accedere a ogni computer interessato usando un account con credenziali amministrative e quindi eliminare il file e la cartella nascosti seguenti, se presenti:

    File: C:\Users\Default\AppData\Local\Microsoft\Windows\WebCacheLock.dat
    Cartella: C:\Users\Default\AppData\Local\Microsoft\Windows\WebCache

  2. Per ogni account utente nel computer, assicurarsi che l'utente sia disconnesso completamente e che il profilo sia stato scaricato completamente, quindi eliminare il file nascosto e la cartella seguenti, se esistenti:

    File: C:\Users\<affectedUserFolder>\AppData\Local\Microsoft\Windows\WebCacheLock.dat
    Cartella: C:\Users\<affectedUserFolder>\AppData\Local\Microsoft\Windows\WebCache

Nota

<affectedUserFolder> è un segnaposto per il nome della cartella del profilo utente. Ad esempio, per l'account utente Amministratore, la cartella si trova in C:\Users\Administrator. È necessario rimuovere i file e le cartelle precedenti per ogni account utente interessato nel computer.

Come visualizzare i file nascosti

Per visualizzare i file nascosti, seguire questa procedura:

  1. In Esplora risorse selezionare File e quindi Opzioni.
  2. Nella scheda Visualizza selezionare l'opzione Mostra file, cartelle e unità nascosti .
  3. Deselezionare l'opzione Nascondi file del sistema operativo protetto (scelta consigliata) e quindi fare clic su OK.

Nota

È consigliabile selezionare nuovamente le due opzioni dopo aver risolto il problema.

Ulteriori informazioni

Poiché il database della cache è progettato per essere generato per utente al momento dell'accesso iniziale a un singolo computer, Microsoft non consiglia o supporta l'inclusione del database della cache nel profilo predefinito o in qualsiasi altro profilo utente che deve essere usato come modello.