"Errore 0x800f0831" durante l'installazione di un aggiornamento

Questo articolo risolve un problema in cui viene visualizzato l'Errore 0x800f0831 quando si installa un aggiornamento cumulativo.

Versione originale del prodotto: Configuration Manager (Current Branch), Windows Server Update Services
Numero della Knowledge Base originale: 4477073

Sintomo

Quando si tenta di installare un aggiornamento di Windows, in particolare un aggiornamento cumulativo, viene visualizzato il messaggio di errore seguente in WindowsUpdate.log:

ERRORE IRREVERSIBILE: CBS ha chiamato un Errore 0x800f0831

Questo problema è più probabile che si verifichi quando non è disponibile l'accesso a Microsoft Update.

Vengono inoltre visualizzati messaggi di errore simili ai seguenti in CBS.log:

Danneggiamento dell'archivio, manifesto mancante per il pacchetto: <Missing_Package>
Impossibile risolvere il pacchetto <Missing_Package> [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Contrassegnare il flag di danneggiamento dell'archivio a causa del pacchetto: <Missing_Package> [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Impossibile risolvere il pacchetto [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Impossibile ottenere il pacchetto successivo per rivalutare [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Impossibile eseguire la catena di esecuzione. [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Impossibile elaborare l'esecuzione monofase. [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
Segnalazione errori Windows: generazione del report degli errori per il pacchetto:<Failed_Package> stato: 0x800f0831, fonte dell'errore: Execute, stato iniziale: Staged, stato di destinazione: Installed, client id: DISM Package Manager Provider

Nota

              <Failed_Package> rappresenta il pacchetto che non può essere installato.               <Missing_Package> rappresenta il pacchetto per il quale manca il manifesto.

Causa

Questo problema si verifica perché l'aggiornamento che non può essere installato richiede il manifesto di un pacchetto di aggiornamento precedente.

Risoluzione

Per risolvere il problema, usare uno dei metodi seguenti.

Metodo 1: Ripristinare l'archivio componenti con i comandi di Gestione e manutenzione immagini distribuzione

Per ripristinare l'archivio componenti usando il DISM RestoreHealth comando , seguire questa procedura:

  1. Aprire un prompt dei comandi con privilegi elevati ed eseguire questi comandi:

    DISM /ONLINE /CLEANUP-IMAGE /SCANHEALTH
    
    DISM /ONLINE /CLEANUP-IMAGE /CHECKHEALTH
    
    DISM /ONLINE /CLEANUP-IMAGE /RESTOREHEALTH
    
    Sfc /Scannow
    
  2. Riavviare il dispositivo.

Metodo 2: Ripristinare manualmente con il payload del componente parzialmente installato

  1. Accedere a Microsoft Update Catalog.
  2. Nella casella Ricerca, inserire l'ID del pacchetto <Missing_Package>.
  3. Tra i risultati della ricerca individuare l'aggiornamento idoneo al sistema operativo in uso, quindi fare clic sul pulsante Scarica.
  4. Nella finestra Catalogo di Microsoft Update selezionare il collegamento del file per scaricare l'aggiornamento.
  5. Fare clic su Chiudi al termine del processo di download. A questo punto sarà disponibile una cartella contenente il pacchetto di aggiornamento nella posizione specificata.
  6. Aprire la cartella e quindi fare doppio clic sul pacchetto di aggiornamento per installare l'aggiornamento.