Un cluster di server con un tipo di risorsa Script generico smette di rispondere

Nel presente articolo viene illustrata una versione beta di un prodotto Microsoft. Le informazioni contenute in questo articolo vengono fornite "nello stato in cui si trovano" e sono soggette a modifiche senza preavviso.

Per questo prodotto beta Microsoft non fornisce alcun tipo di supporto formale. Per informazioni su come ottenere supporto per una versione beta, consultare la documentazione fornita con i file del prodotto beta oppure visitare il sito Web da cui la versione del prodotto è stata scaricata.

Sintomi

Un cluster che include un tipo di risorsa Script generico smette di rispondere ovvero si blocca. Cluadmin e Cluster.exe appaiono bloccati e se si verifica il registro del cluster si notano dei thread bloccati all'interno di una risorsa Script generico. Ad esempio:Cluadmin e Cluster.exe sono bloccati in numerosi comandi e il cluster non risponde alla maggior parte delle API cluster. Se il cluster smette di rispondere, un utente non è in grado di eliminare la risorsa di script che causa l'errore. Finché il problema non verrà corretto, non sarà possibile avviare o arrestare il servizio cluster utilizzando le comuni procedure.

Cause

Uno script di tipo di risorsa Script generico scritto in modo mediocre può causare il blocco dell'intero cluster. Si tratta solitamente di script che contengono cicli infiniti oppure che comportano l'avvio di Cluster.exe. I cicli infiniti impediscono l'uscita dallo script, mentre il richiamo di Cluster.exe determina il blocco di tutto il cluster.

Risoluzione

Per correggere il blocco del cluster, attenersi alla procedura seguente:
  1. In tutti i nodi cambiare la modalità di avvio del servizio cluster da automatica a manuale utilizzando il comando sc config clussvc start=demand oppure lo snap-in Servizi.
  2. Riavviare tutti i nodi del cluster, uno alla volta.
  3. Se lo script che causa l'errore è installato su volumi locali su ciascun nodo del cluster, eliminare o rinominare ciascuna istanza del file di script.

    Se lo script è installato su un volume condiviso (pratica consigliata), attenersi alla procedura descritta di seguito:
    1. Su uno dei nodi avviare il servizio cluster utilizzando il comando net start clussvc oppure lo snap-in Servizi. Questa operazione è necessaria per accedere al volume condiviso.

      Il servizio cluster potrebbe bloccarsi quando si tenta di avviarlo. In tal caso il servizio verrà visualizzato con stato SERVICE_START_PENDING per lungo tempo.

      Tutte le API cluster smetteranno di rispondere.
    2. Eliminare o rinominare i file di script presenti sul volume condiviso.
    3. Riavviare il nodo.
  4. Cambiare la modalità di avvio del servizio cluster in automatica per tutti i nodi utilizzando il comando sc config clussvc start=auto oppure lo snap-in Servizi.
  5. Riavviare il servizio cluster su tutti i nodi, un nodo per volta utilizzando il comando net start clussvc oppure lo snap-in Servizi.

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Si applica a..." di questo articolo.
Proprietà

ID articolo: 811685 - Ultima revisione: 13 gen 2008 - Revisione: 1

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