Il computer portatile è Impossibile rinnovare l'indirizzo IP da un server DHCP dopo la rimozione del computer dall'alloggiamento di espansione

Importante Questo articolo contiene informazioni su come modificare il Registro di sistema. Assicurarsi di eseguire il backup del Registro di sistema prima di modificarlo. Assicurarsi di sapere come ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:
256986 descrizione del Registro di sistema di Microsoft Windows
In questo articolo si applica solo a Microsoft Windows 2000 SP4 e non per altre versioni di Windows 2000.

Sintomi

Un computer portatile potrebbe risultare impossibile rinnovare l'indirizzo IP (Internet Protocol) da un server Dynamic Host Configuration Protocol (DHCP) dopo aver rimosso il computer dall'alloggiamento di espansione o da un replicatore di porta. Inoltre, errori non vengono registrati nel Registro di sistema e il problema persiste dopo aver disattivato e quindi abilitare nuovamente la scheda di rete.

Causa

Questo problema si verifica perché il computer non riesce a raggiungere il server DHCP. Windows 2000 utilizza la funzionalità di rilevamento del supporto per rimuovere protocolli che sono associati a una scheda di rete che viene rilevata come "inattivo" o "disconnesso". Nello scenario descritto nella sezione "Sintomi", il messaggio di protocollo ICMP (Internet Control) invia una richiesta restituisce uno stato in sospeso , rimuove Media Sense, il protocollo TCP/IP e scheda di rete non viene rilevata in quanto nessun protocollo associato alla scheda di rete.

Risoluzione

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta al servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:Nota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Non è richiesto alcun prerequisito.

Richiesta di riavvio

Dopo avere applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di data e ora nel Pannello di controllo.
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Afd.sys5.0.2195.6687120,24019-Jun-200320:05x86
Msafd.dll5.0.2195.6602108,81619-Jun-200320:05x86
Tcpip.sys5.0.2195.6921315,12026-Apr-200421:38x86
Tdi.sys5.0.2195.665516,24019-Jun-200320:05x86
Wshtcpip.dll5.0.2195.660117,68019-Jun-200320:05x86

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Soluzione alternativa

Per risolvere questo problema, impedire che la scheda di rete rilevi lo stato di collegamento modificando il Registro di sistema per disattivare la funzionalità di rilevamento del supporto per TCP/IP. A tale scopo, attenersi alla seguente procedura.

Nota: NetBIOS Extended User Interface (NetBEUI) e (Internetwork Packet Exchange) non riconoscono la funzionalità Media Sense.

Avviso L'errata modifica del Registro di sistema utilizzando l'Editor del Registro di sistema o un altro metodo può causare problemi gravi. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che questi problemi possano essere risolti. Modificare il Registro di sistema a proprio rischio.
  1. Fare clic su Start e quindi fare clic su Esegui.
  2. Nella casella Apri digitare regedit e quindi fare clic su OK.
  3. Individuare e selezionare la seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters

  4. Dal menu Modifica , scegliere Nuovoe quindi fare clic su Valore DWORD
  5. Digitare il nome della nuova voce DisableDHCPMediaSense e quindi premere INVIO.
  6. Fare doppio clic su nuova voce DisableDHCPMediaSense , digitare 1 nella casella dati valore e quindi fare clic su OK.
  7. Chiudere l'Editor del Registro di sistema e riavviare il computer.
Nota: Il valore della DisableDHCPMediaSense controlla il comportamento di rilevamento del supporto DHCP. Se si imposta questo valore su 1, i client DHCP e client non DHCP ignorano gli eventi di Media Sense dalla scheda di rete. Per impostazione predefinita, gli eventi di rilevamento del supporto attivano il client per eseguire un'azione, ad esempio per tentare di ottenere un lease quando si verifica un evento di connessione o per invalidare la scheda di rete e le route di quando un evento di disconnessione si verifica. Per ulteriori informazioni sulla disattivazione di rilevamento del supporto per TCP/IP, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:

239924 come disattivare la funzionalità di "Rilevamento del supporto" per TCP/IP in Windows

Ulteriori informazioni

Per ulteriori informazioni sulla denominazione pacchetti di hotfix, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:

I pacchetti di aggiornamento 816915 nuovo schema di denominazione per il software Microsoft Windows

Per ulteriori informazioni sulla terminologia utilizzata nel presente articolo, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:

824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Proprietà

ID articolo: 818635 - Ultima revisione: 30 gen 2017 - Revisione: 1

Feedback