Un programma smette di eseguire un'attività o Explorer.exe utilizza il 100 percento della CPU quando si fa clic con il pulsante destro del mouse su un elemento in Esplora risorse

Sintomi

Quando si fa clic con il pulsante destro del mouse su un elemento, quale un file, una cartella o una connessione di rete, in Esplora risorse o in Risorse del computer, gli altri programmi potrebbero smettere temporaneamente di eseguire un'attività. La riproduzione di un video in Microsoft Windows Media Player, ad esempio, potrebbe essere temporaneamente interrotta.

Se si avvia Task Manager Windows, si potrebbe notare nella scheda Processi che il processo Explorer.exe utilizza molte risorse della CPU o il 100 percento. Per avviare Task Manager Windows, fare clic con il pulsante destro del mouse su un'area vuota sulla barra delle applicazioni, quindi scegliere Task Manager.

Cause

Questo problema si verifica se sono attivate le seguenti impostazioni e se si fa clic con il pulsante destro del mouse su un elemento per selezionarlo:
  • Mostra operazioni comuni nelle cartelle
  • Visualizza menu con effetto dissolvenza o scorrimento
Per impostazione predefinita, in Windows XP sono attivate entrambe le impostazioni.

Se queste impostazioni sono attivate, le informazioni sull'elemento selezionato sono visualizzate nel riquadro Attività di Esplora risorse utilizzando un'animazione. Se si apre un menu di scelta rapida, visualizzato quando si fa clic con il pulsante destro del mouse su un elemento, mentre è in corso l'animazione, potrebbe non essere possibile terminare l'animazione fino alla chiusura del menu di scelta rapida, utilizzando in questo modo molte risorse della CPU.

Workaround

Per aggirare questo problema, selezionare l'elemento prima di farvi clic con il pulsante destro del mouse. Per selezionare un elemento, fare clic sull'elemento o posizionare il puntatore del mouse sull'elemento.

È possibile evitare questo problema disattivando le impostazioni elencate nella sezione "Cause" di questo articolo. Per effettuare questa operazione, utilizzare uno dei metodi seguenti.

Metodo 1: Disattivare l'effetto visivo "Visualizza menu con effetto dissolvenza o scorrimento"

  1. Scegliere Start, quindi Pannello di controllo.
  2. Scegliere Prestazioni e manutenzione, quindi Sistema oppure fare doppio clic sull'icona Sistema.
  3. Nella scheda Avanzate, scegliere Impostazioni in Prestazioni.
  4. Nella scheda Effetti visivi deselezionare la casella di controllo Visualizza menu con effetto dissolvenza o scorrimento.
  5. Scegliere OK.

Metodo 2: Utilizzare le cartelle di Windows classiche

  1. Scegliere Start, quindi Pannello di controllo.
  2. Scegliere Aspetto e temi, quindi Opzioni cartella oppure fare doppio clic sull'icona Opzioni cartella.
  3. Nella scheda Generale, scegliere Usa cartelle di Windows.
  4. Scegliere OK.

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Si applica a..." di questo articolo.
Proprietà

ID articolo: 819946 - Ultima revisione: 13 gen 2008 - Revisione: 1

Feedback