ID evento 677 e messaggi di errore evento ID 673 controllo vengono registrati ripetutamente nel Registro di protezione del controller di dominio che eseguono Windows 2000 e Windows Server 2003

Sintomi

In un dominio Microsoft Windows Server 2003, i messaggi di ID evento sono associati a errori di accesso account possono vengono registrati ripetutamente nel registro eventi di protezione controller di dominio. Ad esempio, il seguente messaggio di evento viene registrato più volte nei controller di dominio basato su Microsoft Windows 2000:
Il seguente messaggio di evento viene registrato più volte nei controller di dominio basato su Windows Server 2003:

Causa

Questo problema si verifica perché il client Kerberos nei computer basati su Windows 2000 e nei computer basati su Windows Server 2003 viene esaminato il centro distribuzione chiave (KDC) a intervalli stabiliti per verificare che l'estensione Kerberos Service-for-User (S4U) è supportato. Per impostazione predefinita, il client Kerberos viene esaminato il KDC ogni 15 minuti. Poiché Windows 2000 non supporta l'estensione Kerberos S4U, messaggi di evento ID 677 vengono registrati nel registro eventi di protezione di un controller di dominio Windows 2000. In Windows Server 2003, i messaggi di evento ID 673 vengono registrati nel registro eventi di protezione se non è configurata l'estensione Kerberos S4U. Per utilizzare l'estensione Kerberos S4U, è necessario disporre di un dominio nativo di Windows Server 2003 e configurare gli account computer appropriati per la delega vincolata.

Risoluzione

Questa correzione elimina evento ID 677 e 673 ID evento in questo contesto.

Windows Server 2003

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:Nota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Non è richiesto alcun prerequisito.

Richiesta di riavvio

Dopo avere applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.
Windows Server 2003, versioni basate su x86
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Kdcsvc.dll5.2.3790.288226,81616-Mar-200502:02x86
Windows Server 2003, versioni basate su Itanium
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Kdcsvc.dll5.2.3790.288586,75215 - Mar-200510:03IA-64

Windows 2000

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:Nota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, è necessario disporre di Windows 2000 Service Pack 3 (SP3) è installato nel computer.

Richiesta di riavvio

Dopo avere applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Adsldp.dll5.0.2195.6824124,68814 -Nov-200323:56x86
Adsldpc.dll5.0.2195.6824132,36814-Nov-200323:56x86
Adsmsext.dll5.0.2195.682463,76014-Nov-200323:56x86
Advapi32.dll5.0.2195.6824381,71214-Nov-200323:56x86
Browser.dll5.0.2195.686669,90414-Nov-200323:56x86
Dnsapi.dll5.0.2195.6824136,46414-Nov-200323:56x86
Dnsrslvr.dll5.0.2195.682496,01614-Nov-200323:56x86
Eventlog.dll5.0.2195.686647,37614-Nov-200323:56x86
Kdcsvc.dll5.0.2195.6871148,24014-Nov-200323:56x86
Kerberos.dll5.0.2195.6871205,58405-Nov-200319:32x86
Ksecdd.sys5.0.2195.682471,88821-set-200300:32x86
Lsasrv.dll5.0.2195.6869511,24829 ottobre 200306:45x86
Lsass.exe5.0.2195.686933,55229 ottobre 200306:45x86
Msv1_0.dll5.0.2195.6866114,96017 ottobre 200300:33x86
Netapi32.dll5.0.2195.6866307,98414-Nov-200323:56x86
Netlogon.dll5.0.2195.6863361,23214-Nov-200323:56x86
Ntdsa.dll5.0.2195.6874931,60014-Nov-200323:56x86
Samsrv.dll5.0.2195.6824392,46414-Nov-200323:56x86
Scecli.dll5.0.2195.6824113,93614-Nov-200323:56x86
Scesrv.dll5.0.2195.6824259,85614-Nov-200323:56x86
Sp3res.dll5.0.2195.68705,847,55206-Nov-200322:29x86
W32time.dll5.0.2195.682448,91214-Nov-200323:56x86
W32tm.exe5.0.2195.682457,10421-set-200300:32x86
Wldap32.dll5.0.2195.6869126,22414-Nov-200323:56x86

Nota: Applicare questo hotfix ai computer seguenti:
  • Controller di dominio che eseguono Windows 2000 o Windows Server 2003
  • Server membri che eseguono Windows Server 2003

Soluzione alternativa

Importante Questa sezione, metodo o attività contiene passaggi su come modificare il Registro di sistema. Tuttavia, una modifica errata del registro di sistema potrebbe causare gravi problemi. Pertanto, assicurarsi di seguire attentamente i passaggi. Per maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. Cosicché sia possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristinare il Registro di sistema, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
322756 come eseguire il backup e ripristinare il Registro di sistema Windows


Per risolvere il problema e per ridurre la frequenza dell'evento 677 ID evento ID 673 messaggi ed evento, aumentare il valore di timeout della cache S4U nel client Kerberos sul computer che eseguono Windows Server 2003:
  1. In un computer che esegue Windows Server 2003, fare clic su Start, scegliere Esegui, digitare regedite quindi fare clic su OK.
  2. Individuare e selezionare la seguente chiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\Kerberos\Parameters
  3. Dal menu Modifica , scegliere Nuovoe quindi fare clic su Valore DWORD.
  4. Digitare S4UCacheTimeoute quindi premere INVIO.
  5. Nella casella dati valore digitare il numero di minuti che si desidera specificare il valore di timeout e quindi fare clic su OK.

    Nota: Per impostazione predefinita, il valore di timeout della cache S4U è 15 minuti.
  6. Chiudere l'Editor del Registro di sistema.

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

Windows Server 2003 introduce il supporto per la delega vincolata nell'estensione del servizio-per-utente-a-Proxy (S4U2Proxy) di Kerberos. Utilizzando l'estensione di S4U2Proxy, un servizio può ottenere ticket a un altro servizio per un utente. Per ulteriori informazioni sulle estensioni Kerberos S4U, visitare il seguente sito Web Microsoft:Per ulteriori informazioni su LsaLogonUser, visitare il seguente sito Web Microsoft:
Per ulteriori informazioni sulla denominazione dei pacchetti di hotfix, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

816915 denominazione nuovo schema per i pacchetti di hotfix di Microsoft Windows

Per ulteriori informazioni sulla terminologia utilizzata per descrivere gli aggiornamenti software Microsoft, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:

824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Proprietà

ID articolo: 824905 - Ultima revisione: 30 gen 2017 - Revisione: 1

Feedback