Come inviare un modulo di InfoPath in una raccolta documenti di Windows SharePoint Services

INTRODUZIONE

Nella versione originale di Microsoft Office InfoPath 2003, è possibile inviare direttamente i dati del modulo in una raccolta documenti di Microsoft Windows SharePoint Services. In questo articolo viene descritto come progettare un modello di modulo che utilizza uno script per inviare i dati in una raccolta documenti di Windows SharePoint Services. In InfoPath 2003, Service Pack 1 (SP1) e versioni successive di InfoPath, è possibile inviare i dati del modulo in una raccolta documenti di Windows SharePoint Services direttamente tramite l'interfaccia utente. In questo articolo contiene la procedura da utilizzare per eseguire questa operazione.


Ulteriori informazioni

Progettazione di origine dati modulo e layout di InfoPath 2003

  1. Avviare InfoPath. Progettare un nuovo modulo vuoto.
  2. Nel riquadro attività Origine dati , aggiungere un'origine dati al form. A tale scopo, attenersi alla seguente procedura:
    1. Destro campiPersonalie quindi fare clic su Aggiungi.

      Verrà visualizzata la finestra di dialogo Aggiungi campo o gruppo .
    2. Digitare il nome del campo FirstName e quindi fare clic su OK.
    3. Ripetere r. passaggio di tipo MiddleInitial come nome del campo e quindi fare clic su OK.
    4. Ripetere r. passaggio di tipo LastName come nome del campo e quindi fare clic su OK.
  3. Aggiungere al form campiPersonali .
  4. Fare clic sulla sezione con controlli.

Progettazione di origine dati modulo e il layout in InfoPath 2007

  1. Avviare InfoPath 2007.
  2. Fare clic su Progetta modello di modulo, fare clic su vuotoe quindi fare clic su OK.
  3. Nel riquadro Attività di progettazione, fare clic su Origine dati.
  4. Destro campiPersonalie quindi fare clic su Aggiungi.
  5. Nella finestra Aggiungi campo o gruppo , digitare il nome del campo FirstName e quindi fare clic su OK.
  6. Nella finestra Aggiungi campo o gruppo , digitare una MiddleInitial come nome del campo e quindi fare clic su OK.
  7. Nella finestra Aggiungi campo o gruppo , digitare il nome del campo Cognome e quindi fare clic su OK.
  8. Aggiungere il gruppo campiPersonali al modulo e quindi fare clic su controlli nella tabella Layout.

Progettazione di origine dati modulo e il layout in InfoPath 2010

  1. Avviare InfoPath 2010.
  2. Nei Comuni modelli di modulo, fare clic su vuotoe quindi fare clic su Progetta modulo.
  3. Se non è disponibile un riquadro Attività di progettazione , fare clic su Origine dati.
  4. Se non è disponibile un riquadro campi visualizzato a destra, quindi nella scheda dati , fare clic su Mostra campi.
  5. Nella finestra Aggiungi campo o gruppo , digitare il nome del campo FirstName e quindi fare clic su OK.
  6. Aggiungere un altro campo. Nella finestra Aggiungi campo o gruppo , digitare una MiddleInitial come nome del campo e quindi fare clic su OK.
  7. Aggiungere un altro campo. Nella finestra Aggiungi campo o gruppo , digitare il nome del campo Cognome e quindi fare clic su OK.
  8. Aggiungere il gruppo campiPersonali al form.

Inviare i dati in una raccolta documenti di SharePoint Services

È possibile utilizzare script o l'interfaccia utente per inviare i dati alla raccolta documenti di SharePoint Services.

Utilizzare script per inviare i dati in una raccolta documenti di SharePoint Services in InfoPath 2003

  1. Scegliere Invio modulidal menu Strumenti .

    Verrà visualizzata la finestra di dialogo Invio moduli .
  2. Nella finestra di dialogo Invio moduli fare clic su Consentito.
  3. Nella finestra di INVIO , fare clic su Invia utilizzando uno Script personalizzato.
  4. Fare clic su Apri Microsoft Script Editore quindi fare clic su OK.

    Verrà avviato Microsoft Script Editor.
  5. Modificare come segue l'evento OnSubmitRequest .

    Nota: È necessario modificare il valore della variabile strURL a un URL valido nel codice. L'URL nel seguente esempio di codice fa riferimento a un server denominato ServerName, un sito di SharePoint denominato NomeSitoe una raccolta documenti denominata DocumentLibraryName.
    function XDocument::OnSubmitRequest(eventObj){
    // If the submit operation is successful, set
    // eventObj.ReturnStatus = true.
    var fSuccessful = false;

    // Set the URL of the file that you want to submit here.
    var strUrl = "http://ServerName/SiteName/DocumentLibraryName/testform.xml";

    try
    {
    // Create an xmlhttp object.
    var oXmlHttp = new ActiveXObject("MSXML2.XMLHTTP");

    // See whether the document with the same name already exists in the Windows SharePoint Services (WSS) document library.
    oXmlHttp.Open("HEAD", strUrl, false);
    oXmlHttp.Send();

    // No document with the URL has been found. Continue to submit.
    // If you must replace the original file, you must call
    // oXmlHttp.Open("DELETE", strUrl, false) to delete the document
    // in the WSS document library.
    if (oXmlHttp.Status == 404)
    {
    // Put the document in the WSS document library.
    oXmlHttp.Open("PUT", strUrl, false);
    oXmlHttp.Send(XDocument.DOM.xml);

    // A 200 status code or a 201 status code indicates that the form has been submitted successfully.
    if (oXmlHttp.Status == 200 || oXmlHttp.Status == 201)
    {
    fSuccessful = true;
    }
    }
    }
    catch (ex){}

    if (fSuccessful)
    {
    XDocument.UI.Alert("Document submitted successfully.");
    eventObj.ReturnStatus = true;
    }
    else
    {
    eventObj.ReturnStatus = false;
    }
    }

  6. Salvare lo script. Chiudere l'Editor di Script.
  7. Salvare il modello di modulo come SubmitToWSS.xsn.

Utilizzare l'interfaccia utente di inviare i dati del modulo in una raccolta documenti di SharePoint Services in InfoPath 2003 Service Pack 1

  1. Scegliere Invio modulidal menu Strumenti .

    Verrà visualizzata la finestra di dialogo Invio moduli .
  2. Nella finestra di dialogo Invio moduli fare clic su consentito tramite comandi e pulsanti.
  3. Nella sezione INVIO , fare clic su raccolta moduli di SharePoint.
  4. Nella finestra di dialogo Invio moduli fare clic su Aggiungi.

    Verrà avviata la Connessione guidata dati .
  5. Inserire il collegamento di raccolta di SharePoint Services form nella finestra di raccolta moduli di SharePoint .

    Il collegamento potrebbe essere simile al seguente:

    http://ServerName/SiteName/DocumentLibraryName
  6. Nella casella Nome File , digitare il nome del documento.

    È possibile utilizzare il nome di un documento, ad esempio TestForm.

    Fare clic su Avanti.
  7. Nella Connessione guidata dati, fare clic su Fine.
  8. Nella finestra di dialogo Invio moduli fare clic su OK.
  9. Salvare il modello di modulo come "SubmitToWSS.xsn".

Utilizzare l'interfaccia utente di inviare i dati del modulo in una raccolta documenti di SharePoint Services in InfoPath 2007

  1. Dal menu Strumenti , fare clic su Opzioni di invio.

    Verrà visualizzata la finestra di dialogo Opzioni invio .
  2. Nella finestra di dialogo Opzioni invio , fare clic su Consenti agli utenti di inviare il modulo.
  3. Fare clic per selezionare la casella di controllo Invia dati modulo a una singola destinazione .
  4. Nell'elenco a discesa, fare clic su Raccolta documenti di SharePoint.
  5. Nella finestra di dialogo Opzioni invio , fare clic su Aggiungi.

    Verrà avviata la Connessione guidata dati .
  6. Digitare il collegamento di raccolta documenti di SharePoint nella casella di Raccolta documenti .

    Il collegamento al documento libreria potrebbe simile al seguente:
    http://ServerName/SiteName/DocumentLibraryName
  7. Nella casella Nome File , digitare il nome del documento.

    È possibile utilizzare il nome di un documento, ad esempio TestForm.
  8. Fare clic su Avanti.
  9. Nella casella Immettere un nome per la connessione dati , digitare un nome per la connessione dati.
  10. Nella connessione guidata dati, fare clic su Fine.
  11. Nella finestra di dialogo Opzioni invio , fare clic su OK.
  12. Salvare il modello di modulo come SubmitToWSS2007.xsn.

Utilizzare l'interfaccia utente di inviare i dati del modulo in una raccolta documenti di SharePoint Services in InfoPath 2010

  1. Nella scheda dati , fare clic su Opzioni di invio.

    Verrà visualizzata la finestra di dialogo Opzioni invio .
  2. Nella finestra di dialogo Opzioni invio , fare clic su Consenti agli utenti di inviare il modulo.
  3. Fare clic per selezionare la casella di controllo Invia dati modulo a una singola destinazione .
  4. Nell'elenco a discesa, fare clic su Raccolta documenti di SharePoint.
  5. Nella finestra di dialogo Opzioni invio , fare clic su Aggiungi.

    Verrà avviata la Connessione guidata dati .
  6. Digitare il collegamento di raccolta documenti di SharePoint nella casella di Raccolta documenti .

    Il collegamento al documento libreria potrebbe simile al seguente:
    http://ServerName/SiteName/DocumentLibraryName
  7. Nella casella Nome File , digitare il nome del documento.

    È possibile utilizzare il nome di un documento, ad esempio TestForm.
  8. Fare clic su Avanti.
  9. Nella casella Immettere un nome per la connessione dati , digitare un nome per la connessione dati.
  10. Nella connessione guidata dati, fare clic su Fine.
  11. Nella finestra di dialogo Opzioni invio , fare clic su OK.
  12. Salvare il modello di modulo come SubmitToWSS2010.xsn.

Controllare il modulo in InfoPath 2003

  1. Dal menu File , fare clic su Compila modulo.
  2. Nel riquadro attività Compila modulo , fare clic su SubmitToWSS.
  3. Completare il modulo.
  4. Dal menu File , fare clic su Invia.

    Se il modulo viene inviato correttamente, viene visualizzato un messaggio che indica che si.
  5. Chiudere InfoPath. Se viene chiesto di salvare le modifiche apportate al modulo, fare clic su No.
  6. Avviare Microsoft Internet Explorer. Individuare la raccolta moduli di documento.

    Ad esempio, la raccolta moduli di documento può essere http://ServerName/SiteName/DocumentLibraryName.

    Un nuovo elemento denominato testform è nella raccolta documenti.
  7. Fare clic su testform.

    Verrà aperto il modulo inviato in InfoPath 2003.

Controllare il modulo in InfoPath 2007

  1. Dal menu File , fare clic su Compila modulo.
  2. Nel riquadro attività Compila modulo , fare clic su SubmitToWSS2007.
  3. Completare il modulo.
  4. Dal menu File , fare clic su Invia.

    Se il modulo viene inviato correttamente, viene visualizzato un messaggio che indica che si.
  5. Chiudere InfoPath. Se viene chiesto di salvare le modifiche apportate al modulo, fare clic su No.
  6. Avviare Windows Internet Explorer. Individuare la raccolta moduli di documento.

    Ad esempio, la raccolta di documenti modulo potrebbe essere http://nomeserver/NomeSito/DocumentLibraryName.

    Un nuovo elemento denominato testform è nella raccolta documenti.
  7. Fare clic su testform.

    In InfoPath 2007 verrà aperto il modulo inviato.

Controllare il modulo in InfoPath 2010

  1. Avviare InfoPath Filler 2010
  2. Fare clic su Trova un modulo.
  3. Trova SubmitToWSS2010.xsn, selezionarlo e quindi fare clic su Apri.
  4. Completare il modulo.
  5. Dal menu File , fare clic su Invia.

    Se il modulo viene inviato correttamente, viene visualizzato un messaggio che indica che si.
  6. Chiudere InfoPath Filler. Se viene chiesto di salvare le modifiche apportate al modulo, fare clic su Non salvare.
  7. Avviare Windows Internet Explorer. Individuare la libreria del documento specificato nel passaggio 6 di "Uso dell'interfaccia utente di inviare i dati del modulo in una raccolta documenti di SharePoint Services in InfoPath 2010."

    Verrà visualizzato un nuovo elemento di modulo nella raccolta documenti, e il tuo nome apparirà nella colonna Modificata .
  8. Fare clic su nuovo elemento di Form.

    Verrà aperto il modulo inviato in InfoPath 2010.

Riferimenti

Per ulteriori informazioni su come ottenere il service pack più recente per Microsoft Office, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:

870924 come ottenere il service pack più recente per Office 2003

Per ulteriori informazioni su come script con i moduli di InfoPath 2003, fare clic sui numeri per visualizzare gli articoli della Microsoft Knowledge Base riportato di seguito:

828853 come modificare il linguaggio di script per il modulo di InfoPath

827002 come eseguire il debug di uno script per un modulo di Microsoft Office InfoPath 2003

Proprietà

ID articolo: 826993 - Ultima revisione: 30 gen 2017 - Revisione: 1

Feedback