Un'applicazione di Office è lenta o potrebbe non rispondere (bloccarsi) quando si apre un file da un percorso di rete

Sintomi

Quando si tenta di aprire un file da un percorso di rete in una delle applicazioni di Microsoft Office, ad esempio PowerPoint 2003, Excel 2003, Publisher 2003 o versione successiva, tale applicazione potrebbe funzionare molto lentamente o non rispondere (bloccato).

Causa

Questo comportamento può verificarsi se la connessione al percorso di rete viene persa nel momento in cui l'applicazione di Office apre il file.

Soluzione alternativa

Importante

In questa sezione, metodo o attività viene illustrata la procedura per modificare il Registro di sistema. Poiché l'errata modifica del Registro di sistema può causare seri problemi, Di conseguenza, attenersi scrupolosamente alla procedura indicata. Per una maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. In questo modo sarà possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire backup e ripristino del Registro di sistema, vedere Backup e ripristino del Registro di sistema in Windows.

Per risolvere questo problema, aggiungere il valore EnableShellDataCaching al Registro di sistema di Microsoft Windows. A tal fine, attenersi alla seguente procedura:

  1. Chiudere le applicazioni di Office.

  2. Fare clic su Start quindi scegliere Esegui.

  3. Nella casella Apri, digitare regedit e quindi fare clic su OK.

  4. Individuare e selezionare una delle seguenti sottochiavi del Registro di sistema di conseguenza:

    • Microsoft 365 Apps, Office LTSC 2021, Office 2019 e Office 2016:

      HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Open Find

    • Office 2013:

      HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Open Find

    • Office 2010:

      HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Open Find

    • Office 2007:

      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\Open Find

    • Office 2003:

      HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\Open Find

  5. Dopo aver selezionato la chiave specificata nel passaggio 4, selezionare Nuovo dal menu Modifica e quindi fare clic su Valore DWORD.

  6. Digitare EnableShellDataCaching e quindi premere INVIO.

  7. Fare clic con il pulsante destro del mouse su EnableShellDataCaching e selezionare Modifica.

  8. Nella casella Dati valore digitare 1, quindi fare clic su OK.

    Nota

    Qualsiasi numero diverso da zero nella casella Dati valore attiverà la memorizzazione nella cache. Un numero uguale a zero o un campo vuoto (impostazione predefinita) disattiverà la memorizzazione nella cache.

  9. Scegliere Esci dal menu File per chiudere l'editor del Registro di sistema.

Il problema è stato risolto?

Verificare se il problema è stato risolto. Se il problema è stato risolto, non occorre leggere il resto della sezione. Se il problema persiste, è possibile contattare il Supporto tecnico.

Ulteriori informazioni

Questa situazione può verificarsi dopo aver fatto clic su Apri nella finestra di dialogo Apri (nel menu File, fare clic su Apri) per aprire un file da un percorso di rete (ad esempio un server di rete). Durante il processo di apertura del file, la connessione di rete viene persa oppure il percorso di rete contenente il file che si sta tentando di aprire non è più valido. Durante il processo di apertura del file, l'applicazione di Office tenta di aggiungere il nome del file e le informazioni sul percorso del file che si sta tentando di aprire all'elenco dei file recenti di Windows. Poiché il percorso di rete (percorso) non esiste, l'applicazione di Office potrebbe funzionare lentamente e non rispondere (bloccata).

Nota

Questa situazione può verificarsi anche se la connessione alla rete è lenta perché l'applicazione di Office deve eseguire più query alla rete per ottenere le informazioni corrette sul file.