Numerosi processi orfani di Csrss.exe causano problemi di prestazioni su un server terminal che esegue Windows 2000 o Windows Server 2003

Sintomi

Nel computer basato su Microsoft Windows 2000 Server o computer basato su Microsoft Windows Server 2003 che esegue Servizi Terminal, possono verificarsi i seguenti sintomi:
  • Il server diventa lento e bloccarsi. Infine, è possibile stabilire nuove sessioni di servizi Terminal.
  • Se si utilizza Task Manager per visualizzare i processi in esecuzione, si può vedere che esistono numerosi processi orfani di Csrss.exe. Non esistono sessioni client Servizi Terminal corrispondente quando si visualizza le sessioni in Gestione servizi Terminal.
  • È possibile arrestare i processi isolati di Csrss.exe per liberare le risorse del server. Pertanto, i processi di Csrss.exe che continuano ad accumularsi fino a quando non è necessario riavviare il server per liberare risorse di memoria e CPU.
Se si applica l'aggiornamento rapido descritto nell'articolo della Microsoft Knowledge Base 827350, ciò può contribuire a ridurre il numero di processi Csrss.exe, ma il problema persiste.
827350 Impossibile connettersi a un server terminal quando Csrss.exe e Termsrv.exe raggiungere il 100% della CPU

Causa

Il problema si verifica a causa di una regressione introdotta in Windows 2000 Service Pack 3 (SP3). Windows 2000 SP3 include una correzione che introduce un oggetto temporaneo winstation nel processo di Csrss.exe. Questa correzione è descritta nel seguente articolo della Microsoft Knowledge Base:
261322 stop 0x0000001E messaggio di errore quando si stampa da un client di servizi Terminal di Windows 2000

Se gli oggetti temporanei winstation non vengono rilasciati in modo corretto, possono verificarsi i sintomi descritti in precedenza in questo articolo.

Risoluzione

Informazioni sull'hotfix

Windows Server 2003

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:Nota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Non è richiesto alcun prerequisito.

Richiesta di riavvio

Dopo avere applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in ora UTC (coordinated universal time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nello strumento Data e ora nel Pannello di controllo.
Windows Server 2003, versioni basate su x86
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Winsrv.dll5.2.3790.170291,84004-May-200423:28x86

Windows Server 2003, versioni basate su Itanium
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Winsrv.dll5.2.3790.170764,92804-May-200408:22IA-64

Windows 2000

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:Nota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per installare questo hotfix, è necessario disporre di Windows 2000 Service Pack 3 (SP3) è installato nel computer.

Richiesta di riavvio

Dopo avere applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.
Nome del fileVersione del fileDimensione del fileDataOraPiattaformaRamo del servizio
Basesrv.dll5.0.2195.682442,25624-Mar-200402:17x86Non applicabile
Cmd.exe5.0.2195.6824236,30421-Sep-200300:45x86Non applicabile
Gdi32.dll5.0.2195.6660233,74419-Jun-200320:05x86Non applicabile
Kernel32.dll5.0.2195.6897742,16024-Mar-200402:17x86Non applicabile
Mpr.dll5.0.2195.682454,54424-Mar-200402:17x86Non applicabile
Msgina.dll5.0.2195.6958335,12013-Jul-200421:25x86Non applicabile
Rdpwd.sys5.0.2195.689290,26424-Mar-200402:17x86Non applicabile
Sp3res.dll5.0.2195.69355,887,48804-Jun-200423:13x86Non applicabile
User32.dll5.0.2195.6897403,21624-Mar-200402:17x86Non applicabile
Userenv.dll5.0.2195.6794385,80805-Aug-200322:14x86Non applicabile
Win32k.sys5.0.2195.69581,631,76010-Jul-200405:36x86Non applicabile
Winlogon.exe5.0.2195.6898181,52011-Mar-200402:37x86Non applicabile
Winsrv.dll5.0.2195.6958244,49613-Jul-200421:25x86Non applicabile
Kernel32.dll5.0.2195.6897742,16024-Mar-200402:17x86UNIPROC
Win32k.sys5.0.2195.69581,631,76010-Jul-200405:36x86UNIPROC
Winsrv.dll5.0.2195.6958244,49613-Jul-200421:25x86UNIPROC

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Questa funzionalità era prima incluso in Windows Server 2003 Service Pack 1.

Ulteriori informazioni

Per ulteriori informazioni sulla denominazione pacchetti di hotfix, fare clic sui numeri per visualizzare gli articoli della Microsoft Knowledge Base riportato di seguito:

816915 nuovo schema di denominazione per i pacchetti di hotfix di Microsoft Windows

824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Supporto tecnico per versioni basate su x64 di Microsoft Windows

Se l'hardware fornito con un'edizione di Microsoft Windows x64 è già installata, il produttore dell'hardware offre supporto tecnico e assistenza per Windows x64 edition. In questo caso, il produttore dell'hardware fornisce supporto poiché una Windows x64 edition è stato inclusa con l'hardware. Il produttore dell'hardware potrebbe avere personalizzato l'installazione di Windows x64 utilizzando componenti univoci. Quali specifici driver di periferica o impostazioni facoltative per ottimizzare le prestazioni dell'hardware. Microsoft fornirà assistenza ragionevole sforzo per assistenza tecnica con una versione x64 di Windows. Tuttavia, potrebbe essere necessario contattare direttamente il produttore. Il soggetto più qualificato per supportare il software preinstallato sull'hardware. Se è stata acquistata separatamente una versione x64 di Windows come un'edizione di Microsoft Windows Server 2003 x64, contattare il supporto tecnico Microsoft.

Per informazioni su Microsoft Windows XP Professional x64 Edition, visitare il seguente sito Web Microsoft:Per informazioni sulle versioni basate su x64 di Microsoft Windows Server 2003, visitare il seguente sito Web Microsoft:
Proprietà

ID articolo: 837585 - Ultima revisione: 30 gen 2017 - Revisione: 1

Feedback