I programmi client FTP in modalità attiva non possono accedere a un server FTP da Internet Security and Acceleration Server 2004

Sintomi

Si supponga che si è connessi a una rete in Microsoft Internet Security and Acceleration (ISA) Server 2004, e quindi si tenta di accedere a un server FTP File Transfer Protocol () che è connesso a una rete diversa. In questo scenario, è possibile che si verifichi uno dei seguenti sintomi:
  • Se si tenta di utilizzare Microsoft Internet Explorer per aprire una cartella che si trova sul server FTP, viene visualizzato il seguente messaggio di errore:
    Windows non può accedere a questa cartella. Assicurarsi di aver digitato correttamente il nome del file e di disporre dell'autorizzazione per accedere alla cartella.



    Dettagli: Timeout dell'operazione.
  • Se si tenta di utilizzare un programma client FTP come SmartFTP per aprire una cartella che si trova sul server FTP, viene visualizzato il seguente messaggio di errore:
    425 Impossibile aprire la connessione dati.

Causa

Questo problema si verifica se sono vere le seguenti condizioni:
  • Il programma Client Firewall di ISA Server 2004 è installato e attivato.
  • È selezionata la casella di controllo Attiva la visualizzazione cartella per i siti FTP in Internet Explorer.

    Nota: Se questa casella di controllo è selezionata, Internet Explorer presenta lo stesso comportamento di un tipico programma client FTP. Questo comportamento è descritto nella RFC 959. Se questa casella di controllo non è selezionata, le richieste FTP in Internet Explorer viene inviata al server proxy Web come richieste HTTP.

    Alla visualizzazione RFC 959, visitare il seguente sito Web gruppo di lavoro di rete:Microsoft fornisce informazioni di contatto di terze parti per facilitare l'individuazione del supporto tecnico. Tali informazioni potrebbero cambiare senza preavviso. Microsoft non garantisce l'accuratezza delle informazioni per contattare altri produttori.
  • La casella di controllo Usa FTP passivo non è selezionata in Internet Explorer.

    Nota: Questa casella di controllo Controlla se Internet Explorer utilizza la modalità attiva o passiva FTP.
Per individuare queste caselle di controllo, attenersi alla seguente procedura:
  1. Avviare Internet Explorer.
  2. Dal menu Strumenti scegliere Opzioni Internet.
  3. Fare clic sulla scheda Avanzate e in esplorazione, individuare le caselle di controllo seguenti:
    Attiva la visualizzazione cartella per i siti FTP
    Usa FTP passivo
Questo problema si verifica se sono vere le seguenti condizioni:
  • Utilizzare il programma client FTP della riga di comando Ftp.exe.
  • Il programma Client Firewall non è installato e il computer è configurato come client SecureNAT.

Risoluzione

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:Nota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per installare questo hotfix è richiesto alcun prerequisito.

Richiesta di riavvio

Non è necessario riavviare il computer dopo avere applicato questo hotfix.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in ora UTC (coordinated universal time). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nello strumento Data e ora nel Pannello di controllo.
   Date         Time   Version            Size    File name   ----------------------------------------------------------
20-Sep-2004 4.0.2161.8573,464 Ftpfltr.dll

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

I prodotti di terze parti descritti in questo articolo sono forniti da società indipendenti da Microsoft. Microsoft esclude ogni garanzia, implicita o esplicita, relativamente alle prestazioni o all'affidabilità di questi prodotti.

Proprietà

ID articolo: 884580 - Ultima revisione: 30 gen 2017 - Revisione: 1

Feedback