Importante
Questo articolo descrive un problema di compatibilità noto tra Adobe Acrobat 7.0 e le versioni precedenti di Microsoft Office. Se si usa una versione corrente di Microsoft 365 o una versione più recente di Adobe Acrobat, questo articolo potrebbe non essere applicabile al proprio ambiente.
Sintomi
Quando si usa un'applicazione di Microsoft Office elencata nella sezione "Si applica a", è possibile che si verifichino uno o più dei sintomi seguenti:
Quando si cambia l'area di lavoro in Microsoft Word, le modifiche non vengono salvate quando si esce da Word. Queste modifiche all'area di lavoro includono gli esempi seguenti:
- Si crea una macro.
- Viene modificato il tipo di carattere predefinito.
- Si aggiunge una voce di Glossario.
- Aggiungere una barra degli strumenti.
Al riavvio di Word, gli elementi modificati o aggiunti non sono disponibili.
Nota: questo comportamento si verifica anche se la casella di controllo Richiedi di salvare modello normale è selezionata.
Quando si tenta di avviare un'applicazione di Office, viene visualizzato un messaggio di errore simile a uno dei seguenti:
Nota
Errore di runtime di Visual C++
Nota
Libreria di runtime di Microsoft Visual C++
Programmi\Microsoft office\office10\nome prodotto.exe
Questa applicazione ha richiesto al runtime di terminarla in modo insolito.
Quando si apre un documento di Word, viene visualizzato il messaggio di errore seguente:
Nota
Memoria o spazio su disco insufficiente. Word non riesce a visualizzare il tipo di carattere richiesto.
Quando Word viene chiusa, è necessario fare doppio clic su un file per aprirlo in Word. In questo scenario, Word smette di rispondere (si blocca).
Causa
Questi problemi possono verificarsi dopo l'installazione di Adobe Acrobat 7.0 Professional, Adobe Acrobat 7.0 Standard o Adobe Acrobat 7.0 Elements.
Acrobat 7.0 installa un componente aggiuntivo COM nella seguente cartella:
\Acrobat 7.0\PDFMaker\OfficeQuesto componente aggiuntivo COM fornisce le icone PDFMaker e i comandi di menu per le applicazioni di Office.
Soluzione alternativa
Per ovviare a questo problema, utilizzare uno dei seguenti metodi, a seconda della situazione. Se le modifiche non vengono salvate quando si chiude Word, usare il metodo 1 o il metodo 2. Se viene visualizzato un messaggio di errore quando si tenta di avviare un programma di Office o quando si cerca di aprire un documento di Word, usare il metodo 3 o il metodo 4.
Metodo 1: salvare macro, preferenze e impostazioni personalizzate in Word usando il comando "Salva tutto" nel menu File
Nota: questo metodo non si applica a Microsoft Office Word 2007.
Per salvare manualmente macro, preferenze e impostazioni personalizzate in Word 2003 e nelle versioni precedenti di Word, eseguire le operazioni seguenti:
- Tenere premuto MAIUSC.
- Scegliere Salva tutto dal menu File.
Le modifiche vengono salvate. Inoltre, le modifiche sono disponibili in altri documenti di Word.
Metodo 2: aggiungere il comando "Salva tutto"
In Word fare clic sul comando Salva tutto ogni volta che si crea una macro, una preferenza o un'impostazione personalizzata.
Per aggiungere il comando Salva tutto in Word, eseguire una delle azioni seguenti:
In Word 2007 eseguire i passaggi seguenti per aggiungere il comando Salva tutto alla barra di accesso rapido:
- Fare clic sul pulsante Microsoft Office e quindi su Opzioni di Word.
- Fai clic su Personalizza.
- Nella casella Scegli comandi da fare clic su Tutti i comandi.
- Nell'elenco sotto la casella Scegli comandi da fare clic su Salva tutto e quindi su Aggiungi.
- Fare clic su OK per chiudere la finestra di dialogo Opzioni di Word.
In Word 2003 e nelle versioni precedenti di Word, seguire questa procedura per aggiungere il comando Salva tutto al menu File:
- Scegliere Personalizza dal menu Strumenti.
- Nella scheda Comandi , fare clic su File in Categorie.
- In Comandi, trascina Salva tutto nel menu File . Quando si apre il menu File , posizionare il comando Salva tutto nella posizione desiderata.
- Chiudere la finestra di dialogo Personalizza .
Metodo 3: contattate Adobe
Contattate Adobe Systems Incorporated per determinare se è disponibile un aggiornamento per Acrobat 7.0.
Microsoft fornisce informazioni di contatto di terze parti per aiutarti a trovare il supporto tecnico. Le informazioni di contatto sono soggette a modifica senza preavviso. Microsoft non garantisce l'accuratezza di queste informazioni di contatto di terze parti.
Metodo 4: rimuovere il componente aggiuntivo Adobe da Office
Se rimuovete il componente aggiuntivo Adobe, non potete salvare un file come file PDF (Portable Document File) in un'applicazione di Office.
Per rimuovere il componente aggiuntivo Adobe, effettuate le seguenti operazioni.
Nota: poiché esistono diverse versioni di Microsoft Windows, i passaggi seguenti potrebbero essere diversi nel computer in uso. In caso affermativo, consultare la documentazione del prodotto per completare questi passaggi.
- Chiudere tutte le applicazioni.
- Fare clic sul pulsante Start, scegliere Impostazioni, quindi Pannello di controllo.
- Fare doppio clic su Installazione applicazioni.
- In Programmi attualmente installati, fare clic su Adobe Acrobat Professional 7.0, quindi su Cambia.
- Fare clic su Modifica (Modify), quindi su Next (Avanti).
- Espandere Crea Adobe PDF.
- Espandere Acrobat PDFMaker.
- Fare clic sulla freccia accanto a Microsoft Office, quindi su Non installato.
- Nell'installazione guidata di Adobe Acrobat Professional 7.0, fare clic su OK.
- Chiudi Installazione applicazioni.
Se riscontri ancora i sintomi menzionati in precedenza dopo aver completato questi passaggi, potresti voler rimuovere manualmente il componente aggiuntivo Adobe dal registro.
Importante Prima di rimuovere manualmente il componente aggiuntivo Adobe, contattate Adobe per ulteriori informazioni.
Importante: in questa sezione, metodo o attività viene illustrata la procedura per modificare il Registro di sistema. Tuttavia, la modifica non corretta del Registro di sistema può causare problemi gravi. Assicurarsi, quindi, di seguire attentamente tutti i passaggi. Per una maggiore sicurezza, eseguire un backup del Registro di sistema prima di modificarlo, in modo che sia possibile ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup e il ripristino del Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322756 Come eseguire il backup e il ripristino del Registro di sistema in Windows
Per rimuovere manualmente il componente aggiuntivo Adobe, effettuate le seguenti operazioni:
Fare clic sul pulsante Start, scegliere Esegui, digitare regedit, quindi fare clic su OK.
Individuare e fare clic sulla sottochiave del Registro di sistema seguente:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddinScegliere Esporta dal menu File, digitare un nome per il file e quindi fare clic su Salva.
Fare clic con il pulsante destro del mouse sulla voce del Registro di sistema PDFMaker.OfficeAddin e quindi scegliere Elimina.
Eseguire i passaggi 3 e 4 per eliminare le voci del componente aggiuntivo del Registro di sistema nelle sottochiavi del Registro di sistema seguenti:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\Addins\PDFMaker.OfficeAddin
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outlook\Addins\PDFMOutlook.PDFMOutlook
Chiudere l'editor del Registro di sistema.
Altre informazioni
Il modello globale, ovvero il file Normal.dotm in Word 2007 e il file Normal.dot in Word 2003 e nelle versioni precedenti di Word, è il modello predefinito utilizzato da Word. Per impostazione predefinita, le modifiche che interessano tutti i nuovi documenti vengono salvate nel modello globale. Questo comportamento si verifica a meno che non si specifichi un altro modello quando si salvano le modifiche. Acrobat 7.0 può impedire a Word di salvare automaticamente le modifiche al modello globale.
Per ulteriori informazioni sul problema, visitare il seguente sito Web di Adobe: