L'installazione guidata stampante o l'interruzione della casella finestra di dialogo della stampante su un computer basato su Windows Server 2003, basato su Windows XP o basato su Windows 2000

Sintomi

Si verifichi uno o più dei seguenti problemi della stampante in un computer che esegue Microsoft Windows Server 2003, Microsoft Windows XP o Microsoft Windows 2000:
  • Quando si tenta di aprire la finestra di dialogo Stampa, impiegato molto tempo.
  • Quando si utilizza l'installazione guidata stampante per installare una stampante di rete che è ospitata su un server che esegue il servizio SMB, la stampante potrebbe bloccarsi. Il problema si verifica dopo avere copiati i file del driver.


  • Quando si seleziona una stampante di rete diverso nella casella nome di stampante nell'installazione guidata stampante, potrebbe esistere un ritardo prima che venga applicata la modifica. Questo problema può verificarsi anche se le condizioni nella sezione "Cause" non si applicano alla stampante di rete selezionato.

Causa

Questo problema si verifica a causa di un bug nello spooler (Spoolss. dll). Questo problema si verifica se sono vere le seguenti condizioni:

  • La dimensione della struttura DEVMODE dal driver della stampante utilizzata è maggiore di 4.096 byte.

  • Il nome della stampante ha un numero dispari di caratteri. Nel nome della stampante di rete seguenti, ad esempio, MyPrinterName contiene un numero dispari di caratteri (13):

    \\SMBPrinterServer\MyPrinterName
    Il problema non si verifica se il nome della stampante è un numero pari di caratteri.

Risoluzione

Informazioni sul service pack di Windows Server 2003

Per risolvere questo problema, procurarsi il service pack più recente per Windows Server 2003. Per ulteriori informazioni, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

Informazioni sull'hotfix per Windows Server 2003

Prerequisiti

Per applicare questo hotfix, è necessario disporre di Windows Server 2003 Service Pack 1 (SP1) installato nel computer.

Nota: Windows Server 2003, versioni basate su x64 non richiedono Windows Server 2003 SP1 applicare questo hotfix.

Richiesta di riavvio

Dopo avere applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.

Informazioni sui file

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:Nota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua. Versione inglese di di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di data e ora nel Pannello di controllo.
Windows Server 2003, versioni basate su x64
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Spoolss.dll5.2.3790.2805167,93604-Oct-200617:31x64
Windows Server 2003, versioni basate su Itanium
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Spoolss.dll5.2.3790.2805253,95204-Oct-200617:32IA-64
Windows Server 2003, versioni basate su x86
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Spoolss.dll5.2.3790.280587,55204-Oct-200617:15x86

Informazioni sull'hotfix per Windows XP

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:Nota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Non è richiesto alcun prerequisito.

Richiesta di riavvio

Dopo avere applicato questo hotfix, è necessario riavviare il computer.
Informazioni sulla sostituzione dell'aggiornamento rapido
Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di data e ora nel Pannello di controllo.
Windows XP, versioni basate su x86
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Spoolss.dll5.1.2600.300874,75204-Oct-200617:13x86

Windows 2000

Per risolvere questo problema in Windows 2000, utilizzare un numero pari di caratteri per il nome della stampante.

Stato

Microsoft ha confermato che si tratta di un problema nei prodotti Microsoft elencati nella sezione "Si applica a". Il problema è stato risolto in Windows Server 2003 Service Pack 2.

Ulteriori informazioni

Per ulteriori informazioni, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Supporto tecnico per versioni basate su x64 di Microsoft Windows

Il produttore dell'hardware offre supporto tecnico e assistenza per le versioni basate su x64 di Windows. Il produttore dell'hardware fornisce supporto poiché versioni basate su x64 di Windows è stato incluso con l'hardware. Il produttore dell'hardware potrebbe avere personalizzato l'installazione di Windows con particolari componenti. Quali specifici driver di periferica o impostazioni facoltative per ottimizzare le prestazioni dell'hardware. Microsoft fornirà assistenza ragionevole sforzo per ulteriore assistenza tecnica con la versione basata su x64 di Windows. Tuttavia, potrebbe essere necessario contattare direttamente il produttore. Il soggetto più qualificato per supportare il software preinstallato sull'hardware.

Per informazioni su Microsoft Windows XP Professional x64 Edition, visitare il seguente sito Web Microsoft:Per informazioni sulle versioni basate su x64 di Microsoft Windows Server 2003, visitare il seguente sito Web Microsoft:
Proprietà

ID articolo: 917777 - Ultima revisione: 30 gen 2017 - Revisione: 1

Microsoft Windows Server 2003, Datacenter Edition (32-bit x86), Microsoft Windows Server 2003, Enterprise Edition (32-bit x86), Microsoft Windows Server 2003, Standard Edition (32-bit x86), Microsoft Windows Server 2003, Web Edition, Microsoft Windows XP Professional, Microsoft Windows XP Home Edition, Microsoft Windows 2000 Advanced Server, Microsoft Windows 2000 Professional Edition, Microsoft Windows 2000 Server

Feedback