Potrebbero verificarsi problemi di prestazioni quando si lavora con gli elementi in un file pst di grandi dimensioni o in un file di grandi dimensioni ost in Outlook 2007

Sintomi


Microsoft Office Outlook 2007 momentaneamente si blocca durante le normali operazioni. Sono inclusi quando si leggono i messaggi di posta elettronica, messaggi di posta elettronica di spostare o eliminare i messaggi di posta elettronica.

Questi sintomi sono più evidenti durante il recapito della posta o durante la sincronizzazione. Questi sintomi diventano più evidente come archivio di dimensioni maggiori. Sono più probabile che si verifica quando la dimensione del file pst o la dimensione del file ost approssimativamente i 2 gigabyte (GB). Inoltre, sono più pronunciato in un file pst di dimensioni molto grandi o in un file con estensione ost molto grandi di 4 GB o superiore.



Nota: Quando si eseguono le stesse operazioni eseguite nelle versioni precedenti di Outlook, gli stessi problemi di prestazioni non si verificano se il file pst o ost è grande.

Causa

Per supportare le nuove funzionalità, Outlook 2007 ha introdotto una nuova struttura di dati per i file pst e ost. In questa nuova struttura di dati, la frequenza di scrittura di dati sul disco rigido aumenta man mano che il numero di elementi i file pst o ost file aumenta.

Nota: Non è possibile creare un file con estensione pst o ost senza questa nuova struttura di dati.

Risoluzione

Per risolvere questo problema, installare l'aggiornamento descritto nel seguente articolo della Microsoft Knowledge Base:
933493 descrizione dell'aggiornamento per Outlook 2007: 13 aprile 2007

933493 è disponibile per migliorare la capacità di risposta generale di Outlook 2007 durante le operazioni più comuni. Queste operazioni includono la lettura, lo spostamento, eliminazione e il download dei messaggi di posta elettronica per gli utenti che dispongono di cassette postali di grandi dimensioni file (file con estensione pst e ost) archiviati nei loro computer. Dal punto di vista tecnico, questo aggiornamento consente di ottimizzare il modello in cui Outlook 2007 scrive in un file pst di grandi dimensioni o in un file ost di grandi dimensioni. Ciò comporta una riduzione dell'accesso al disco.

Questo aggiornamento per Outlook 2007 è parte del nostro impegno continuo a migliorare l'esperienza relativa ai prodotti dei nostri clienti. Siamo consapevoli che alcuni clienti hanno rilevato problemi di prestazioni durante l'esecuzione di Outlook 2007. Questo aggiornamento include diversi miglioramenti delle prestazioni. Questo aggiornamento è progettato per eseguire le operazioni seguenti:
  • Ridurre il tempo necessario per copiare o spostare messaggi da una cartella in un'altra cartella.
  • Aumentare la velocità di download quando si scaricano i messaggi.
  • Ridurre il tempo necessario per eliminare i messaggi.

Ulteriori informazioni

È possibile utilizzare uno dei seguenti metodi per risolvere o evitare questo problema.

Video: Come ridurre le dimensioni del file pst di Outlook


Metodo 1: Ridurre la dimensione della cassetta postale di Exchange

Se si riduce la dimensione della cassetta postale di Exchange, si riduce anche la dimensione del file ost. Per ridurre la dimensione della cassetta postale di Exchange, eseguire una o più delle operazioni seguenti:
  • Eliminare gli elementi nella cassetta postale.
  • Archiviare gli elementi nella cassetta postale in uno o più file pst.
È possibile eliminare gli elementi o archiviare gli elementi manualmente. In alternativa, è possibile utilizzare Pulitura cassetta postale. Per utilizzare Pulitura cassetta postale in Outlook 2007, fare clic su
Riordino cassetta postale dal menu Strumenti . Nella finestra di dialogo Pulitura cassetta postale , è possibile utilizzare una qualsiasi delle seguenti funzionalità:
  • Visualizza dimensione cassetta postale.
  • Trovare gli elementi che risalgono a più di un numero di giorni specificato.
  • Trovare gli elementi che superano la dimensione specificata.
  • Sposta i vecchi elementi nel file di archivio, fare clic su
    Archiviazione automatica.
  • Svuotare la cartella Posta eliminata.
  • Eliminare tutte le versioni alternative di elementi nella cassetta postale.

Metodo 2: Utilizzare un profilo in modalità in linea anziché un profilo in modalità cache

Profili in modalità cache di un file ost per memorizzare la cassetta postale locale sul disco rigido. Se si dispongono di cassette postali di Exchange, è un file ost di dimensioni ancora maggiore. Ad esempio, se la dimensione della cassetta postale è 350 megabyte (MB), la dimensione del file ost può essere 475 MB o superiore.

Metodo 3: Dividere il file pst di grandi dimensioni in più file pst più piccoli

Outlook 2007 non dispone di una funzione incorporata per suddividere un file pst in più file pst. Pertanto, è necessario utilizzare una delle seguenti operazioni per dividere un file pst di grandi dimensioni:
  1. Utilizzare la funzione di archiviazione per spostare elementi in un nuovo file pst. A tale scopo, attenersi alla seguente procedura:
    1. In Outlook 2007, selezionare il file pst nel riquadro di spostamento.
    2. Dal menu File , fare clic su
      Archivio.
    3. Nella finestra di dialogo Archivia , fare clic per selezionare la casella di controllo Archivia la cartella e tutte le sottocartelle e quindi fare clic su una cartella dall'elenco.
    4. Nella casella di riepilogo Archivia elementi antecedenti , fare clic su una data.
    5. Fare clic su Sfoglia, specificare un percorso e un nome per il nuovo file pst e quindi fare clic su OK.

      Nota: Il nuovo file pst viene visualizzato nell'elenco Cartelle di posta elettronica come
      Cartelle di archiviazione.
    Se si desidera modificare il nome visualizzato per il file pst, attenersi alla seguente procedura:
    1. Destro Cartelle archivioe quindi scegliere proprietà.
    2. Nella finestra di dialogo Proprietà delle cartelle di archiviazione , fare clic su Avanzate.
    3. Nella finestra di dialogo Cartelle personali , immettere il nuovo nome nella casella nome visualizzato.
    4. Scegliere OK due volte per tornare a Outlook.
  2. Utilizzare la funzionalità Sposta nella cartella per spostare elementi in un nuovo file pst. A tale scopo, attenersi alla seguente procedura:
    1. Dal menu File , scegliere
      Nuovo, quindi fare clic su File di dati di Outlook.
    2. Nella finestra di dialogo Nuovo File di dati di Outlook , fare clic su File delle cartelle personali di Office Outlook (pst)e quindi fare clic su OK.
    3. Specificare un percorso e un nome per il nuovo file pst.
    4. Nella finestra di dialogo Cartelle personali Microsoft , specificare il nome visualizzato del file pst nel
      Casella nome . Questo è il nome utilizzato da Outlook, il
      Elenco di Cartelle di posta elettronica .
    5. Nella cartella che contiene gli elementi che si desidera spostare in un nuovo file pst, fare clic su uno o più elementi da spostare.
    6. Dal menu Modifica , scegliere Sposta nella cartella.
    7. Nella finestra di dialogo Sposta elementi , fare clic su
      Nuovo.
    8. Nella finestra di dialogo Crea nuova cartella , immettere un nome per la nuova cartella nella casella nome .
    9. In Selezionare la posizione della cartella, fare clic sul nuovo file pst e quindi fare clic su OK.
    10. Nella finestra di dialogo Sposta elementi , assicurarsi che sia selezionata la nuova cartella nel nuovo file pst e quindi fare clic su
      OK.

Metodo 4: Utilizzare un filtro per limitare gli elementi che si sincronizzano da Exchange a file con estensione ost

Per configurare un filtro di sincronizzazione di una specifica cartella cassetta postale di Exchange, attenersi alla seguente procedura:
  1. Pulsante destro del mouse sulla cartella e quindi fare clic su
    Le proprietà.
  2. Nella finestra di dialogo proprietà , fare clic su di
    Scheda di sincronizzazione .
  3. Nella scheda sincronizzazione , fare clic su
    Filtro.
  4. Nella finestra di dialogo filtro , specificare i criteri che verranno utilizzati per sincronizzare i nuovi elementi che si desidera arrivare in questa cartella.
  5. Scegliere OK due volte per tornare a Outlook.
Nota: Questo metodo consente di ridurre la dimensione corrente del file ost. Elementi che sono stati sincronizzati in precedenza in questa cartella verranno rimossi dalla copia locale del file con estensione ost alla successiva che Outlook si sincronizza la cartella. Questi elementi verranno rimossi se essi non soddisfano i criteri di filtro. Potrebbe essere necessario attendere per la compattazione di sfondo si verifica prima di poter visualizzare le dimensioni del file con estensione ost diminuire. In alternativa, è possibile compattare manualmente il file ost facendo clic sul pulsante Compact ora nelle impostazioni avanzate dell'account di Exchange.

Se si utilizza un filtro di sincronizzazione, è possibile visualizzare gli elementi che non sono sincronizzati con il file ost o utilizzando Microsoft Office Outlook Web Access utilizzando un client di Outlook è configurato per utilizzare la modalità in linea in un profilo di Outlook.

Se si utilizza un computer portatile

Se si utilizza un computer portatile, questi errori possono verificarsi più rapidamente rispetto a quelle un computer desktop. Ciò avviene perché i dischi rigidi nei computer portatili sono in genere più lenti rispetto ai dischi rigidi nei computer desktop. Problemi di prestazioni sono direttamente correlati alla velocità disco rigido. Se si aggiungono più la random access memory (RAM) a un computer, non vi è alcun effetto su questo problema.

Riferimenti

Per ulteriori informazioni sui file pst di Outlook, fare clic sui numeri per visualizzare gli articoli della Microsoft Knowledge Base riportato di seguito:

830336 il file pst ha un formato diverso e il limite di dimensione di cartella in Outlook 2007 e Outlook 2003

832925 come configurare il limite di dimensione per pst e ost in Outlook 2003

Nota: Il percorso del Registro di sistema che viene utilizzato nell'articolo 832925 è per Outlook 2003. Per Outlook 2007, utilizzare il percorso \12.0 anziché il percorso \11.0 menzionato nell'articolo.
Proprietà

ID articolo: 932086 - Ultima revisione: 31 gen 2017 - Revisione: 1

Microsoft Office Outlook 2007

Feedback