Un Tablet PC che esegue Windows XP Tablet PC Edition 2005 non risponde (si blocca) quando si inserisce in standby o sospensione

Importante Questo articolo contiene informazioni su come modificare il Registro di sistema. Assicurarsi che il backup del Registro di sistema prima di modificarlo. Assicurarsi di sapere come ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:
256986 descrizione del Registro di sistema di Microsoft Windows

Sintomi

Quando si tenta di inserire un Tablet PC che esegue Microsoft Windows XP Tablet PC Edition 2005 in standby o ibernazione, essa non risponde (si blocca).

Questo problema si verifica quando sono installati uno o più dispositivi compositi USB che supportano la sospensione selettiva.

Causa

Questo problema si verifica perché una condizione di deadlock si verifica quando il driver dell'hub USB (Usbhub. sys) invia in modo sincrono il PowerDeviceD0 pacchetto di richiesta dei / o dello stato dell'alimentazione (D0) (IRP). Pacchetti IRP sono in coda, ma non completate l'IRP. Questa condizione di deadlock impedisce il Tablet PC di standby o sospensione.

Risoluzione

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:Nota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Usbccgp.sys5.1.2600.311632,12811-Apr-200711:06x86

Come attivare l'aggiornamento rapido

Avviso L'errata modifica del Registro di sistema utilizzando l'Editor del Registro di sistema o un altro metodo può causare problemi gravi. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che questi problemi possano essere risolti. Modificare il Registro di sistema a proprio rischio.

Dopo avere applicato questo hotfix, attenersi alla seguente procedura per attivare l'hotfix per la periferica composita USB:
  1. Fare clic su Start, scegliere Esegui, digitare regedit e quindi fare clic su OK.
  2. Individuare e selezionare la seguente sottochiave del Registro di sistema:
    < XXXX > HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\Vid_ & PID _ < XXXX > \ < InstanceID > \Device Parameters
    Nota: Vid_ < XXXX > è l'ID fornitore della periferica. PID _ < XXXX > è il numero di serie del dispositivo. < InstanceID > è l'ID dell'istanza del dispositivo.
  3. Dal menu Modifica , scegliere Nuovoe quindi fare clic su Valore DWORD.
  4. Digitare IdleCompletionAsyncPowerIrpe quindi premere INVIO.
  5. Dal menu Modifica, fare clic su Modifica.
  6. Digitare 1 nella casella dati valore e quindi fare clic su OK.
  7. Dal menu File, fare clic su Esci per uscire dall'Editor del Registro di sistema.

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

Per ulteriori informazioni sulla terminologia utilizzata per descrivere gli aggiornamenti software Microsoft, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:

824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Proprietà

ID articolo: 935892 - Ultima revisione: 31 gen 2017 - Revisione: 1

Feedback