Eventi 1925, 1006, 1645, 1055, 40961 sugli errori di autenticazione o controller di un dominio basato su Windows Server 2008

Sintomi

In Windows Vista o versione successiva, viene visualizzato il seguente messaggio di errore quando si tenta di utilizzare connessione Desktop remoto per connettersi a un altro computer basato su Windows Vista o versione successivo. Oppure, in un computer che esegue Windows Vista o versione successiva con strumenti di Hyper-V RSAT, venga visualizzato il seguente messaggio di errore quando si utilizza VMConnect o connessione Desktop remoto per connettersi a un computer guest Hyper-V:
Per l'autenticazione, è Impossibile contattare un'autorità. Per assistenza, contattare l'amministratore del sistema o il supporto tecnico.
E viene visualizzato il seguente messaggio di errore quando si utilizza la Console di amministrazione di System Center Virtual Machine Manager per connettersi a una macchina virtuale Hyper-V:
Si è verificato un errore di autenticazione (codice: 0x80090303).
Una classe simile problema può verificarsi quando si utilizza un'applicazione di comunicazione tra Windows Vista o versione successivo computer tramite DCOM. L'applicazione è possibile riscontrare un errore come:

Il file non è valido per il seguente motivo: si è verificato un errore specifico del pacchetto di protezione (codice: 80070721).

Questi problemi si verificano se sono vere le seguenti condizioni:
  • Si tenta di connettersi utilizzando un nome di dominio completo (FQDN) o un nome NetBIOS.
  • Entrambi i computer sono in un dominio basato su Windows Server 2003.
  • Avere eseguito un ripristino autorevole nel contenitore utenti nel servizio directory Active Directory.
Se il dominio controller di dominio di Windows Server 2008, replica di Active Directory e aggiornamento dei criteri di gruppo potrebbero non funzionare. Inoltre, venga visualizzato il seguente messaggi registro eventi: WMI: non è possibile elencare gli spazi dei nomi da un computer remoto. Questa situazione possono verificarsi quando si utilizza wmimgmt. msc per "connettersi al computer remoto" e selezionare proprietà e quindi protezione. "Principale" non si espanderà per mostrare gli spazi dei nomi disponibili.

Quando si utilizza Gestione remota di Hyper-V, la console di gestione di Hyper-V si blocca quando si tenta di creare un disco rigido virtuale a dimensione fissa (VHD) su un server remoto di Hyper-V.

Nota: Questi problemi si verificano in presenza di una delle seguenti condizioni:
  • Si connette utilizzando l'indirizzo IP del computer remoto e utilizzando un account utente locale sul computer remoto.
  • Si connette da un computer basato su Windows XP a un computer basato su Windows Vista.
  • Si connette da un computer basato su Windows Vista a un computer basato su Windows XP.

Causa

Questi problemi si verificano perché il numero di versione dell'account KRBTGT aumenta quando si esegue un ripristino autorevole. L'account KRBTGT è un account di servizio utilizzato dal servizio Centro distribuzione chiavi (KDC) di Kerberos.

Risoluzione

Per risolvere questo problema, applicare questo hotfix in tutti i controller di dominio basato su Windows Server 2003 nel dominio. Questa correzione impedisce che il problema prima di eseguire un ripristino autorevole. Questo hotfix consente inoltre di correggere il problema dopo avere già eseguito un ripristino autorevole.

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:Nota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, è necessario disporre di Windows Server 2003 Service Pack 2.
Per ulteriori informazioni, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

Richiesta di riavvio

Dopo avere applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce eventuali altri aggiornamenti rapidi.

Informazioni sui file

La versione inglese di questo hotfix presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Le date e ore dei file sono elencate in base al formato UTC (Coordinated Universal Time Coordinated). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e ora locale, utilizzare la scheda fuso orario nell'elemento di Data e ora nel Pannello di controllo.
Windows Server 2003 con Service Pack 2, versioni basate su x86
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Samsrv.dll5.2.3790.4250454,65611-Mar-200806:55x86
Windows Server 2003 con Service Pack 2, versioni basate su x64
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Samsrv.dll5.2.3790.42501,059,32811-Mar-200809:39x64
Windows Server 2003 con Service Pack 2, versioni basate su Itanium
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Samsrv.dll5.2.3790.42501,140,22411-Mar-200809:37IA-64

Soluzione alternativa

Per risolvere questo problema, disattivare la nuova funzionalità di autenticazione di Remote Desktop Protocol (RDP) che fornisce a Windows Vista. A tale scopo, attenersi alla seguente procedura:
  1. Fare clic su Start, tipo
    mstsc.exe nella casella Inizia ricerca e quindi premere INVIO.
  2. Fare clic su Opzioni.
  3. Nella scheda Generale , fare clic su Salva con nome.
  4. Nella finestra di dialogo Salva con nome specificare un percorso e un nome per il file e quindi fare clic su OK.

    Nota: Il file salvato avranno l'estensione di file con estensione rdp.
  5. Fare clic su Start, tipo
    il blocco note nella casella Inizia ricerca e quindi premere INVIO.
  6. Nel blocco note aprire il file salvato nel passaggio 4.
  7. Individuare la riga che è simile al seguente:
    authentication level:i:x
    Nota: Il segnaposto x rappresenta il livello di autenticazione corrente.
  8. Modificare il livello di autenticazione su 0in modo che la riga diventa la seguente:
    authentication level:i:0
    Nota: Quando il livello di autenticazione è impostato su 0, RDP 6.0 controllo per l'autenticazione server.
  9. Aggiungere la seguente riga alla fine del file:
    enablecredsspsupport:i:0
    Nota: Quando questa riga è presente, gli utenti devono immettere le credenziali prima che stabiliscono una connessione desktop remoto.
  10. Salvare il file.
  11. Per la connessione utilizzando connessione Desktop remoto, eseguire il file salvato al passaggio 10.
Nota: Dopo questa procedura, RDP 6.0 diventa compatibile con computer basati su Windows Vista con l'opzione Consenti connessioni solo da computer che eseguono Desktop remoto con autenticazione a livello di rete attivata nelle proprietà del sistema.

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

È necessario distribuire questo aggiornamento rapido a tutti i controller di dominio di Windows Server 2003 nei domini in cui è stato ripristinato il contenitore users.

Questo hotfix risolve anche i seguenti problemi:
  • Problema di connessione di macchina virtuale Hyper-V come descritto in KB961723.
    Per ulteriori informazioni, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:
    Si verifica un errore di connessione a una macchina virtuale in esecuzione in Hyper-V 961723

  • Gestione remota di Hyper-V: Interfaccia utente di gestione di Hyper-V si blocca quando tenta di creare un disco rigido virtuale a dimensione fissa in un Server remoto di Inse-V.
  • La cartella principale nella scheda protezione non può essere espanse per visualizzare gli spazi dei nomi disponibili dopo avere utilizzato lo strumento wmimgmt. msc per connettersi a un computer remoto.
  • Offerta di assistenza remota non funziona tra computer Windows 7 e viene visualizzato il seguente messaggio di errore nel Registro di sistema:
    DCOM ha ricevuto l'errore "% 2147746132" dal computer COMPUTERNAME quando si tenta di attivare il server: {833E4010-AFF7-4AC3-AAC2-9F24C1457BCE}
  • Quando si utilizza System Center Virtual Machine Manager 2012 Service Pack 1 o Virtual Machine Manager 2012 R2 in un ambiente con controller di dominio che eseguono Windows Server 2003, viene visualizzato il seguente messaggio di errore in Virtual Machine Manager quando vengono aggiornati gli host Hyper-V:
    cs(3148) 0x00000000 recupero errore WMI da generare. Hai stringa "< f:WSManFault xmlns:f ="http://schemas.microsoft.com/wbem/wsman/1/wsmanfault"codice macchina"1311"= ="VMM. CONTOSO.COM">< f:Message > non sono attualmente Nessun server di accesso disponibile per soddisfare la richiesta di accesso. < / f:Message >< / f:WSManFault > "{00000000-0000-0000-0000-000000000000}
    66 02:49:53.843 08-27-2013 0x0950 0x115C WsmanAPIWrapper.cs(3148) 0x00000000 COMException (0x8007051F): non sono attualmente Nessun server di accesso disponibile per soddisfare la richiesta di accesso.
    ...
    67 02:49:53.846 08-27-2013 0x0950 0x115C VmRefresher.cs(200) 0x00000000 si tratta di un'eccezione di WS-Management temporaneo e si ignoreranno. Host SERVER1. CONTOSO.COM {00000000-0000-0000-0000-000000000000}
    68 02:49:53.848 08-27-2013 0x0950 0x115C Microsoft.Carmine.WSManWrappers.WSManProviderException VmRefresher.cs(200) 0x00000000: VMM è in grado di completare l'operazione richiesta perché non sono presenti server di accesso disponibili.
    Assicurarsi che il controller di dominio sia in esecuzione e di avere accesso ad esso. ---> COMException: attualmente non sono presenti server di accesso disponibile per soddisfare la richiesta di accesso.
Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:
824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft
Proprietà

ID articolo: 939820 - Ultima revisione: 31 gen 2017 - Revisione: 1

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