Al momento sei offline in attesa che la connessione Internet venga ristabilita

Acquisizione del traffico di rete con Network Monitor

Il supporto per Windows XP è terminato

Il supporto Microsoft per Windows XP è terminato l Ulteriori informazioni su come continuare a essere protetti.

Questo articolo è stato precedentemente pubblicato con il codice di riferimento I148942
Sommario
Lo scopo di questo articolo è di fornire le informazioni necessarie per acquisire dati sul traffico di una rete locale mediante Microsoft Network Monitor. Il testo dell'articolo è tratto direttamente dal file della Guida di Network Monitor e va consultato per reperirvi istruzioni più dettagliate.
Informazioni
Network Monitor è uno strumento per la diagnostica di rete che consente di controllare le reti locali e ottenere una visualizzazione grafica dei dati statistici. Gli amministratori di rete possono farne uso per eseguire attività abituali di risoluzione dei problemi, come l'individuazione dei server inattivi o di quelli che ricevono richieste eccessive. Nel raccogliere informazioni dal flusso di dati della rete, Network Monitor consente di visualizzare i seguenti tipi di informazioni:
  • L'indirizzo di origine del computer che ha inviato un frame in rete (tale indirizzo è un numero esadecimale, o in base 16, univoco che identifica il computer nella rete).
  • L'indirizzo di destinazione del computer che ha ricevuto il frame.
  • I protocolli utilizzati per inviare il frame.
  • I dati o una parte del messaggio inviato.
Il processo mediante il quale Network Monitor raccoglie queste informazioni viene definito acquisizione. Per impostazione predefinita, in Network Monitor i dati statistici relativi a tutti i frame rilevati vengono inseriti in un buffer di acquisizione che corrisponde a un'area di archiviazione riservata della memoria. Per acquisire i dati di un gruppo specifico di frame, è possibile selezionarli impostando un filtro di acquisizione. Al termine dell'acquisizione delle informazioni è possibile definire un filtro di visualizzazione per specificare quali tra le informazioni acquisite verranno mostrate nella finestra del visualizzatore di frame di Network Monitor.

Per poter utilizzare Network Monitor è necessario che il computer in uso disponga di una scheda di rete che supporti la modalità promiscua. Se si utilizza Network Monitor in un computer remoto, non sarà necessaria una scheda di rete che supporti la modalità promiscua nella workstation locale mentre lo sarà nel computer remoto.

Per acquisire dati tra reti o per mantenere le risorse locali, utilizzare l'Agente di Network Monitor che consente di eseguire l'operazione tramite un computer remoto con installato Windows NT. Quando l'acquisizione avviene in modalità remota, l'Agente di Network Monitor raccoglie i dati statistici da un computer remoto e li invia al computer locale in cui vengono visualizzati in una finestra di Network Monitor locale.

Dopo l'acquisizione, locale o remota, i dati possono essere salvati in un file di testo o di acquisizione ed essere aperti ed esaminati in un momento successivo.

Nota Le funzionalità di base di Network Monitor, descritte nella Guida, sono supportate dal Servizio Supporto Tecnico Clienti Microsoft. Non viene fornito supporto per le operazioni che dipendono dalla rete, come l'interpretazione dei dati acquisiti dalla rete di appartenenza. L'assistenza tecnica per l'Agente di Network Monitor è garantita per Windows NT, ma non per Windows 3.1 e le workstation che eseguono Windows per Workgroup.

Creazione di un elenco di indirizzi

Per poter utilizzare coppie di indirizzi in un filtro di acquisizione, è necessario che sia stato precedentemente creato un database di indirizzi. Sarà quindi possibile utilizzare gli indirizzi contenuti nel database per specificare le coppie di indirizzi in un filtro di acquisizione.

Per creare un elenco di indirizzi, attenersi alla seguente procedura:
  1. Scegliere Avvia dal menu Acquisizione. In alternativa è possibile aprire un file con estensione cap nella finestra del visualizzatore di frame.
  2. Al termine dell'acquisizione scegliere Interrompi e Visualizza dal menu Acquisizione per aprire la finestra del visualizzatore di frame.
  3. Scegliere Trova tutti i nomi dal menu Visualizza. I frame verranno elaborati e aggiunti al database di indirizzi.
  4. Chiudere la finestra del visualizzatore di frame e aprire la finestra di acquisizione.
  5. Scegliere Filtro dal menu Acquisizione per visualizzare la finestra di dialogo Filtro acquisizione.
  6. Nella finestra di dialogo Filtro acquisizione fare doppio clic sulla riga Coppie di indirizzi oppure scegliere Indirizzo nella casella di gruppo Aggiungi.
Verrà visualizzato il database di indirizzi creato. Utilizzare i nomi che vi sono contenuti per specificare le coppie di indirizzi nel filtro di acquisizione.

Acquisizione di dati tra due computer

Per controllare il traffico tra due computer, attenersi alla seguente procedura:
  1. Scegliere Filtro dal menu Acquisizione per visualizzare la finestra di dialogo Filtro acquisizione.
  2. Fare doppio clic sulla riga ANY<->ANY per visualizzare la finestra di dialogo Espressione indirizzo.
  3. Nel riquadro di sinistra della finestra di dialogo Espressione indirizzo selezionare l'indirizzo di un computer.
  4. Nel riquadro di destra della finestra di dialogo Espressione indirizzo selezionare l'indirizzo di un computer.
Al termine scegliere Avanti nella parte superiore di questa finestra per visualizzare altre istruzioni.
  1. Nella finestra Direzione della finestra di dialogo scegliere uno dei simboli seguenti:
    • Scegliere <--> per controllare il traffico che fluisce in entrambe le direzioni tra gli indirizzi selezionati.
    • Scegliere --> per controllare solo il traffico che fluisce dall'indirizzo selezionato nella finestra di sinistra a quello selezionato nella finestra di destra.
  2. Scegliere OK.
  3. Nella finestra di dialogo Filtro acquisizione scegliere OK.
  4. Scegliere Avvia dal menu Acquisizione.

Salvataggio dei dati acquisiti

Utilizzare il comando Salva con nome per salvare i dati statistici acquisiti in un file di acquisizione oppure per salvare le modifiche apportate a file esistenti. Successivamente, per visualizzare i frame salvati nel file, è possibile aprire tale file e visualizzare le statistiche nella finestra del visualizzatore di frame di Network Monitor.

Per salvare i frame acquisiti in un file di acquisizione o di testo:
  1. Effettuare una delle seguenti operazioni:
    • Fare clic sul pulsante Salvataggio file sulla barra degli strumenti.
      Oppure
      .
    • Scegliere Salva con nome dal menu File.
  2. Effettuare una delle seguenti operazioni:
    • Per salvare il file sull'unità e nella directory correnti, specificare il nome del file e l'estensione nella casella Nome file. Non è possibile salvare un file al quale si sono apportate modifiche con il nome originale e nella stessa directory.
    • Per salvare il file in una condivisione di rete alla quale non si è ancora connessi, scegliere il pulsante Rete e utilizzare la finestra di dialogo Connetti unità di rete per stabilire la connessione.
    • Per salvare il file su un'unità e in una directory diverse, attenersi alla seguente procedura:
      1. Nella casella Unità selezionare una nuova unità.
      2. Nella casella Directory selezionare una nuova directory.
      3. Digitare il nome del file.
  3. Per salvare solo i dati statistici che soddisfano i requisiti del filtro di visualizzazione corrente, scegliere Filtrato.

    Questa opzione è disponibile solo se si salvano i dati dalla finestra del visualizzatore di frame.
  4. Per salvare uno specifico intervallo di frame, digitare i numeri del primo e dell'ultimo frame nelle caselle Da e A.
  5. Scegliere OK.
Note Quando un intervallo di frame viene salvato in un file di acquisizione, i numeri associati ai frame vengono cambiati. Nel file di acquisizione la numerazione inizia sempre da 1, a prescindere dal numero associato al frame originale. Allo stesso modo se si applica un filtro di visualizzazione e si salvano i frame filtrati, i numeri dei frame nel file di acquisizione iniziano da 1. Se tuttavia si utilizza l'opzione Stampa su file nella finestra di dialogo Stampa, i numeri associati ai frame originali vengono mantenuti.

Impostazioni delle dimensioni del buffer

Le dimensioni predefinite del buffer sono di 1 megabyte (MB). Per aumentare le dimensioni del buffer in modo da evitare perdite di informazioni, attenersi alla seguente procedura:
  1. Scegliere Impostazioni Buffer dal menu Acquisizione.
  2. Aumentare il valore relativo all'impostazione Dimensioni buffer (in MB), quindi scegliere OK.

Esecuzione di tracce in un ambiente WAN

Potrebbe a volte essere necessario acquisire il traffico di rete tra due computer separati da uno o più router. In questi casi il tecnico del supporto potrebbe avere l'esigenza di analizzare tutto il traffico tra un computer e il router ad esso più vicino, e questo per entrambi i computer. Il più delle volte lo scopo è quello di verificare se i pacchetti di rete vengono persi o danneggiati tra i router. Affinché le tracce siano coerenti e perché sia possibile leggerle simultaneamente, gli orologi di sistema dei due computer devono essere sincronizzati prima dell'esecuzione della traccia. Per sincronizzare l'ora dei due computer, attenersi alla seguente procedura:
  1. Scegliere il computer rispetto al quale sincronizzare l'ora.
  2. Dall'altro computer digitare il comando
    net time \\NomeComputer /set /yes
    dove NomeComputer è il nome del computer di cui al passaggio 1.
  3. Verificare se i computer segnano la stessa ora digitando TIME su ognuno.
  4. Proseguire con la traccia.

Reperimento di indirizzi MAC (Media Access Control)

Se sul computer da controllare è in esecuzione:
  • Client di rete basato su MS-DOS: eseguire MSD.
  • Windows per Workgroup 3.11 (che esegue TCP/IP): digitare IPCONFIG /ALL dalla riga di comando
  • Windows 95: eseguire WINIPCFG dalla riga di comando della workstation locale.
  • MacOS: aprire il pannello di controllo di Appletalk. Scegliere User Mode dal menu Modifica e scegliere la modalità avanzata. Nel pannello di controllo di Appletalk sarà reso disponibile il pulsante Info. Scegliere questo pulsante per ottenere l'indirizzo MAC.
  • Windows NT: nella console locale utilizzare una di queste opzioni:
    • NET CONFIG SERVER dalla riga di comando
    • IPCONFIG /ALL dalla riga di comando
    • IPXROUTE config dalla riga di comando
    • arp -a dalla riga di comando
    • Getmac.exe dal Resource Kit di Windows NT
    • WinMSD
  • Windows NT: in modalità remota, eseguire Getmac.exe dal Resource Kit di Windows NT
1.00 3.50 3.51 4.00 netmon network monitor trace HIS 2000
Proprietà

ID articolo: 148942 - Ultima revisione: 04/21/2006 14:06:00 - Revisione: 7.0

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Advanced Server 3.1
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft SNA Server 2.1
  • Microsoft SNA Server 3.0
  • Aggiornamento da Microsoft LAN Manager a Windows NT Advanced Server
  • Microsoft Systems Management Server 1.0 Standard Edition
  • Microsoft Systems Management Server 1.1 Standard Edition
  • Microsoft Systems Management Server 1.2 Standard Edition
  • Microsoft LAN Manager 2.2c
  • Microsoft TCP/IP per Windows per Workgroup 3.11
  • Microsoft TCP/IP per Windows per Workgroup 3.11a
  • Microsoft TCP/IP per Windows per Workgroup 3.11b
  • Microsoft Windows per Workgroup 3.11
  • Microsoft Internet Information Server 1.0
  • Microsoft Host Integration Server 2000 Standard Edition
  • kbhowto KB148942
Feedback