WD97: Cosa fare se si dispone di un virus macro

Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 181079
Questo articolo è stato archiviato. L’articolo, quindi, viene offerto “così come è” e non verrà più aggiornato.
Sintomi
Il primo virus macro è stato rilevato nell'estate del 1995. Da allora, sono visualizzati altri virus macro. In questo articolo viene descritto che cosa fare se si ritiene che si dispone di un virus macro di Word, oppure se si desidera assicurarsi che i documenti non diventano infettati uno.

Di seguito sono alcuni sintomi di un virus macro di Word che influiscono su Word e in Word documenti:

  • Quando si tenta di salvare un documento, Word solo consente di salvare il documento come un modello.
    - oppure -
  • L'icona per il file apparirà come un modello anziché di un documento.
    - oppure -
  • Quando si apre un documento, viene visualizzata una finestra di dialogo che mostra il numero 1.
    - oppure -
  • Non visualizzare i comandi di macro e personalizzare gli strumenti non è più menu.
    - oppure -
  • Nuove macro visualizzato nell'elenco di macro. AutoOpen e FileSaveAs macro anche possono seguire, se si dispone già di macro da questi nomi, il contenuto potrebbe essere stato modificato dal virus macro.
    - oppure -
  • I messaggi inusuali o imprevisti vengono visualizzati quando si apre una parola documento o modello.
NOTES :

  • In Word 97 è disponibile un'opzione di protezione da virus macro (scegliere Opzioni dal menu, scegliere Opzioni e fare clic sulla scheda Generale) progettato per avvisare l'utente se si apre un file contenente macro, indipendentemente da cosa le macro. Per una soluzione permanente, è necessario utilizzare software antivirus, è progettato specificatamente per rilevare e prevenire i virus delle macro.

  • Word non cercare o rimuovere eventuali virus macro da documenti esistenti e modelli. Esso verrà semplicemente informare se il documento che si sta aprendo contiene delle macro. Il messaggio di avviso consente di aprire il documento con le macro attive o di aprirlo con le macro disattivate. Non è consigliabile aprire un documento con le macro attivo se non si è assolutamente certi che il documento non contenga alcun virus macro dannosi.
Per una soluzione a lungo termine per i virus delle macro, installare software antivirus progettato per rilevare i virus delle macro. Per ulteriori informazioni sui software antivirus disponibili presso fornitori terze parti, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
49500Elenco di fornitori di software antivirus
Workaround
Utilizzare le soluzioni alternative descritte di seguito come solo soluzioni provvisori.

Metodo 1: Premere MAIUSC quando si apre un file

Se non si dispone di uno dei sintomi descritti in questo articolo, ma non si desidera essere interessati da un virus macro, tenere premuto il tasto MAIUSC quando si apre un file che potrebbe essere interessato da un virus macro. Premendo MAIUSC impedirà qualsiasi macro automatiche in esecuzione, se un virus macro è presente, esso non verrà caricato.

Metodo 2: Elimina la macro e ripristino del documento

Se si sono verificato i sintomi elencati in questo articolo, oppure se si ritiene che sia di un virus macro che non è descritto di seguito, è possibile utilizzare la procedura seguente per rimuovere le macro che causano problemi e documenti interessati corretti. (Tenere presente che si tratta solo una soluzione temporanea, poiché vengono create nuove macro, questa procedura non funzionino):

  1. Chiudere Word e rinominare il file Normal.dot Name.dot.
  2. Creare una copia di backup di un file interessato.
  3. Aprire Word e dal menu file fare clic su Apri.
  4. Passare alla cartella contenente il file interessato.
  5. Fare clic per selezionare il file interessato.
  6. Premere e tenere premuto il tasto MAIUSC e scegliere Apri.

    Continuare a tenere premuto MAIUSC finché non viene aperto il file interessato.

    Nota : esecuzione con il tasto MAIUSC durante l'apertura di un file mantiene le macro automatiche di parole.
  7. Per rimuovere virus sospetto contenente macro, effettuare le seguenti operazioni:
    1. Scegliere Macro dal menu Strumenti, quindi macro.
    2. Nell'elenco macro in, fare clic su tutti i modelli Active e documenti.
    3. Selezionare la macro sospetta e fare clic su Elimina. Scegliere Sì quando viene chiesto se si desidera eliminare la macro.
    4. Ripetere il passaggio c per tutte le macro sospette.
    5. Fare clic su Annulla o x per chiudere la finestra di dialogo macro.
  8. Per recuperare il testo di un documento contenente virus:
    1. Selezionare l'intero documento premendo CTRL+5 (Tn) oppure facendo clic su Seleziona tutto dal menu Modifica.
    2. Per eliminare segno di paragrafo finale del documento dalla selezione, premere MAIUSC+freccia sinistra.
    3. Scegliere Copia dal menu Modifica.
    4. Scegliere Nuovo dal menu file. Selezionare il modello che si desidera utilizzare e fare clic su OK.
    5. Scegliere Incolla dal menu Modifica.
    6. Ripetere il passaggio 7 per garantire che le macro contenenti virus non siano state replicate nuovamente.
    7. Salvare il documento.
  9. Ripetere questi passaggi per qualsiasi sospetto di documento di contenere un virus macro.
Nota : questo metodo non funziona, provare a 3.

Metodo 3: Utilizzare la libreria per eliminare temporaneamente i virus delle macro

Utilizzare la libreria per pulire il virus macro. Tenere presente che se altri file sono stati aperti dopo il file infetto, che probabilmente verranno essere infetti nonché.

Per rimuovere il virus dal modello normale:

  1. Chiudere tutti i documenti. Se è aperto un documento di infetto, facilmente possibile reinfect Normal.dot.
  2. Dal menu Strumenti, fare clic su modelli e aggiunte e fare clic sul pulsante libreria.
  3. Scegliere la scheda macro e rinominare o eliminare tutte le macro seguenti:
    NewMacros
    AutoClose
    AutoExec
    AutoOpen
    FileExit
    FileNew
    FileOpen
    FileSalva
    FileSaveAs
    Macro
    ToolsMacro
  4. Fare clic su Chiudi.
  5. Premere MAIUSC e dal menu file, fare clic su Salva tutto per salvare il modello.
Per rimuovere il virus da documenti contenenti virus:

Se è stato infettato da un file, utilizzare lo stesso metodo descritto in precedenza, ma rimuovere le macro da entrambi il modello Normal sia dal documento (modello), mentre nella libreria infetto. Al termine, premere MAIUSC e il menu file e fare clic su Salva tutto e passare il file successivo. Tenere presente che ogni volta che si apre un file infetto verrà infettare il modello Normal, costantemente è necessario rimuovere le macro al modello Normal.

Metodo 4: È possibile inserire IT in un nuovo documento

Con questo metodo, sarà necessario rinominare il file Normal.dot e quindi dal menu Inserisci, scegliere file per rimuovere temporaneamente le macro. Questo metodo è particolarmente utile con il virus macro denominata "CAP", che rimuove la macro e Personalizza dal menu Strumenti.

Nota : in questo caso, il comando modelli e aggiunte dal menu Strumenti non funzionino.

  1. Chiudere Word e rinominare il file Normal.dot Name.dot.
  2. Aprire Word e verificare che siano macro e personalizzare scegliere Opzioni dal menu.
  3. Aprire un nuovo documento e nel menu Inserisci, fare clic su file.
  4. Passare alla cartella contenente il file interessato.
  5. Fare clic per selezionare il file interessato.
  6. Premere e tenere premuto il tasto MAIUSC e fare clic su OK.

    Continuare a tenere premuto MAIUSC finché non viene aperto il file interessato.

    Nota : esecuzione con il tasto MAIUSC durante l'apertura di un file mantiene le macro automatiche di parole.
  7. Per verificare se vi sono tutte le macro nel nuovo documento (non devono essere tutti elencati), scegliere Macro dal menu Strumenti e quindi fare clic su macro. Nell'elenco macro in fare clic su "tutti i modelli attivi e documenti. In Nome Macro non devono essere tutte le macro elencate. Fare clic su Annulla.
  8. Salvare il file con un nome di file diverso.
  9. Eliminare il file infetto.
Informazioni
Un virus macro è un programma scritto nel linguaggio macro di un programma, come in Word. Si propaga automaticamente tra i file di dati e può danneggiare i file o del sistema operativo.

Virus macro in Word non viaggi liberamente attraverso Internet o qualsiasi altro supporto, può essere trasferiti solo quando un utente apre un documento o modello che contiene la macro virus.

Microsoft Internet Assistant e i documenti creati o lettura da esso non può essere interessato da tali macro. Internet Assistant, per impostazione predefinita, blocca il meccanismo che distribuisce il virus macro.

Virus macro possono essere trasferiti da WordMail, a meno che non un documento interessato è incorporato nel messaggio di posta elettronica e il destinatario apre il documento.
Disinfestare protezione protetto aziendale infettare salvataggio apertura saveas nucleari DMV prank concetto word97 word8

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 181079 - Ultima revisione: 12/05/2015 08:23:42 - Revisione: 2.1

Microsoft Word 97 Standard Edition

  • kbnosurvey kbarchive kbmt kbfaq kbinfo kbvirus KB181079 KbMtit
Feedback