Al momento sei offline in attesa che la connessione Internet venga ristabilita

Il nuovo stato della stampante è "Non in linea" dopo l'eliminazione di una coda di stampa e il riavvio di un computer con Windows

Il supporto per Windows XP è terminato

Il supporto Microsoft per Windows XP è terminato l'8 aprile 2014. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

Il supporto per Windows Server 2003 è terminato il 14 luglio 2015.

Microsoft ha sospeso il supporto per Windows Server 2003 in data 14 luglio 2015. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

Sintomi
Considerare lo scenario seguente:
  • Si elimina una coda di stampa quando si trova in uno stato non in linea.
  • Si aggiunge una nuova coda di stampa avente lo stesso nome della vecchia.
  • Si riavvia il computer.
In questo scenario, lo stato della nuova coda di stampa viene visualizzato come Non in linea.
Cause
Questo problema si verifica se nel computer è configurato il valore del Registro di sistema seguente quando la stampante è stata impostata sullo stato Non in linea:

Chiave: HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\Print\Printers\<nome coda di stampa>
Valore: PrinterOnLine
Dati: 0

Questo valore, tuttavia, non viene eliminato dal file Localspl.dll quando viene eliminata la coda di stampa. Quando si aggiunge una coda di stampa avente lo stesso nome della vecchia, quindi, la nuova eredita lo stato Non in linea dalla vecchia.
Risoluzione
Per risolvere il problema automaticamente, accedere alla sezione "Correzione automatica". Per risolvere il problema autonomamente, accedere alla sezione "Correzione manuale".

Correzione automatica



Per risolvere il problema automaticamente, fare clic sul pulsante o sul collegamento Fix it. Fare clic, quindi, su Esegui nella finestra di dialogo Download file e attenersi alla procedura guidata Fix it.





Note
  • Eseguire questo pacchetto dopo aver eliminato una coda di stampa ma prima di aggiungere una nuova coda di stampa avente lo stesso nome.
  • Questa procedura guidata potrebbe essere disponibile solo in lingua inglese. La correzione automatica, tuttavia, funziona anche per versioni di Windows in altre lingue.
  • Se non si sta utilizzando il computer che presenta il problema, è possibile salvare la soluzione Fix it su un'unità di memoria flash o su un CD ed eseguirla sul computer interessato dal problema.

Accedere, quindi, alla sezione "Il problema è stato risolto?".



Correzione manuale

Per risolvere questo problema, premere il pulsante destro del mouse sulla nuova coda di stampa nello strumento Stampanti e Fax, quindi deselezionare l'impostazione Usa stampante non in linea. In tal modo, viene ripristinato il valore corretto della chiave del Registro di sistema. In alternativa, è possibile eliminare la chiave del Registro di sistema indicata nella sezione "Causa" dopo aver eliminato una coda di stampa ma prima di aggiungere una nuova coda avente lo stesso nome.

Il problema è stato risolto?

  • Controllare se il problema è stato risolto. Se il problema è stato risolto, non è necessario continuare la lettura di questa sezione. Se il problema non è stato risolto, contattare il supporto tecnico.
  • I commenti degli utenti sono molto utili. Per fornire commenti o segnalare problemi relativi a questa soluzione, lasciare un commento nel blog "Correzione automatica" o inviare un messaggio di posta elettronica a Microsoft.
Informazioni
fixit fix it fixme
Proprietà

ID articolo: 2027593 - Ultima revisione: 10/21/2011 12:56:00 - Revisione: 3.0

Microsoft Windows XP Home Edition, Microsoft Windows XP Professional, Microsoft Windows Server 2003, Standard Edition (32-bit x86), Microsoft Windows Server 2003, Datacenter Edition (32-bit x86), Microsoft Windows Server 2003, Enterprise Edition (32-bit x86), Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86), Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86), Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86), Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 Standard, Windows Server 2008 R2 Enterprise, Windows Server 2008 Datacenter, Windows Server 2008 Enterprise, Windows Server 2008 Standard, Windows Vista Business, Windows Vista Enterprise, Windows Vista Home Premium, Windows Vista Ultimate, Windows 7 Enterprise, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Ultimate

  • KB2027593
Feedback
document.createElement('meta');m.name='ms.dqp0';m.content='true';document.getElementsByTagName('head')[0].appendChild(m);" onload="var m=document.createElement('meta');m.name='ms.dqp0';m.content='false';document.getElementsByTagName('head')[0].appendChild(m);" src="http://c1.microsoft.com/c.gif?"> >/html>