Informazioni sull'elenco di completamento automatico di Outlook

Il supporto per Office 2003 è terminato

Il supporto Microsoft per Office 2003 è terminato l'8 aprile 2014. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 2199226
Sommario
In questo articolo viene fornita una panoramica dell'elenco di completamento automatico di Microsoft Outlook (noto anche come l'elenco completamento automatico di Outlook). Oltre a descrivere la funzionalità, in questo articolo contiene ulteriori informazioni e istruzioni dettagliate per gli utenti esperti di gestire l'elenco.
Informazioni
Outlook gestisce l'elenco di completamento automatico. L'elenco viene utilizzato sia la funzione di controllo dei nomi automatico e la funzionalità di completamento automatico. Elenco di completamento automatico, noto anche come cache del nome alternativo, viene generato automaticamente quando si inviano messaggi di posta elettronica da Outlook. L'elenco contiene gli indirizzi SMTP, LegacyExchangeDN voci e i nomi visualizzati per le persone a cui hai inviato in precedenza la posta.

Nota Elenco di completamento automatico per Outlook è specifico di Outlook e non è condiviso da Outlook Web App (OWA). OWA mantiene il proprio elenco di completamento automatico.

Le sezioni seguenti forniscono informazioni sulla funzionalità Completamento automatico.

Limitare il numero di voci

Outlook consente di limitare il numero di voci che è possibile salvare l'elenco di completamento automatico. Dopo che si raggiunge questo limite, Outlook utilizza un algoritmo interno per determinare i nomi migliori da rimuovere dall'elenco. Ciò è basato su un peso di utilizzo. Pertanto, è possibile che alcuni nomi inaspettatamente rimosse dalla cache del nome alternativo. Esistono due approcci generali che è possibile utilizzare per evitare questa situazione:
  1. È possibile rimuovere in modo proattivo voci dell'elenco di completamento automatico che non è più necessario. Questo è l'approccio preferito. Per ulteriori informazioni su come effettuare questa operazione, vedere la sezione intitolata "Come rimuovere voci dell'elenco di completamento automatico uno alla volta".
  2. È possibile aumentare il limite per la cache dei nomi alternativi. Poiché questa configurazione non è stata testata, non la consigliamo. Se si dispone di una cache più grande di nome alternativo, è possibile perdere anche un maggior numero di voci memorizzate nella cache se la cache dei nomi alternativi diventa inutilizzabile causa il danneggiamento. Per ulteriori informazioni su come aumentare il limite, vedere la sezione intitolata "Come modificare il limite per l'elenco di completamento automatico".
I limiti sono i seguenti:
  • Outlook 2016: 1.000 voci
  • Outlook 2013: 1.000 voci
  • Outlook 2010: 1.000 voci
  • Outlook 2007: 2.000 voci
  • Outlook 2003: 1.000 voci

Come attivare la funzionalità Completamento automatico

In questa sezione viene illustrato come attivare o disattivare la funzionalità Completamento automatico.
Outlook 2010, Outlook 2013 e 2016 Outlook
Per accedere all'impostazione di completamento automatico, attenersi alla seguente procedura:
  1. ScegliereOpzionidal menuFile.
  2. Selezionare la scheda posta elettronica .
  3. Circa metà strada verso il basso finché non si inviano messaggidi scorrimento. Assicurarsi che sia selezionata la casella Utilizza elenco completamento automatico per suggerire nomi durante la digitazione in a, Cc e Ccn righe .

Outlook 2003 e Outlook 2007
Per accedere alle impostazioni di completamento automatico, attenersi alla procedura seguente:
  1. Fare clic su Strumentie quindi fare clic su Opzioni.
  2. Fare clic sul pulsante di Opzioni di posta elettronica pulsante.
  3. Fare clic sul pulsante Opzioni avanzate di posta elettronica .
  4. Assicurarsi che il Suggerisci nomi durante il completamento a, Cc e Ccn campisia selezionata. (L'immagine riportata di seguito illustra come eseguire questa operazione).La schermata per questo passaggio.

Come importare file nk2 in Outlook 2010, Outlook 2013 e 2016 Outlook

Microsoft Office Outlook 2007 e versioni precedenti memorizzano l'elenco di completamento automatico in un file di nome alternativo (. nk2) sul disco. Outlook 2010, Outlook 2013 e 2016 Outlook memorizzare l'elenco di completamento automatico in un messaggio nascosto nell'archivio dei messaggio principale. Outlook 2010, Outlook 2013 e 2016 Outlook consentono di importare i vecchi file nk2.

Per ulteriori informazioni su come importare file nk2 in Outlook 2010, visitare il seguente sito Web Microsoft:
Per ulteriori informazioni su come importare file nk2 Outlook 2013 e 2016 di Outlook, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
2806550Come importare file nk2 in 2013 Outlook o Outlook 2016

Come copiare l'elenco theAutoComplete

La procedura per esportare e importare l'elenco di completamento automatico è diversa a seconda della versione di Outlook che si sta utilizzando.
Outlook 2010, Outlook 2013 e 2016 Outlook
Per copiare l'elenco di completamento automatico in Outlook 2010, Outlook 2013 e 2016 di Outlook, attenersi alla seguente procedura:

Passaggio1

Per esportare il messaggio di completamento automatico della cassetta postale, attenersi alla seguente procedura:
  1. Uscire da Outlook e quindi chiudere Outlook Web Access o Outlook Web App (OWA) su tutte le workstation connesse alla cassetta postale.
  2. Scaricare e installare MFCMAPI da http://MFCMAPI.codeplex.com.
  3. Eseguire mfcmapi.exe.
  4. Nel menu della sessione , fare clic su accesso.
  5. Se richiesto un profilo, selezionare il nome del profilo desiderato e quindi fare clic su OK.
  6. Nel riquadro superiore, individuare la riga che corrisponde alla cassetta postale e quindi fare doppio clic su esso.
  7. Nel riquadro di spostamento sinistro, espandere Il contenitore radicee quindi espandere Superiore dell'archivio informazioni o IPM_SUBTREE.
  8. Fare clic sulla cartella della posta in arrivo e quindi scegliere Apri tabella di contenuto associata. Questa azione apre una nuova finestra MFCMAPI contenente diverse proprietà.
  9. Nella colonna argomento destro l'elemento con l'oggetto IPM. Configuration.Autocomplete, quindi fare clic su Esporta messaggi. Questa azione viene visualizzata la finestra di Messaggio Salva su File .
  10. Nell'elenco a discesa, selezionare il file MSG (UNICODE)e quindi fare clic su OK.
  11. Selezionare una cartella a cui si desidera salvare il messaggio e quindi fare clic su Salva. Prendere nota del percorso.
Passaggio 2

Per importare il messaggio di completamento automatico della cassetta postale, attenersi alla seguente procedura.
  1. Uscire da Outlook e quindi chiudere Outlook Web Access o Outlook Web App (OWA) su tutte le workstation connesse alla cassetta postale.
  2. Scaricare e installare MFCMAPI da http://MFCMAPI.codeplex.com
  3. Eseguire mfcmapi.exe.
  4. Nel menu della sessione , fare clic su accesso.
  5. Se richiesto un profilo, selezionare il nome del profilo desiderato e quindi fare clic su OK.
  6. Nel riquadro superiore, individuare la riga che corrisponde alla cassetta postale e quindi fare doppio clic su esso.
  7. Nel riquadro di spostamento sinistro, espandere radice - cassetta postalee quindi espandere Superiore dell'archivio informazioni o IPM_SUBTREE.
  8. Fare clic sulla cartella della posta in arrivo e quindi scegliere Apri tabella di contenuto associata. Questa azione apre una nuova finestra MFCMAPI contenente diverse proprietà.
  9. Per evitare voci duplicate, è necessario eliminare il messaggio di completamento automatico esistente.

    Nota Prima di eliminare il IPM. Configuration.Autocomplete messaggio, è necessario esportare il messaggio utilizzando la procedura descritta nella sezione "Come esportare la cache di completamento automatico".

    Per eliminare il messaggio di completamento automatico esistente, attenersi alla seguente procedura:

    1. Nella colonna argomento , individuare l'elemento con l'oggetto IPM. Configuration.Autocomplete.
    2. L'elemento e quindi fare clic su Elimina messaggio. Verrà visualizzata la finestra Elimina elemento .
    3. Nell'elenco a discesa, selezionare l'eliminazione permanente (eliminazioni di mantenimento degli elementi eliminati, se supportato)e quindi fare clic su OK.
  10. Cartella dal menu fare clic su Importae quindi fare clic su Da MSG.
  11. Individuare il file con estensione msg creato nel passaggio 11 della sezione "Come per esportare l'elenco di completamento automatico" e quindi fare clic su OK.
  12. Nella finestra Carico MSG che viene visualizzata, selezionare il messaggio di caricamento nella cartella corrente nell'elenco stile carico e quindi fare clic su OK.
Le informazioni di completamento automatico viene importate dal modulo IPM. Configuration.Autocomplete_<hexadecimal code=""></hexadecimal>. MSG, dove il segnaposto<hexadecimal code=""> </hexadecimal> rappresenta una lunga stringa di numeri e lettere.
Outlook 2003 e Outlook 2007
La procedura per copiare l'elenco di completamento automatico in Outlook 2003 e Outlook 2007 è diversa. In questo modo Outlook 2003 e Outlook 2007 è possibile memorizzare l'elenco di completamento automatico nel file nk2.

Per copiare l'elenco di completamento automatico in Outlook 2003, visitare il seguente sito Web Microsoft:
Per copiare l'elenco di completamento automatico in Outlook 2007, visitare il seguente sito Web Microsoft:

Come rimuovere voci dell'elenco di completamento automatico uno alla volta

Per rimuovere voci dalla voce della cache AutoComplete uno alla volta, attenersi alla seguente procedura:
  1. Aprire un nuovo messaggio di posta elettronica.
  2. Digitare i primi caratteri della voce di completamento automatico che si desidera rimuovere.
  3. Consigliato quando il movimento viene visualizzato nell'elenco dei nomi, spostare il puntatore del mouse sul nome fino a quando non viene evidenziato, ma non fare clic sul nome.
  4. Quando l'icona "X" viene visualizzato accanto al nome evidenziato, fare clic suX per rimuovere il nome dall'elenco oppure premere il tasto CANC sulla tastiera.

Come cancellare l'intero elenco di completamento automatico

In questa sezione viene illustrato come eliminare l'elenco di completamento automatico.
Outlook 2010, Outlook 2013 e 2016 Outlook
Per eliminare l'elenco di completamento automatico in Outlook 2010, Outlook 2013 e 2016 di Outlook, utilizzare uno dei due metodi seguenti.

Metodo 1
  1. Aprire Outlook.
  2. Nella scheda File , fare clic su Opzioni.
  3. Fare clic sulla scheda posta .
  4. In Invia messaggi, fare clic su Elenco di completamento automatico vuoto.


  5. Fare clic su .

Metodo 2

Avviare Outlook utilizzando l'opzione /CleanAutoCompleteCache. A tale scopo, attenersi alla seguente procedura:
  1. Fare clic su Start e quindi fare clic su Esegui.
  2. Tipo/CleanAutoCompleteCache di Outlook.exe.

    Nota Se Outlook non è installato nel percorso predefinito, deve puntare al percorso di Outlook.exe.
Outlook 2003 e Outlook 2007
Per eliminare l'elenco di completamento automatico in Outlook 2003 e Outlook 2007, è necessario eliminare manualmente il file nk2. Per eliminare il file nk2, attenersi alla seguente procedura:
  1. Uscire da Outlook.
  2. Fare clic suStarte quindi fare clic suComputer.
  3. Fare clic suOrganizzae quindi fare clic suOpzioni cartella e ricerca.
  4. Nella schedaVisualizza, fare clic suMostra file nascosti, cartelle e unità.
  5. Fare clic suOK.
  6. Fare clic suStart, scegliereTutti i programmi, Accessorie quindi fare clic suEsegui.
  7. Nella finestra di dialogoEsegui, digitare il comando seguente (incluse le virgolette) e quindi fare clic suOK:

    "C:\ MSOCache\All Users \nomeutente\AppData\Roaming\Microsoft\Outlook"


    Nota Nome utentein questo percorso è il nome di attualmente connesso all'utente di Windows.
  8. Destro di. File nk2 con nome del profilo che si desidera ripristinare, quindi scegliereRinomina.
  9. Rinominare il file comeprofilename.bake premere INVIO.
  10. IA Outlook.

Problemi con la cache di completamento automatico

In questa sezione vengono descritti i problemi noti che possono verificarsi con la cache di completamento automatico. La cache di completamento automatico può danneggiarsi nel tempo e non può salvare le nuove voci. In questo caso, provare a rimuovere singole voci dall'elenco. A tale scopo, vedere la sezione intitolata "Come rimuovere voci dell'elenco di completamento automatico uno alla volta". Se il problema persiste, è possibile reimpostare l'intero elenco di completamento automatico. A tale scopo, vedere la sezione intitolata "Come cancellare l'intero elenco di completamento automatico".

Come modificare il limite per l'elenco di completamento automatico

Poiché questa configurazione non è stata testata, non la consigliamo. Se si dispone di un elenco di completamento automatico più grande, si potrebbe perdere anche un maggior numero di voci memorizzate nella cache se la cache di completamento automatico diventa inutilizzabile a causa di un errore. Dato questo declinazione di responsabilità, è possibile utilizzare i seguenti dati del Registro di sistema per aumentare il limite di elenco di theAutoComplete in Outlook.

Importante Questa sezione, metodo o attività contiene passaggi su come modificare il Registro di sistema. Tuttavia, può causare seri problemi la modifica del Registro di sistema in modo non corretto. Pertanto, assicurarsi di seguire attentamente i passaggi. Per maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. Cosicché sia possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristinare il Registro di sistema, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:

322756 Eseguire il backup e ripristino del Registro di sistema in Windows
  1. Uscire da Outlook.
  2. Avviare l'Editor del Registro di sistema.
    • In Windows 8. x, premere Windows chiave, digitare regedit e quindi preme INVIO.
    • In Windows 7 e Windows Vista, fare clic su Start, tipo Regedit Nella casella Inizia ricerca e quindi premere INVIO.
  3. Individuare e selezionare la seguente sottochiave del Registro di sistema:

    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoNameCheck

    Nota Il segnaposto x.0 In questo registro di sistema sottochiave rappresenta la versione di Microsoft Office. Utilizzare il valore appropriato dall'elenco seguente.

    Outlook 2016 = 16,0
    Outlook 2013 = 15.0
    Outlook 2010 = 14.0
    Outlook 2007 = 12.0
    Outlook 2003 = 11.0
  4. Dal menu Modifica , scegliere Nuovoe quindi fare clic su valore DWORD.
  5. Digitare MaxNickNames, quindi premere INVIO.
  6. Dal menu Modifica, fare clic su Modifica.
  7. Digitare il nuovo valore per il limite e quindi fare clic su OK.

    Note
    • Assicurarsi di digitare il numero decimal modulo. Che è la forma corretta in cui digitare il numero.
    • Provare ad aumentare il limite di solo una quantità marginale per testare il nuovo limite. Ad esempio, per creare un aumento del 20% il limite di Outlook 2013, specificare1200 per il valore di MaxNickNames.
  8. Uscire dall'Editor del Registro di sistema.
  9. Avviare Outlook.
Nota Il valore del Registro di sistema MaxNickNames specifica semplicemente il limite non predefinito. Pertanto, è possibile utilizzare anche questo valore per ridurre il limite della cache del nome alternativo.

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 2199226 - Ultima revisione: 09/23/2015 04:42:00 - Revisione: 6.0

Outlook 2016, Microsoft Outlook 2013, Microsoft Office Outlook 2003, Microsoft Office Outlook 2007, Microsoft Outlook 2010

  • kbmt KB2199226 KbMtit
Feedback