La scheda Rilevamento riunioni di Outlook non viene aggiornata

Sintomi

Considerare lo scenario descritto di seguito:

  1. Si usa Microsoft Outlook per pianificare una riunione e invitare i partecipanti.
  2. I partecipanti accettano o rifiutano la riunione e inviano le loro risposte alla riunione.
  3. Le risposte alle riunioni vengono visualizzate nella cartella Posta in arrivo in Outlook.

In questo scenario, quando si apre la riunione pianificata dalla cartella Calendario, si nota che la pagina Rilevamento non mostra i valori aggiornati nella colonna Risposta .

Inoltre, se è stata abilitata l'opzione Aggiorna informazioni di rilevamento e quindi si eliminano le risposte in Outlook, le risposte alle riunioni non vengono eliminate come previsto.

Causa

Le risposte alle riunioni vengono elaborate da un altro client, dispositivo o applicazione di terze parti. Questi possono includere, ma non sono limitati a, i seguenti.

  • Componenti aggiuntivi di Outlook
  • Programma di archiviazione della posta
  • Dispositivi che usano Collaboration Data Objects (CDO) per la sincronizzazione con la cassetta postale o il calendario di Microsoft Exchange
  • Dispositivi che usano Microsoft Exchange ActiveSync (EAS) per la sincronizzazione con la cassetta postale o il calendario

Nota

Se i partecipanti accettano la riunione e scelgono di non inviare una risposta, si prevede che la scheda di rilevamento non venga aggiornata con la relativa risposta.

Risoluzione

Per determinare se i componenti aggiuntivi di Outlook hanno causato l'elaborazione della risposta alla riunione, disabilitare temporaneamente i componenti aggiuntivi di Outlook e quindi provare a riprodurre il problema. Se il problema non si verifica quando i componenti aggiuntivi sono disabilitati, potrebbe essere necessaria un'analisi aggiuntiva dei componenti aggiuntivi.

Per altre informazioni su come disabilitare i componenti aggiuntivi in Outlook, vedere Visualizzare, gestire e installare componenti aggiuntivi nelle applicazioni di Office.

Per determinare se un dispositivo mobile ha causato l'elaborazione della risposta alla riunione, determinare se sono presenti dispositivi mobili regolarmente usati per la sincronizzazione con il calendario di Exchange. Assicurarsi di eseguire l'aggiornamento al sistema operativo più recente del dispositivo mobile per evitare problemi noti già risolti. Disabilitare temporaneamente l'accesso al dispositivo mobile e quindi provare a riprodurre il comportamento. Se il comportamento non si verifica, potrebbe essere necessaria un'analisi aggiuntiva del dispositivo mobile.

È anche possibile analizzare la causa del comportamento usando MFCMapi per esaminare l'elemento del calendario. MFCMapi è un client MAPI (Messaging API) che espone informazioni aggiuntive su cartelle ed elementi in una cassetta postale di Exchange. Scaricare MFCMAPI da github (scorrere verso il basso e quindi fare clic su Versione più recente).

Per determinare se la risposta alla riunione è stata elaborata da un elemento diverso da Outlook, seguire questa procedura:

  1. Nel computer client di Outlook creare una riunione e quindi inviare un invito alla riunione a un partecipante.

  2. Chiudere Outlook.

  3. Fare in modo che il partecipante accetti l'invito alla riunione e quindi invii una risposta all'organizzatore.

  4. Nel computer client mantenere Outlook chiuso.

  5. Usare MFCMapi per esaminare la risposta alla riunione inviata dal partecipante. A tal fine, attenersi alla seguente procedura:

    1. Eseguire MFCMAPI.exe.

    2. Fare clic sul menu Sessione e quindi su Accesso.

    3. Se viene richiesto un profilo, selezionare il nome del profilo e quindi fare clic su OK.

    4. Nel riquadro superiore individuare la riga corrispondente alla cassetta postale e fare doppio clic su di essa.

    5. Nel riquadro di spostamento (riquadro a sinistra) espandere Contenitore radice e quindi espandere IPM_SUBTREE.

      Nota

      Se il profilo scelto nel passaggio 5C si connette alla cassetta postale di Exchange in modalità online, espandere Top of Information Store anziché IPM_SUBTREE.

    6. Fare doppio clic sulla cartella Posta in arrivo per aprire una nuova finestra che ne visualizza il contenuto.

    7. Trovare l'elemento di risposta alla riunione inviato dal partecipante e quindi selezionarlo. Non fare doppio clic per aprirlo.

    8. Nel riquadro inferiore individuare la proprietà PR_PROCESSED nella colonna Nome/i proprietà .

      • Se la risposta alla riunione ha una proprietà PR_PROCESSED e se la proprietà è impostata su True, la risposta alla riunione è stata elaborata da un altro client, dispositivo o applicazione di terze parti. Pertanto, quando si avvia Outlook, considera che questo elemento è già stato elaborato e non aggiorna il rilevamento sull'elemento del calendario.
      • Se la risposta alla riunione non dispone della proprietà PR_PROCESSED, la risposta alla riunione non è stata elaborata.
  6. Usare MFCMapi per individuare la risposta alla riunione dei partecipanti. A tal fine, attenersi alla seguente procedura:

    1. Aprire la cartella Calendario e quindi individuare l'elemento.
    2. Nella colonna Nome proprietà individuare la proprietà PR_RECIPIENT_TRACKSTATUS e quindi esaminare la colonna Smart View . I valori possibili sono i seguenti:
      • Flag: respNone
      • Flag: respAccepted
      • Flag: respDeclined
      • Flag: respTentative