Al momento sei offline in attesa che la connessione Internet venga ristabilita

Creazione di snap-in MMC personalizzati mediante Microsoft Management Console

Questo articolo è stato archiviato. L’articolo, quindi, viene offerto “così come è” e non verrà più aggiornato.
Sommario
Gli amministratori possono utilizzare Microsoft Management Console (Mmc.exe) per creare strumenti speciali per delegare attività amministrative specifiche a utenti o gruppi. Questi strumenti personalizzati, salvati come file della console MMC (msc), possono essere inviati tramite posta elettronica, condivisi in una cartella di rete o pubblicati sul Web. Possono anche essere assegnati a utenti, gruppi o computer con impostazioni dei criteri di sistema. Uno strumento può essere aumentato o ridotto, integrato in modo uniforme nel sistema operativo, inserito in un nuovo pacchetto e personalizzato. In questo articolo viene descritto come eseguire queste operazioni.

Torna all'inizio

Creazione di un file di console

  1. Fare clic sul pulsante Start, scegliere Esegui, digitare mmc, quindi scegliere OK. Microsoft Management Console viene avviato con una console vuota (o strumento amministrativo). La console vuota non dispone di alcuna funzionalità di gestione finché non viene aggiunto uno snap-in.
  2. Scegliere Aggiungi/Rimuovi snap-in dal menu File.
  3. La casella Snap-in aggiunti in indica solo la directory principale della console. Scegliere Aggiungi.
  4. Selezionare lo snap-in appropriato nell'elenco di snap-in autonomi disponibili, quindi scegliere Aggiungi.
  5. Al termine scegliere OK.

    È possibile nidificare gli snap-in in una struttura a livelli aggiungendo uno snap-in sotto l'altro nella casella "Snap-in aggiunti in". In alcuni casi potrebbe essere necessario fare clic sulla scheda Estensioni, che contiene la casella di controllo "Aggiungi tutte le estensioni". Quando questa casella di controllo è selezionata, e in genere lo è per impostazione predefinita, vengono utilizzate tutte le estensioni localmente installate nel computer in cui è aperto il file di console. Se questa casella di controllo viene deselezionata, tutti gli snap-in delle estensioni dell'elenco selezionati vengono caricati in modo esplicito quando il file di console viene aperto in un computer diverso.
  6. Scegliere OK per chiudere la finestra di dialogo Aggiungi/Rimuovi snap-in. La finestra della directory principale della console è ora popolata dagli snap-in selezionati, disponibili nella cartella della directory principale.
NOTA: è importante pianificare la struttura dello snap-in personalizzato perché sia funzionale e di semplice utilizzo, come verrà spiegato in maggiore dettaglio nella sezione successiva.

Torna all'inizio

Personalizzazione del layout degli snap-in nella console

  1. Nel riquadro sinistro fare clic con il pulsante destro del mouse sull'icona dello snap-in e scegliere Nuova finestra da qui. Si aprirà una nuova finestra diretta allo snap-in selezionato.
  2. Scegliere Affianca orizzontalmente o Sovrapponi dal menu Finestra per personalizzare le finestre.
  3. Per salvare la nuova console MMC, scegliere Salva con nome dal menu File e digitare un nome per la console. La console viene salvata come file che può essere distribuito a chiunque abbia bisogno di configurare un computer con lo strumento desiderato.

Torna all'inizio

Impostazione delle opzioni dei file di console

Quando si crea un file di console per un altro utente, è utile essere in grado di impedire un'ulteriore personalizzazione del file di console da parte di tale utente. Questa operazione può essere effettuata nella finestra di dialogo Opzioni:
  1. Scegliere Opzioni dal menu File, quindi fare clic sulla scheda Console.
  2. Se si desidera selezionare un'icona diversa, fare clic su Cambia icona, selezionare l'icona appropriata, quindi scegliere OK.
  3. Selezionare una delle quattro modalità console, vale a dire:

    • Modalità di modifica: consente l'accesso a tutte le funzionalità di MMC, compresa la possibilità di aggiungere o rimuovere snap-in, di creare nuove finestre e di esplorare l'intera struttura della console.
    • Modalità utente - Accesso completo: gli utenti hanno accesso a tutte le funzionalità di gestione delle finestre di MMC e accesso completo alla struttura del contesto. Gli utenti non possono aggiungere o rimuovere snap-in né modificare le opzioni del file di console. I comandi di salvataggio non sono disponibili perché le modifiche che non influiscono sulle relazioni degli snap-in vengono salvate automaticamente.
    • Modalità utente - Accesso limitato, finestra multipla: gli utenti non possono aprire nuove finestre né hanno accesso ad aree della struttura della console che non erano visibili al momento in cui il file di console non è stato salvato. Si applicano anche tutte le limitazioni esistenti per la modalità utente ad accesso completo. Sono consentite più finestre secondarie, ma l'utente non può chiuderle.
    • Modalità utente - Accesso limitato, finestra singola: vengono applicate tutte le limitazioni relative alla modalità utente ad accesso limitato, finestre multiple, a eccezione del fatto che esiste una sola finestra, pertanto non sono presenti i controlli per utilizzare più finestre.
    Nella casella Modalità console selezionare la modalità che si adatta meglio alle esigenze amministrative e di protezione specifiche.
  4. Per impedire che gli utenti apportino modifiche alla console personalizzata, selezionare la casella di controllo Non salvare le modifiche apportate a questa console.
  5. Scegliere OK.
  6. Per salvare la nuova console MMC, scegliere Salva con nome dal menu File e digitare un nome per la console. La console viene salvata come file che può essere distribuito a chiunque abbia bisogno di configurare un computer con lo strumento desiderato.

Torna all'inizio

Collocare un'icona MSC personalizzata nella cartella Programmi

  1. Fare clic con il pulsante destro del mouse sul pulsante Start, quindi scegliere Apri cartella Utenti.
  2. Fare doppio clic sull'icona Programmi.
  3. Fare clic con il pulsante destro del mouse su un'area vuota della cartella Programmi, scegliere Nuovo, quindi fare clic su Cartella.
  4. Digitare Strumenti console e premere INVIO.
  5. Fare doppio clic sulla cartella Strumenti console per aprirla.
  6. Fare clic con il pulsante destro del mouse su un'area vuota della cartella Strumenti console, scegliere Nuovo, quindi fare clic su Collegamento.
  7. Fare clic su Sfoglia.
  8. Individuare la cartella contenente lo strumento di console personalizzato, quindi scegliere OK. Scegliere Avanti.
  9. Digitare un nome per il collegamento, quindi scegliere Fine.

Torna all'inizio
Proprietà

ID articolo: 230263 - Ultima revisione: 12/05/2015 14:20:22 - Revisione: 3.3

Microsoft Windows 2000 Server, Microsoft Windows 2000 Advanced Server, Microsoft Windows 2000 Professional Edition, Microsoft Windows 2000 Datacenter Server

  • kbnosurvey kbarchive kbhowto kbhowtomaster kbfaq kbproductlink KB230263
Feedback