Messaggio di errore: Impossibile accedere adesso. Il dominio <Nomecomputer> non è disponibile

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IMPORTANTE: in questo articolo vengono fornite informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, eseguire una copia di backup e assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986 Descrizione del Registro di sistema di Microsoft Windows
Sintomi
È possibile che subito dopo avere digitato il nome utente e la password durante l'accesso a un computer, venga visualizzato il seguente messaggio di errore
Impossibile accedere adesso. Il dominioNomeComputer non è disponibile.
dove NomeComputer è il nome del computer locale al quale si sta tentando di connettersi.

NOTA: questo comportamento può presentarsi dopo avere installato un prodotto software e riavviato il computer al termine dell'installazione o dopo avere avviato il sistema in modalità provvisoria e avere tentato di eseguire l'accesso.
Cause
Il problema può insorgere se i file di crittografia necessari sono mancanti, danneggiati o non corrispondono alle informazioni sulla crittografia memorizzate nel Registro di sistema. Ad esempio se il Registro di sistema è configurato per utilizzare la crittografia a 128 bit e i file corrispondenti non sono nel computer.

Quando si installano determinati programmi e questi rilevano la presenza della crittografia avanzata (128 bit), viene installata la versione inclusa nel programma specifico. In questi casi le versioni di alcuni file sostituiti sono meno recenti di quelle dei file inclusi in Windows 2000.
Risoluzione
Per risolvere il problema, utilizzare uno dei seguenti metodi.

Metodo 1: è installata la crittografia avanzata a 128 bit (High Encryption Pack)

NOTA: questo è il metodo preferito.

Sostituzione dei file a 128 bit

Se si utilizza il provider di protezione predefinito di Windows 2000, utilizzare le opzioni di ripristino standard di Windows 2000 o la Console di ripristino per verificare se i file DLL di crittografia sono intatti. Per ulteriori dettagli, fare riferimento alla sezione "Informazioni" in questo articolo.

Per verificare se il file Rsaenh.dll è stato sostituito da una versione meno recente:
  1. Avviare la Console di ripristino.
  2. Digitare cd system32 e premere INVIO.
  3. Digitare dir rsaenh.dll, quindi premere INVIO.
  4. Digitare ren rsaenh.dll rsaenh.old, quindi premere INVIO.
  5. Inserire nell'unità corrispondente il disco floppy contenente i file di High-Encryption Pack.
  6. Digitare copy a:\rsaenhs.dll rsaenh.dll, quindi premere INVIO.

    NOTA: con questa operazione il file Rsaenhs.dll viene copiato dal disco floppy al disco rigido e rinominato in Rsaenh.dll. Quasi sempre questo file viene sostituito con una versione meno recente.
  7. Digitare chiudi e premere INVIO per riavviare normalmente il computer. Togliere il disco floppy dall'unità.

Metodo 2: ripristino del computer dalla crittografia a 128 bit alla crittografia standard a 56 bit

Utilizzare questo metodo solo se i dischi floppy della crittografia avanzata a 128 bit non sono disponibili. Con questo metodo si ripristina la crittografia a 56 bit standard per eseguire l'accesso al computer. Per risolvere completamente il problema, sarà necessario ottenere i file per la crittografia avanzata a 128 bit.

Dovrebbe essere possibile avviare la Console di ripristino di emergenza per recuperare il file del Registro di sistema originale, quindi riavviare il computer per modificare il file sostituito e consentire di nuovo l'uso del computer.
  1. Avviare la Console di ripristino di emergenza.
  2. Utilizzare il comando cd (change directory) e passare alla cartella %SystemRoot%\System32\Config.
  3. Rinominare il file Software in Software.old.
  4. Utilizzare il comando cd (change directory) e passare alla cartella %SystemRoot%\Repair.
  5. Copiare l'hive Software nella cartella Config (ad esempio, copy software c:\winnt\system32\config\software).
  6. Chiudere la Console di ripristino di emergenza.
  7. Riavviare il computer ed eseguire l'accesso normalmente.

    NOTA: l'hive Software non contiene tutte le modifiche apportate al computer dall'installazione iniziale. Se si mantiene il file Software nella posizione corrente, potrebbe essere necessario reinstallare tutti i prodotti software, a meno di modificare il file originale (Software.old), come specificato nella sezione "Risoluzione" di questo articolo (Metodo 2).
  8. Modificare il file Software.old seguendo la procedura descritta nella sezione "Workaround" di questo articolo.
  9. Dopo avere modificato e salvato il file, riavviare la Console di ripristino di emergenza.
  10. Individuare la cartella %SystemRoot%\System32\Config\.
  11. Rinominare l'hive Software esistente, ad esempio Software in Software.ripristino.
  12. Rinominare il file originale corretto con il nome precedente, ad esempio Software.old in Software.

    NOTA: con questa operazione l'hive Software originale modificato viene reinserito nel percorso corretto e tutte le impostazioni dei programmi saranno ripristinate nel Registro di sistema.
  13. Chiudere la Console di ripristino e riavviare il computer.
Se l'esecuzione di questa procedura non fornisce il risultato desiderato oppure se è stato eseguito un aggiornamento e la crittografia avanzata a 128 bit è stata installata prima dell'aggiornamento, potrebbe essere necessario eseguire un'installazione parallela per modificare il Registro di sistema, eseguendo la procedura riportata nella sezione "Workaround" che segue.
Workaround
Per modificare il Registro di sistema, è necessario eseguire un'installazione parallela di Windows 2000 o utilizzare la Console di ripristino di emergenza per copiare il file di registro Software su un supporto rimovibile in modo da poterlo modificare in un altro computer. Il file Registro di sistema Software si trova nel percorso %SystemRoot%\System32\Config ed è denominato Software senza estensione.

AVVISO: l'errato utilizzo dell'editor del Registro di sistema può causare seri problemi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la risoluzione di problemi causati dall'errato utilizzo dell'editor del Registro di sistema. L'utilizzo dell'editor del Registro di sistema è a rischio e pericolo dell'utente.
  1. Da un computer con Windows 2000 avviare l'editor del Registro di sistema (Regedt32).
  2. Dalla finestra HKEY_Local_Machine, fare clic sulla chiaveHKEY_LOCAL_MACHINE.
  3. Scegliere Carica hive dal menu Registro di sistema.
  4. Individuare il file Software e fare doppio clic su di esso.
  5. Nella casella Nome, digitare test e quindi premere INVIO.
  6. Fare doppio clic sulla chiave Test e individuare la seguente chiave:
    Microsoft\Cryptography\Defaults\Provider Types\Type 001
  7. Fare doppio clic sul valore Nome e modificare il nome in Microsoft Base Cryptographic Provider v1.0.

    NOTA: con questa operazione viene ripristinata la crittografia di base predefinita, ma dovrebbe essere possibile accedere al sistema.
  8. Fare clic sulla chiave Test.
  9. Scegliere Scarica hive dal menu Registro di sistema.
  10. Assicurarsi che il file Software modificato sia reinserito nella cartella Winnt\System32\Config del computer che non funziona.
Questa modifica consente di accedere al computer, ma ripristina la crittografia al livello di base. Per disporre di nuovo del livello di crittografia desiderato dopo avere apportato queste modifiche, potrebbe essere necessario reinstallare i pacchetti o il software di crittografia.
Informazioni
Nell'elenco seguente sono riportati i provider di crittografia Microsoft e i nomi dei file DLL associati:
  • Microsoft Base Cryptographic Provider 1.0 utilizza il file Rsabase.dll.
  • Microsoft Base DSS Cryptographic Provider utilizza il file Dssbase.dll.
  • Microsoft Enhanced Cryptographic Provider utilizza il file Rsaenh.dll (installato con High Encryption Pack). Il nome del file nel pacchetto è Rsaenhs.dll e viene rinominato in Rsaenh.dll al momento dell'installazione.
NOTA: poiché il file Rsaenh.dll non è incluso in Windows 2000 e viene caricato durante l'installazione di High Encryption Pack, non verrà controllato o sostituito durante il ripristino dei file di sistema. Per controllare e ripristinare questo file, qualora fosse mancante, danneggiato o di una versione non corretta, occorre utilizzare la Console di ripristino di emergenza.
Riferimenti
Per ulteriori informazioni, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
229716 Descrizione della Console di ripristino di emergenza di Windows 2000
235364 Descrizione del Comando SET nella Console di ripristino di emergenza
255669 Internet Explorer Administration Kit crea la crittografia di sostituzione da 128-Bit in Windows 2000
128bit system cannot log you on now because domain win2000hotds
Proprietà

ID articolo: 244671 - Ultima revisione: 12/05/2015 17:13:13 - Revisione: 4.0

Microsoft Windows 2000 Server, Microsoft Windows 2000 Advanced Server, Microsoft Windows 2000 Professional Edition, Microsoft Windows 2000 Datacenter Server

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