FIX: Richiede più di un minuto per estrarre un file su un server che esegue Visual Studio Team System 2008 Team Foundation Server Service Pack 1

Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 2479245
Sintomi
Quando si estrae un file da un server che esegue Microsoft Visual Studio Team System 2008 Team Foundation Server Service Pack 1, è necessario più di un minuto per completare il Check-Out.
Cause
Questo problema si verifica perché ilPrc_ichecklockstatsusstored procedure viene eseguita molto lentamente nel livello dati Team Foundation Server.
Risoluzione
ImportanteSe si utilizza Team Explorer, Team Build o il Proxy TFS sullo stesso computer del livello di applicazione di TFS, è inoltre necessario installare l'aggiornamento rapido descritto nell'articolo della Knowledge Base riportato di seguito:
974596La dimensione del database TfsVersionControl non viene ridotta come previsto quando si esegue il comando "tf destroy" in Microsoft Visual Studio 2008 Team Foundation Server

Informazioni sull'aggiornamento rapido

È disponibile un hotfix supportato. Tuttavia, questo hotfix è destinato a correggere il problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano il problema descritto in questo articolo. Questo hotfix vengano eseguiti ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il prossimo aggiornamento software contenente tale hotfix.

Per risolvere immediatamente il problema, contattare il servizio di supporto tecnico clienti Microsoft per ottenere l'hotfix. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:NotaIn casi particolari, le spese normalmente addebitate per le chiamate al servizio supporto tecnico clienti Microsoft potrebbero essere annullate qualora un addetto del supporto Microsoft determina che uno specifico aggiornamento risolverà il problema. I costi di supporto standard verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

Per scaricare questo aggiornamento rapido da MSDN Code Gallery, visitare il seguente sito Web Microsoft:
NotaMSDN Code Gallery vengono visualizzate le lingue per cui è disponibile l'aggiornamento rapido. Se non è disponibile la lingua desiderata nell'elenco, è perché la pagina delle risorse Code Gallery non è disponibile per tale lingua.

In alternativa, è possibile scaricare questo aggiornamento rapido dal sito Web Microsoft Connect riportato di seguito:

Prerequisiti

Per applicare questo hotfix, è necessario disporre di Visual Studio Team System 2008 Team Foundation Server Service Pack 1 installato.

Informazioni sul riavvio

Potrebbe essere necessario riavviare il computer dopo aver applicato questo aggiornamento rapido.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.

Informazioni sui file

La versione inglese (Stati Uniti) di questo aggiornamento rapido consente di installare i file con gli attributi elencati nelle tabelle seguenti. Le date e le ore dei file elencate UTC (Coordinated Universal Time). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale. Inoltre, le date e gli orari cambiano quando si eseguono determinate operazioni sui file.
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Microsoft.TeamFoundation.client.dll9.0.30729.508645875212-Gen-201118. 00x86
Microsoft.TeamFoundation.Common.dll9.0.30729.5086331,77612-Gen-201118. 00x86
Microsoft.TeamFoundation.databaseinstaller.dll9.0.30729.50864,399,10412-Gen-201118. 00x86
Microsoft.TeamFoundation.dll9.0.30729.50861,060,86412-Gen-201118. 00x86
Microsoft.TeamFoundation.Server.Admin.dll9.0.30729.508616384012-Gen-201118. 00x86
TeamFoundation9.0.30729.5086516,09612-Gen-201118. 00x86
Microsoft.TeamFoundation.VersionControl.Common.dll9.0.30729.508624985612-Gen-201118. 00x86
Microsoft.TeamFoundation.VersionControl.Common.Integration.dll9.0.30729.50863276812-Gen-201118. 00x86
Microsoft.VisualStudio.TeamSystem.Integration.dll9.0.30729.5086208,89612-Gen-201118. 00x86
TFSAdminUtil. exe9.0.30729.508667,41612-Gen-201118. 00x86



Status
Microsoft ha confermato che questo è un problema con i prodotti elencati nella sezione "Si applica a".
Informazioni
Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 2479245 - Ultima revisione: 03/02/2011 09:32:00 - Revisione: 2.0

Microsoft Visual Studio Team System 2008 Team Foundation Server Service Pack 1

  • kbexpertiseinter kbprb kbsurveynew kbfix kbbug kbqfe kbhotfixserver kbmt KB2479245 KbMtit
Feedback