Al momento sei offline in attesa che la connessione Internet venga ristabilita

ID evento 1025 con codice di errore "0x80041606" quando si utilizza Outlook in modalità in linea per cercare una parola in Exchange Server 2007

Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 2498852
Sintomi
Si consideri il seguente scenario. Per impostazione predefinita, la ricerca di Exchange è attivata per un database di cassette postali in un ambiente Microsoft Exchange Server 2007. Per utilizzare Microsoft Outlook in modalità in linea per la ricerca di una cassetta postale per una parola chiave o una frase che contiene una singola lettera o una cifra. In questo scenario, viene visualizzato il seguente messaggio di errore anche se vi sono corrispondenze per la parola chiave nella cassetta postale:
Nessuna corrispondenza trovata per"parola chiave”.


Inoltre, il seguente evento viene registrato nel registro applicazione sul server cassette postali:
ID evento: 1025
Categoria: nessuno
Origine: MSExchangeIS Cassetta postale archivio
Tipo: avviso
Generato:Data>
Scritti:Data>
Macchina:computer>
Messaggio: si è verificato un errore nel database "database di archiviazione/cassetta postale di gruppo>".
Nome della funzione o descrizione del problema: indicizzazione del contenuto ricevuto un'insolita e
unexpect codice errore MSSearch
Errore: 0x80041606


NOTA: 0X80041606 = QUERY_E_TOOCOMPLEX
Cause
Questo problema si verifica perché la ricerca di Exchange con una restrizione di query di 200.000 nodi. Quando una ricerca prefisso supera la restrizione della query, la ricerca restituisce QUERY_E_TOOCOMPLEX. Pertanto, 0x80041606 viene registrato come parte dell'evento ID 1025. Per impostazione predefinita, tutte le ricerche che utilizzano la modalità in linea di Outlook in un ambiente di Exchange 2007 sono prefisso. Se vengono utilizzate solo cifre o lettere, in questo modo il sistema cercare tutti i numeri o parole che iniziano con la cifra o la lettera attraverso il database dell'intera cassetta postale. Se viene raggiunto il limite predefinito di 200.000 nodi, la ricerca restituisce l'errore.

NotaIl modo più comune per raggiungere il limite di 200.000 nodi è cercare una parola o frase che contiene una cifra o lettera. Esistono altre cause meno comuni, ad esempio ricerche molto complesse con molti AND, OR e non gli operatori. Inoltre, i termini di combinazioni complesse di intervalli di date e di ricerca, diverse voci diPer e Da campi o una combinazione di questi elementi potrebbe essere raggiunto il limite.
Risoluzione
Per risolvere questo problema, installare l'aggiornamento cumulativo seguente:
2608656 Descrizione dell'aggiornamento cumulativo 6 per Exchange Server 2007 Service Pack 3
Importante Questa sezione, metodo o attività contiene viene illustrato come modificare il Registro di sistema. Tuttavia, potrebbero verificarsi problemi gravi se l'errata modifica del Registro di sistema. Pertanto, assicurarsi di seguire attentamente i passaggi. Per maggiore protezione, eseguire una copia di backup del registro prima di modificarlo. Quindi, è possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup e ripristinare il Registro di sistema, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
322756 Come eseguire il backup e ripristinare il Registro di Windows

Dopo aver installato l'aggiornamento cumulativo, attenersi alla seguente procedura per impostare il numero massimo di nodi di restrizione di query.

Nota Si consiglia un valore iniziale di 1.000.000 (decimale):
  1. Nel registro applicazione sul server cassette postali 2007 Exchange Server notare quante volte ID evento 1025 con codice di errore 0x80041606 durante lo scorso mese. Queste informazioni verranno utilizzate come base per determinare se l'impostazione MaxRestrictionNodes riduce o Elimina il problema.
  2. Fare clic su Iniziopulsante Start, tipo Regedit nel Avvia ricerca casella e quindi premere INVIO.
  3. Individuare e selezionare la seguente sottochiave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExSearch
  4. Fare clic su Modifica, scegliere Nuovo, quindi scegliere Chiave.
  5. Tipo MaxRestrictionNodes, quindi premere INVIO.
  6. Fare clic su MaxRestrictionNodes, fare clic su Modifica, selezionare Nuovo, quindi scegliere Valore DWORD (32 bit).
  7. Tipo Server, quindi premere INVIO.

    Nota La voce del Registro di sistema sarà simile al seguente:

    Nome chiave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExSearch\MaxRestrictionNodes

    Nome valore: Server
    Tipo valore: REG_DWORD
  8. Fare clic su Server, fare clic su Modifica, quindi scegliere Modificare.
  9. Nel Dati valore tipo di campo 1000000 (Decimale).

    Nota La voce del Registro di sistema sarà simile al seguente:

    Nome chiave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExSearch\MaxRestrictionNodes

    Nome valore: Server
    Tipo valore: REG_DWORD
    Dati valore: 1000000 (decimale)
  10. Uscire dall'Editor del Registro di sistema.
  11. Riavviare il servizio Indicizzatore ricerca di Microsoft Exchange.
Note
  • Dopo aver riavviato il servizio Indicizzatore ricerca di Microsoft Exchange, verificare i seguenti ID evento nel registro applicazione:
    • 130 ID evento: Impossibile convertire un GUID di lettura MailboxDB Guid in sotto la chiave di registro MaxRestrictionNodes
    • 131 ID evento: Impossibile aprire la chiave di registro MaxRestrictionNodes
    • 132 ID evento: Impossibile impostare la proprietà MaxRestrictionNodes nell'indicizzatore
  • Se ricevono uno di questi eventi, può essere immesso la chiave o valore DWORD erroneamente. O potrebbe non avere digitato la chiave o un nuovo valore DWORD correttamente. Apportare le correzioni necessarie e quindi riavviare il servizio Indicizzatore ricerca di Microsoft Exchange. Ricerca di nuove istanze di ID evento 130, 131 e 132.
  • Controllare il registro applicazione settimana o mensile in base al numero di messaggi di evento ID 1025 0x80041606 di errore nel registro applicazione.
  • Se si ricevono ancora un numero significativo di questi eventi, è possibile aumentare il valore incrementale per 2000000 (decimale).
  • Poiché questa operazione potrebbe ridurre le prestazioni del server, non aumentare il valore oltre 2000000 (decimale) senza direzione esplicita dal supporto tecnico.
Status
Microsoft ha confermato che questo è un problema nei prodotti Microsoft elencati nella sezione "Si applica a".
Informazioni
Per ulteriori informazioni sulla ricerca di Exchange, visitare il seguente sito Web Microsoft:
Per ulteriori informazioni su come disattivare o attivare la ricerca di Exchange, visitare il seguente sito Web Microsoft:
Per ulteriori informazioni, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:

2616127ID evento 9877 con codice di errore "0x80041606" quando si utilizza Outlook in modalità in linea per cercare una parola nel 2010 Exchange Server

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 2498852 - Ultima revisione: 10/30/2012 21:22:00 - Revisione: 2.0

Microsoft Exchange Server 2007 Service Pack 3

  • kbqfe kbfix kbsurveynew kbexpertiseinter kbmt KB2498852 KbMtit
Feedback