Come utilizzare l'editor di database Orca per modificare i file di Windows Installer

IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 255905
Dichiarazione di non responsabilità per articoli della Microsoft Knowledge Base su prodotti non più supportati
Questo articolo è stato scritto sui prodotti per cui Microsoft non offre più supporto. L’articolo, quindi, viene offerto ‘così come è’ e non verrà più aggiornato.
Sommario
A causa delle limitazioni degli strumenti di Windows Installer esistente, è necessario modificare direttamente i file di pacchetto MSI di Windows Installer. L'editor di database Orca è uno strumento per la modifica è disponibile nel SDK di Windows Installer e può essere utilizzato per modificare i file con estensione msi. L'editor Orca modifica e crea file di unione (MSM), file di analizzatore di coerenza interna (cub) e file di creazione di patch (con estensione PCP). In questo articolo viene illustrato come utilizzare l'editor Orca per modificare i file con estensione msi.
Informazioni
Avviso La modifica di un file MSI può causare seri problemi che possono lasciare il sistema instabile. Microsoft non garantisce che possano essere risolti i problemi derivanti dall'errato utilizzo dell'editor del file MSI. Modifiche del file MSI del prodotto spedizione devono essere eseguite solo in istruzioni dirette dal fornitore del prodotto.

Installazione ed esecuzione di Orca

Per installare ed eseguire l'editor Orca, attenersi alla seguente procedura:
  1. Scaricare gli esempi di Windows Installer SDK, strumenti, anddocumentation dalla seguente pagina Web:
  2. Installare l'editor Orca facendo doppio clic nella cartella \Microsoft SDK\bin di Orca.msifile.
  3. Fare clic su Start, scegliere programmie quindi fare clic su Orca.
  4. Dal menu File , fare clic su Aprie quindi individuare il file MSI che si desidera toedit.

Tabelle

Le tabelle nel file. msi sono elencate nel riquadro di sinistra. Selezionare la tabella da modificare. I campi della tabella vengono visualizzati nella parte superiore del riquadro di destra. È possibile espandere e comprimere questi campi.

Per aggiungere tabelle standard che non è visualizzato, scegliere Aggiungi tabella dal menu tabelle . Per rimuovere una tabella, scegliere Rimuovi tabella dal menu tabelle . È necessario selezionare una tabella l'opzione Drop Table è visualizzato nel menu.

Le opzioni di Esportazione e Importazione tabelle si trovano nel menu tabelle . L'opzione Esporta tabelle consente di esportare una tabella in un formato di testo che può essere modificato con un editor di testo quale Blocco note. La tabella esportata ha un'estensione di .idt. Tramite l'azione Importa tabelle , è possibile importare queste tabelle IDT nell'editor di Orca.

Righe

Per aggiungere una riga a una tabella, fare clic su Aggiungi riga dal menu tabelle . Una finestra di dialogo viene visualizzata con i campi della tabella selezionata. I campi con una chiave dorata accanto a essi sono le chiavi primarie per la tabella. Il nome del campo è indicato sopra la casella di modifica, seguita dal tipo di campo. Se la parola "Required" segue il tipo di campo, questo campo è obbligatorio e non è possibile aggiungere la riga fino a quando non viene visualizzato un valore in questo campo.

Per rimuovere una riga, selezionare la riga della tabella e quindi fare clic su Riga di riepilogo dal menu tabelle .

Per modificare un campo in una riga esistente, fare doppio clic all'interno del campo che si desidera modificare.

Convalida

La convalida viene eseguita dall'interno dell'editor Orca scegliendo convalida dal menu Strumenti . Se si utilizza l'editor Orca incluso nel SDK più recente di Windows Installer, è un elenco a discesa dei file che è possibile eseguire la valutazione disponibile.

Per convalidare un file, attenersi alla seguente procedura:
  1. Selezionare un gruppo di file valutazione disponibile dal menu a discesa thedrop nell'editor di Orca di Windows Installer SDK più recente.
    • Selezionare l' Intera Suite di MSI convalida per convalidare un file MSI con tutte le convalide disponibili.
    • Selezionare una Suite di programmi Logo di Windows 2000 per eseguire un sottoinsieme i controlli di convalida che vengono utilizzati per la certificazione del logo.
    • Selezionare Gruppo di convalida modulo unione per convalidare un file MSM.
  2. Fare clic per deselezionare Mostra messaggi "INFO" per evitare messaggi informativi che non indicano aproblem con il database.
  3. Fare clic su Vai.
Una volta completata la convalida, è possibile copiare i risultati in un editor di testo per la visualizzazione.

Finestre di dialogo

Se il file MSI aperto nell'editor di Orca contiene finestre di dialogo per l'interfaccia utente, visualizzare in anteprima queste finestre di dialogo utilizzando l'opzione della Finestra di dialogo Anteprima dal menu Strumenti . È necessario utilizzare tabelle appropriate per la modifica delle finestre di dialogo.

Informazioni di riepilogo

Per modificare le informazioni di riepilogo, fare clic su Informazioni di riepilogo dal menu Visualizza .

Nota Il campo ProductID è il codice del pacchetto per il file MSI, non il codice del prodotto. Il codice prodotto viene memorizzato nella tabella delle proprietà nella proprietà ProductCode. Se si salva il file MSI nell'editor di Orca, il codice del pacchetto non viene modificato automaticamente. È necessario apportare questa modifica manualmente.
Riferimenti
Tutte le informazioni specifiche tabelle o campi in un file msi si trovano nel file della Guida di Windows Installer (. chm). Il file della Guida viene installato nella directory MsiIntel.SDK\Help durante l'installazione di Windows Installer SDK. Le informazioni delle tabelle standard sono nel seguente percorso del file della Guida:

Tabelle di Reference\Database Database Database\Installer Installer.
Per installare ed eseguire il controllo di ActiveX SDK Update:

Avviso: questo articolo è stato tradotto automaticamente

Savybės

Straipsnio ID: 255905 – Paskutinė peržiūra: 09/28/2016 00:03:00 – Peržiūra: 5.0

  • kbappsetup kbhowto kbmt KB255905 KbMtit
Atsiliepimai