Risoluzione dei problemi relativi all'installazione dell'agente System Center Operations Manager

Sintomi
L'agente System Center Operations Manager(SCOM) può essere distribuito nei computer Windows tramite "inserimento remoto" da un server di gestione oppure può essere installato manualmente in un computer di destinazione mediante MomAgent.msi.Se l'installazione dell'agente ha esito negativo, esistono alcune procedure di risoluzione dei problemi che possono essere utilizzate a seconda di dove si verifica l'errore e della modalità di distribuzione dell'agente.
Risoluzione

Verificare che il computer di destinazione soddisfi la configurazione supportata
Il passaggio iniziale nella risoluzione dei problemi relativi all'installazione dell'agente Operations Manager in un computer Windows consiste nel verificare se il potenziale agente soddisfa la configurazione hardware e software supportata. Nei seguenti articoli sono riportati i requisiti per un agente Operations Manager 2007 e 2012:

Configurazioni supportate da Operations Manager 2007 R2

Configurazioni supportate da Operations Manager 2012

Se il sistema di destinazione è un computer Unix/Linux, verificare che la distribuzione e la versione siano supportate. Tenere presente che il supporto di alcune versioni di Operations Manager 2007 richiede aggiornamenti cumulativi successivi a R2. Nell'articolo seguente sono incluse le versioni supportate di Unix/Linux:

System Center Operations Manager 2007 R2 Cross Platform Monitoring Management Pack

Versioni dei sistemi operativi Unix e Linux supportate da System Center Operations Manager 2012

Risoluzione dei problemi relativi alla distribuzione dell'agente mediante Individuazione guidata nella console di Operations Manager
Se l'agente verrà distribuito mediante l'individuazione dalla console di Operations Manager, sarà installato dal server di gestione o dal server gateway specificato in Individuazione guidata per gestire l'agente, non dal server al quale era connessa la console operatore al momento dell'apertura. Pertanto, è necessario eseguire eventuali verifiche dal server di gestione o dal server gateway specificato durante l'esecuzione della procedura guidata oppure specificare un server di gestione/gateway diverso durante la procedura guidata, per vedere se si verifica lo stesso errore.

  • Problema:
    La procedura guidata non visualizza un elenco di potenziali agenti da installare.

    Causa:
    Le credenziali specificate nella procedura guidata durante l'individuazione iniziale dovrebbero disporre dell'autorizzazione a cercare in Active Directory potenziali agenti Operations Manager. Se l'account non è in grado di connettersi ad Active Directory, Individuazione guidata avrà esito negativo.

    Gli errori tipici che vengono visualizzati possono essere:
    • Codice errore: 800706BA
      Descrizione errore: Server RPC non disponibile
    • Codice errore: 80070079
      Il server MOM non è riuscito a eseguire l'operazione specificata sul computer nome. Periodo di timeout del semaforo scaduto.
    • Codice errore: 80070643
      L'installazione dell'agente dell'operazione di gestione dell'agente non è riuscita per il computer remoto "nome"

    Risoluzioni possibili:
    • Durante la procedura di individuazione, specificare un account che disponga delle autorizzazioni di amministratore di dominio e che faccia parte del gruppo Amministratori di Operations Manager.
    • Se si verifica il timeout della query LDAP o se questa non è in grado di risolvere gli agenti potenziali in Active Directory, l'individuazione può essere eseguita mediante la shell dei comandi di Operations Manager. Per ulteriori informazioni, vedere la seguente sezione "Risoluzione dei problemi relativi alla distribuzione dell'agente mediante la shell dei comandi di Operations Manager".

  • Problema:
    Il computer di destinazione non è nell'elenco dei potenziali agenti dopo aver eseguito l'individuazione iniziale.

    Causa:
    • Il computer è già identificato nel database come parte del gruppo di gestione.
    • Il computer è elencato nella sezione "Azioni in sospeso"' nella console operatore.

    Risoluzioni possibili:
    • Se il computer di destinazione è elencato nel nodo "Azioni in sospeso" dello spazio "Amministrazione" nella console operatore, l'azione esistente deve essere approvata o rifiutata prima di poter eseguire una nuova azione. Se le impostazioni di installazione esistenti sono sufficienti, approvare l'installazione in sospeso dalla console. Se le impostazioni esistenti non sono corrette, rifiutare l'azione in sospeso, quindi eseguire nuovamente l'individuazione guidata.

  • Problema:
    Durante Individuazione guidata si verifica uno dei seguenti errori mentre si prova a installare l'agente:
    • Operazione: installazione agente
      Codice errore: 800706D9
    • Descrizione errore: Errore sconosciuto 0xC000296E
    • Descrizione errore: Errore sconosciuto 0xC0002976
    • Codice errore: 80070643
      Descrizione errore: Errore irreversibile durante l'installazione.


    Causa:
    • L'account specificato in precedenza per eseguire l'installazione dell'agente in Individuazione guidata dovrà disporre delle autorizzazioni per connettersi in remoto al computer di destinazione e installare un servizio Windows. Questa operazione richiede autorizzazioni di amministratore locale a causa del requisito di scrittura nel Registro di sistema.
    • Le restrizioni di Criteri di gruppo nell'account del computer del server di gestione o nell'account utilizzato per l'inserimento dell'agente, possono impedire una corretta installazione. Gli oggetti Criteri di gruppo in Active Directory che impediscono all'account del computer del server di gestione o all'account utente utilizzato da Individuazione guidata di accedere in remoto alla cartella Windows, al Registro di sistema a WMI o alle condivisioni amministrative nel computer di destinazione possono impedire una corretta distribuzione dell'agente Operations Manager.
    • Windows Firewall blocca le porte tra il server di gestione e il computer di destinazione.
    • I servizi necessari nel computer di destinazione non sono in esecuzione.


    Risoluzioni possibili:
    • Se le credenziali specificate nella procedura guidata non dispongono delle autorizzazioni di amministratore locale, aggiungere l'account al gruppo di sicurezza Administrators nel computer di destinazione o utilizzare un account già membro di tale gruppo.
    • Bloccare l'eredità dei criteri di gruppo nel computer di destinazione o l'account utente che esegue l'installazione.

    • Se l'installazione di un agente non riesce quando si utilizza un account del dominio per forzare l'agente da un server di gestione, l'utilizzo degli strumenti di amministrazione di Windows consente di identificare potenziali problemi. Accedere al server di gestione con le credenziali in questione e provare a eseguire le seguenti attività. Se l'account non dispone delle autorizzazioni per accedere al server di gestione, gli strumenti possono essere eseguiti con credenziali da testare da un prompt dei comandi.
      • "RUNAS /user: compmgmt.msc". Dalla voce di menu "Azione", selezionare "Connetti a un altro computer". Cercare o digitare il nome del computer remoto. Provare ad aprire il visualizzatore eventi e cercare uno dei log eventi.
      • "RUNAS /user:services.msc". Dalla voce di menu "Azione", selezionare "Connetti a un altro computer". Cercare o digitare il nome del computer remoto. Provare ad avviare o arrestare lo spooler di stampa o qualsiasi altro servizio sul computer di destinazione.
      • "RUNAS /user: regedt32.exe". Dalla voce di menu "File", selezionare "Connetti a Registro di sistema in rete". Cercare o digitare il nome del computer remoto. Provare ad aprire "HKey_Local_Machine" sul computer remoto.
      • "RUNAS /user:Explorer.exe". Nella barra degli indirizzi, digitare quanto segue: \\admin$

        Se una di questa attività ha esito negativo, provare a utilizzare un account diverso per ottenere le autorizzazioni Amministratore dominio o Amministratore locale (nel computer di destinazione). Provare, inoltre, le stesse attività da un server o una workstation membri per vedere se le attività hanno esito negativo da più macchine.
        L'impossibilità di connettersi alla condivisione admin$ potrebbe impedire al server di gestione di copiare i file di configurazione nel computer di destinazione. L'impossibilità di connettersi al Registro di sistema Windows nel computer di destinazione potrebbe impedire l'installazione corretta del servizio integrità. L'impossibilità di connettersi a Gestione controllo servizi impedirà al programma di installazione di avviare il servizio.
    • Le seguenti porte devono essere aperte tra il server di gestione e il computer di destinazione:
      • Numero porta mapper endpoint RPC: 135 Protocollo: TCP/UDP
      • *Porte di numero alto RPC/DCOM (SO 2000/2003) Porte 1024-5000 Protocollo: TCP/UDP
      • *Porte di numero alto RPC/DCOM (SO 2008) Porte 49152-65535 Protocollo: TCP/UDP
      • Numero porta del servizio nomi NetBIOS: 137 Protocollo: TCP/UDP
      • Numero porta del servizio sessione NetBIOS: 139 Protocollo: TCP/UDP
      • Numero porta SMB su IP: 445 Protocollo: TCP
      • Numero di porta del canale MOM: 5723 Protocollo: TCP/UDP
    • I seguenti servizi devono essere abilitati e in esecuzione nel computer di destinazione:
      • Netlogon
      • Registro di sistema remoto
      • Windows Installer
      • Aggiornamenti automatici

Nei seguenti articoli vengono fornite alcune informazioni di base sulla distribuzione dell'agente Operations Manager mediante l'individuazione dal server di gestione:

Come distribuire l'agente Operations Manager 2007 mediante l'installazione guidata dell'agente
How does Computer Discovery Work in OpsMgr 2007?
Agent discovery and push troubleshooting in OpsMgr 2007
Console based Agent Deployment Troubleshooting table
Gestione individuazione e agenti in SCOM 2012

Risoluzione dei problemi relativi alla distribuzione dell'agente mediante la shell dei comandi di Operations Manager
In alcune situazioni, potrebbe verificarsi il timeout dell'individuazione automatica di potenziali agenti a causa di ambienti Active Directory molto grandi o complessi. Altre situazioni potrebbero richiedere che l'individuazione automatica venga eseguita con una query LDAP più limitata di quanto è disponibile nell'interfaccia utente. In questi casi, l'individuazione automatica di computer e l'installazione remota dell'agente Operations Manager è possibile mediante la shell di comandi di Operations Manager. Nel seguente post del blog viene illustrata la sintassi necessaria per eseguire la seguente operazione:

Individuazione di computer Windows tramite Powershell

Risoluzione dei problemi relativi alla distribuzione dell'agente attraverso la registrazione dettagliata di Windows Installer
Se l'installazione dell'agente in un computer remoto ha esito negativo durante l'installazione, un registro dettagliato di Windows Installer può essere creato nel server di gestione nel seguente percorso predefinito:

C:\Program Files\System Center Operations Manager \AgentManagement\AgentLogs

Dove è 2007 o 2012

Il registro può essere utilizzato per determinare se si è verificato un errore specifico e potrebbe essere utile per risolvere ulteriormente i problemi relativi all'installazione dell'agente Operations Manager nel computer di destinazione.

Cercare la prima voce con la stringa "Valore restituito 3" nel registro. Le poche righe precedenti indicano generalmente l'errore che si è verificato in Windows Installer. Il formato tipico sarà "funzione/descrizione dell'errore/codice errore restituito" e può indicare problemi relativi alle autorizzazioni, a file mancanti o ad altre impostazioni che devono essere modificate. Esempi:

  • Messaggio di errore:
    ConvertStringSecurityDescriptorToSecurityDescriptor non riuscito: 87

    Possibile causa:
    L'account di installazione non dispone dell'autorizzazione per il Registro di protezione nel computer di destinazione

  • Messaggio di errore:
    ModifyEventLogAccessForNetworkService(): Impossibile concedere l'accesso in lettura a SecurityLog: 0x00000057

    Possibile causa:
    L'account di installazione non dispone dell'autorizzazione per il Registro di protezione nel computer di destinazione

  • Messaggio di errore:
    Impossibile aprire il file di database. Errore di sistema -2147024629

    Possibile causa:
    L'account di installazione non dispone delle autorizzazioni per la cartella TEMP del sistema

Esistono molti possibili errori che possono essere registrati qui. Altri singoli errori possono essere ulteriormente cercati nella TechNet o Knowledge Base online.

Risoluzione dei problemi relativi all'installazione manuale dell'agente Operations Manager
Nei casi in cui non è possibile distribuire l'agente Operations Manager in un computer remoto mediante Individuazione guidata, sarà necessario installare l'agente manualmente. Questa operazione può essere eseguita tramite la riga di comando utilizzando il file MomAgent.msi. Nei seguenti riferimenti vengono descritti i vari comandi e le opzioni di configurazione disponibili per eseguire l'installazione manuale:

Come distribuire l'agente Operations Manager 2007 utilizzando MOMAgent.msi dalla riga di comando
Windows Agent Install MSI Use Cases and Commands
Installazione manuale degli agenti in Operations Manager 2007

Distribuzione dell'agente Operations Manager 2012 mediante la riga di comando

Elaborare installazioni manuali dell'agente in Operations Manager 2012

Esempi di utilizzo del comando MOMAgent per gestire gli agenti in Operations Manager 2012

Se l'agente viene distribuito mediante installazione manuale, dovranno essere distribuiti manualmente anche aggiornamenti del Service Pack o aggiornamenti cumulativi futuri. I computer che sono stati installati manualmente non verranno indicati dal servizio System Center Configuration Management come gestibili in remoto e l'opzione per aggiornarli non sarà presente nella console operatore.

Altre considerazioni chiave da tenere presenti durante l'installazione manuale degli agenti:

  • Se l'installazione viene eseguita da un utente del dominio o locale, l'account deve essere un membro del gruppo di sicurezza Amministratori locale in Vista o sistemi operativi successivi. Nei sistemi operativi precedenti a Vista, gli utenti membri del gruppo di sicurezza "Power Users" disponevano delle autorizzazioni necessarie per installare i servizi.
  • Se l'agente viene distribuito mediante Configuration Manager, l'account del servizio dell'agente di Configuration Manager dovrà essere eseguito come Localsystem (impostazione predefinita) o nel contesto di un amministratore locale.

Gli errori che impediscono l'installazione manuale degli agenti possono essere identificati nei file di registro dell'installazione di Windows Installer. È possibile utilizzare il comando seguente per attivare la registrazione dettagliata di Windows Installer dell'installazione dell'agente Operations Manager:
msiexec.exe /i "MOMAgent.msi" /l*v "C:\Agent\MOMAgent_install.log"

In alternativa, nel seguente articolo viene descritto come attivare globalmente la registrazione dettagliata di Windows Installer in un computer Windows:
Come attivare la registrazione di Windows Installer

Il registro può essere utilizzato per determinare se si è verificato un errore specifico e potrebbe essere utile per risolvere ulteriormente i problemi relativi all'installazione dell'agente Operations Manager nel computer di destinazione.

Cercare la prima voce con la stringa "Valore restituito 3" nel registro. Le poche righe precedenti indicano generalmente l'errore che si è verificato in Windows Installer. Il formato tipico sarà "funzione/descrizione dell'errore/codice errore restituito" e può indicare problemi relativi alle autorizzazioni, a file mancanti o ad altre impostazioni che devono essere modificate.

Esempi:

  • Messaggio di errore:
    ConvertStringSecurityDescriptorToSecurityDescriptor non riuscito: 87

    Possibile causa:
    L'account di installazione non dispone dell'autorizzazione per il Registro di protezione nel computer di destinazione

  • Messaggio di errore:
    ModifyEventLogAccessForNetworkService(): Impossibile concedere l'accesso in lettura a SecurityLog: 0x00000057

    Possibile causa:
    L'account di installazione non dispone dell'autorizzazione per il Registro di protezione nel computer di destinazione

  • Messaggio di errore:
    Impossibile aprire il file di database. Errore di sistema -2147024629

    Possibile causa:
    L'account di installazione non dispone delle autorizzazioni per la cartella TEMP del sistema

Esistono molti possibili errori che possono essere registrati qui. Altri singoli errori possono essere ulteriormente cercati nellaTechNet o Knowledge Base online.

Informazioni
Questo articolo si applica a tutte le versioni di System Center Operations Manager 2007 (OpsMgr 2007) e a tutte le versioni di System Center 2012 Operations Manager (OpsMgr 2012).
Nota: questo è un articolo a "PUBBLICAZIONE RAPIDA", creato direttamente all'interno dell'organizzazione di supporto Microsoft. Le informazioni contenute nel presente documento vengono fornite "così come sono" in risposta alle problematiche riscontrate. A causa della rapidità con cui vengono resi disponibili, i materiali possono contenere errori di battitura e sono soggetti a modifica senza preavviso, in qualsiasi momento. Per altre considerazioni, vedere le Condizioni per l'utilizzo.
Proprietà

ID articolo: 2566152 - Ultima revisione: 10/06/2015 16:47:00 - Revisione: 1.0

Microsoft System Center Operations Manager 2007, Microsoft System Center Operations Manager 2007 R2, Microsoft System Center Operations Manager 2007 Service Pack 1, Microsoft System Center 2012 Operations Manager, Microsoft System Center 2012 Operations Manager Service Pack 1

  • kbtshoot KB2566152
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