Works Suite: Messaggio di errore: Winword ha provocato un errore di pagina non valida nel modulo User32.dll

Questo articolo è stato archiviato. L’articolo, quindi, viene offerto “così come è” e non verrà più aggiornato.
Sintomi
Quando si chiude un documento di Microsoft Word 2000, è possibile che venga visualizzato un messaggio di errore nel quale è specificato che si è verificata un'operazione non valida. Facendo clic su Dettagli, è possibile che venga visualizzato un messaggio di errore analogo al seguente:
Winword ha provocato un errore di pagina non valida nel modulo User32.dll.
Cause
È possibile che questo problema si verifichi se sono vere tutte le seguenti condizioni:
  • Viene aperto un documento di Word 2000 creato da un modello del componente aggiuntivo Word in Works Suite mentre era attivo l'Assistente di Office di Word 2000.
  • Il documento di Word 2000 viene chiuso scegliendo il pulsante di chiusura nell'angolo superiore destro della finestra del documento.
Il messaggio di errore viene generato da un conflitto di chiusura tra l'Assistente di Office in Word 2000 e il modello del componente aggiuntivo Word in Works Suite. Questo comportamento non dovrebbe tuttavia causare perdite di dati.
Risoluzione
Per risolvere il problema, utilizzare i metodi illustrati di seguito nell'ordine in cui vengono presentati.

Disattivare l'Assistente di Office e creare di nuovo il documento di Word 2000

Per disattivare l'Assistente di Office e creare di nuovo il documento di Word 2000:
  1. Avviare Works Suite.
  2. In Avvio attività di Works Suite fare clic sulla scheda Programmi quindi su Word.
  3. Selezionare l'attività che si desidera utilizzare, quindi fare clic su Inizio.
  4. Selezionare il modello che si desidera utilizzare, quindi scegliere Fine.
  5. Aprire il documento di Word originale.
  6. Selezionare il testo nella prima pagina del documento.
  7. Scegliere Copia dal menu Modifica.
  8. Fare clic sul pulsante sulla barra delle applicazioni per passare al nuovo documento.
  9. Nel nuovo documento, posizionare il punto di inserimento nella parte superiore della prima pagina e scegliere Incolla dal menu Modifica.
  10. Fare clic sul pulsante sulla barra delle applicazioni per passare al documento originale.
  11. Ripetere i passaggi da 6 a 10 per ogni pagina che è necessario ricreare nel nuovo documento.
  12. Nel nuovo documento scegliere Nascondi l'Assistente di Office dal menu ?.
  13. Scegliere Salva con nome dal menu File.
  14. Nella finestra di dialogo Salva con nome passare alla cartella in cui si desidera salvare il documento.
  15. Nella casella Nome file digitare un nome da assegnare alla sequenza brani, quindi scegliere Salva.
NOTA: con questo metodo non vengono corretti documenti con problemi che attivano la visualizzazione del messaggio di errore citato nella sezione "Sintomi" di questo articolo. Per questi documenti che creano problemi, è necessario seguire il metodo per ricreare il documento originale.

Se non si desidera disattivare l'Assistente di Office oppure se il numero di documenti da ricreare con il metodo descritto in precedenza è eccessivo, passare al metodo seguente.

Rimuovere il componente aggiuntivo Word in Works Suite

Per impedire il conflitto di chiusura che causa il messaggio di errore citato nella sezione "Sintomi" di questo articolo, è necessario rimuovere il componente aggiuntivo Word in Works Suite. Prima di procedere, consultare la sezione "Informazioni" di questo articolo per informazioni sugli svantaggi che derivano dalla rimozione di questo componente aggiuntivo.

Per rimuovere il componente aggiuntivo Word in Works Suite:
  1. Inserire il CD 1 di Works Suite nell'unità CD-ROM. Tenere premuto MAIUSC quando si inserisce il CD in modo da impedire l'avvio automatico del programma di installazione di Works.
  2. Fare clic sul pulsante Start, scegliere Impostazioni, quindi Pannello di controllo.
  3. Fare doppio clic su Installazione applicazioni.
  4. Fare clic sull'opzione relativa al componente aggiuntivo, quindi scegliere Aggiungi/Rimuovi.
  5. Scegliere Avanti, fare clic su Rimuovi, quindi scegliere Avanti.
  6. Fare clic su Rimuovi, quindi scegliere Fine.
  7. Scegliere OK e chiudere il Pannello di controllo.
Status
Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Si applica a..." di questo articolo.
Informazioni
Microsoft consiglia di considerare i seguenti svantaggi prima di rimuovere il componente aggiuntivo Word in Works Suite.

Quando si rimuove il componente aggiuntivo Word in Works Suite:
  • Viene rimosso Word 2000 da Avvio attività di Works Suite.
  • Si perdono le funzioni dell'elaboratore testi nell'Avvio attività di Works Suite.
  • È necessario avviare Word 2000 nel modo seguente:

    Fare clic sul pulsante Start, scegliere Programmi, quindi Microsoft Word.
Per reinstallare il componente aggiuntivo Word in Works Suite:
  1. Fare doppio clic sull'icona Risorse del computer sul desktop.
  2. Fare clic con il pulsante destro del mouse sull'icona dell'unità CD-ROM, quindi scegliere Esplora.
  3. Nel riquadro sinistro fare doppio clic sulla cartella WordAdd.
  4. Nel riquadro destro fare doppio clic su Setup.exe.
  5. Seguire le istruzioni che verranno visualizzate per reinstallare il componente aggiuntivo Word in Works Suite.
  6. Uscire da Esplora risorse e chiudere la finestra Risorse del computer.
w_works works2k w2001 wkssuite installating uninstalling gpf ipf normal.dot wd2000 wd2k word2000 w2003
Proprietà

ID articolo: 257417 - Ultima revisione: 01/24/2014 03:25:52 - Revisione: 3.0

Microsoft Works Suite 2003 Standard Edition, Microsoft Works Suite 2001 Standard Edition, Microsoft Works Suite 2000 Standard Edition

  • kbnosurvey kbarchive kbaddin kbbug kberrmsg kbpending kbui KB257417
Feedback