Attributi duplicati o non validi impediscono la sincronizzazione delle directory in Office 365

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PROBLEMA
In Microsoft Office 365, un amministratore riceve il seguente avviso di messaggio di posta elettronica al termine della sincronizzazione delle directory:
Oggetto: Rapporto errore di sincronizzazione Directory
Il rapporto di errore nel messaggio di posta elettronica può contenere uno o più dei seguenti messaggi di errore:
  • Esiste già un oggetto sincronizzato con lo stesso indirizzo proxy nella directory di Microsoft Online Services.
  • Impossibile aggiornare questo oggetto perché l'ID utente non viene trovata.
  • Impossibile aggiornare l'oggetto in Microsoft Online Services poiché i seguenti attributi associati all'oggetto hanno valori che possono essere già associati a un altro oggetto nella directory locale.
  • Impossibile aggiornare questo oggetto perché i seguenti attributi associati all'oggetto sono valori che possono essere già associati a un altro oggetto in servizi directory locale: [UserPrincipalName John@contoso.com;]. Correggere o rimuovere i valori duplicati nella directory locale.
  • Impossibile aggiornare questo oggetto perché i seguenti attributi associati all'oggetto sono valori che possono essere già associati a un altro oggetto in servizi directory locale: [ProxyAddresses SMTP:John@contoso.com;]. Correggere o rimuovere i valori duplicati nella directory locale.
Inoltre, se si sta eseguendo il servizio di sincronizzazione di Active Directory di Azure (Connect), nel registro applicazione nel Visualizzatore eventi viene registrato un evento ID 6941 che contiene uno dei seguenti messaggi di errore:
  • ID evento: 6941
    Nome registro: applicazione
    Origine: sincronizzazione Active Directory
    Livello: errore
    Dettagli:
    Esegui esportazione ECMA2 MA ha causato un errore.

    Errore nome: AttributeValueMustBeUnique
    Dettagli errore: Impossibile aggiornare l'oggetto perché i seguenti attributi associati all'oggetto sono valori che possono essere già associati a un altro oggetto in servizi directory locale: [UserPrincipalName John@contoso.com;]. Correggere o rimuovere i valori duplicati nella directory locale. Fare riferimento a http://support.microsoft.com/kb/2647098 per ulteriori informazioni sull'identificazione di oggetti con valori di attributo duplicato.
  • ID evento: 6941
    Nome registro: applicazione
    Origine: sincronizzazione Active Directory
    Livello: errore
    Dettagli:
    Esegui esportazione ECMA2 MA ha causato un errore.

    Errore nome: InvalidSoftMatch
    Dettagli errore: Impossibile aggiornare l'oggetto perché i seguenti attributi associati all'oggetto sono valori che possono essere già associati a un altro oggetto in servizi directory locale: [ProxyAddresses SMTP:John@contoso.com;]. Correggere o rimuovere i valori duplicati nella directory locale.
CAUSA
Questo problema può verificarsi se gli oggetti utente dello schema di Active Directory Domain Services (AD DS) locali sono duplicati o valori non validi alias e se questi oggetti utente non vengono sincronizzati dallo schema di Active Directory a Office 365 correttamente durante la sincronizzazione delle directory.

Tutti i valori di alias in Office 365 devono essere univoci per una determinata organizzazione. Anche se si dispone di più suffissi univoci dopo il simbolo di chiocciola (@) dell'indirizzo di Simple Mail Transfer Protocol (SMTP), tutti i valori di alias devono essere univoci.

In un ambiente locale, è possibile alias valori sono le stesse sono univoci in base a suffissi dopo il simbolo di chiocciola (@) dell'indirizzo SMTP.

Se si creano oggetti con valori di alias duplicato nel cloud per Office 365, per rendere gli alias univoco, un alias è un numero univoco aggiunto a tale. (Ad esempio, se i valori duplicati alias "Albert", uno di essi diventa "Albert2" automaticamente. Se "Albert2" è già in uso, l'alias diventa "Albert3" e così via.) Tuttavia, se vengono creati oggetti con valori duplicati alias nei propri locali un conflitto oggetto AD DS, si verifica quando viene eseguita la sincronizzazione delle directory, e l'oggetto sincronizzazione ha esito negativo.
SOLUZIONE
Per risolvere il problema, determinare i valori duplicati e valori in conflitto con altri oggetti di Active Directory. A tale scopo, utilizzare uno dei metodi descritti di seguito.

Metodo 1: Utilizzare lo strumento di risoluzione dei problemi errore IdFix DirSync

Utilizzare lo strumento di risoluzione dei problemi errore DirSync IdFix per identificare gli attributi duplicati o non validi. Per risolvere gli attributi duplicati utilizzando lo strumento IdFix, vedere il seguente articolo della Microsoft Knowledge Base:
2857385 "Duplicati" viene visualizzato nella colonna errori per due o più oggetti dopo aver eseguito lo strumento IdFix
Per ulteriori informazioni sullo strumento IdFix, visitare il Strumento di risoluzione dei problemi errore IdFix DirSync.

Metodo 2: Eseguire il mapping di un utente locale esistente a un utente AD Azure

Per eseguire questa operazione, vedere il seguente articolo della Microsoft Knowledge Base:
2641663 Come utilizzare SMTP per stabilire una corrispondenza locale gli account utente per gli account utente di Office 365 per la sincronizzazione delle directory

Metodo 3: Determinare conflitti di attributo sono causati da oggetti che non sono stati creati in Active Directory Azure tramite la sincronizzazione delle directory

Per determinare i conflitti di attributo sono causati da oggetti utente che sono stati creati utilizzando gli strumenti di gestione di Office 365 (e che non sono stati creati in Active Directory Azure tramite la sincronizzazione delle directory), attenersi alla seguente procedura:
  1. Determinare gli attributi univoci del locale account utente di Active Directory. A tale scopo, in un computer con installati gli strumenti di supporto di Windows, attenersi alla seguente procedura:
    1. Fare clic su Start, scegliere Esegui, tipo Ldp.exe, quindi scegliere OK.
    2. Fare clic su connessione, fare clic su Connetti, digitare il nome del computer di un controller di dominio Active Directory e quindi fare clic su OK.
    3. Fare clic su connessionee scegliere Associa.
    4. Fare clic su Visualizza, fare clic su Visualizzazione struttura, selezionare il dominio di Active Directory nelBaseDN Riepilogo elenco e quindi fare clic su OK.
    5. Nel riquadro di spostamento, individuare e fare doppio clic sull'oggetto che non è la sincronizzazione in modo corretto. Nel riquadro dei dettagli sul lato destro della finestra sono elencati tutti gli attributi di oggetto. L'esempio seguente mostra gli attributi degli oggetti:

      Schermata dell'oggetto che la non sincronizzazione correttamente, che mostra tutti gli attributi oggetto
    6. Registrare i valori del userPrincipalName attributo e nei multivalore gli indirizzi SMTP proxyAddresses attributo. Questi valori è necessario in un secondo momento.
      Nome dell'attributoEsempioNote
      proxyAddressesproxyAddresses (3): X500: /o = Exchange/ou = gruppo amministrativo di Exchange (FYDIBOHF23SPDLT) / cn = Recipients/cn = 1ae75fca0d3a4303802cea9ca50fcd4f-7628376; SMTP:7628376@Service.contoso.com; SMTP:7628376@contoso.com;
      • Il numero viene visualizzato tra parentesi accanto all'etichetta dell'attributo indica il numero di valori di indirizzo proxy nell'attributo multivalore.
      • Ogni valore di indirizzo proxy distinte è indicato da un punto e virgola (;).
      • Il valore dell'indirizzo proxy SMTP primario è indicato da lettere maiuscole "SMTP:"
      userPrincipalName7628376@contoso.com
      Nota Ldp.exe è incluso in Windows Server 2008 e negli strumenti di supporto di Windows Server 2003. Gli strumenti di supporto di Windows Server 2003 sono inclusi nel supporto di installazione di Windows Server 2003. In alternativa, per ottenere lo strumento, visitare il seguente sito Web Microsoft:
  2. Connettersi a Office 365 utilizzando la Azure Active Directory Module per Windows PowerShell. A tale scopo, attenersi alla seguente procedura:
    1. Fare clic su Start, scegliere Tutti i programmi, fare clic su Active Directory di Windows Azuree quindi fare clic su Windows Azure Active Directory Module per Windows PowerShell.
    2. Digitare i seguenti comandi nell'ordine in cui vengono presentati e premere INVIO dopo ciascun comando:
      • $cred = get-credential
        Nota Quando richiesto, immettere le credenziali di amministratore di Office 365.
      • Connect-MSOLService –credential $cred
      Lasciare aperta la finestra di console. È necessario utilizzarlo nel passaggio successivo.
  3. Controllo per il duplicato userPrincipalName attributi in Office 365.

    Nella connessione alla console che è stato aperto nel passaggio 2, digitare i seguenti comandi nell'ordine in cui vengono presentati e premere INVIO dopo ciascun comando:
    • $userUPN = "<search UPN>"
      Nota In questo comando, il segnaposto"<search upn="">"</search> rappresenta il UserPrincipalName attributo annotato nel passaggio 1f.
    • get-MSOLUser –UserPrincipalName $userUPN | where {$_.LastDirSyncTime -eq $null}
    Lasciare aperta la finestra di console. Si utilizzerà nuovamente nel passaggio successivo.
  4. Controllo duplicato proxyAddresses attributi. Nella connessione alla console che è stato aperto nel passaggio 2, digitare i seguenti comandi nell'ordine in cui vengono presentati e premere INVIO dopo ciascun comando:
    • $SessionExO = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://outlook.office365.com/powershell-liveid/ -Credential $Cred -Authentication Basic - AllowRedirection
    • Import-PSSession $sessionExO -prefix:Cloud
  5. Per ogni voce di indirizzo proxy annotato nel passaggio 1f, digitare i seguenti comandi nell'ordine in cui vengono presentati e premere INVIO dopo ciascun comando:
    • $proxyAddress = "<search proxyAddress>"

      Nota In questo comando, il segnaposto"<search proxyaddress="">"</search> rappresenta il valore di un proxyAddresses attributo annotato nel passaggio 1f.
    • get-mailbox | where {[string] $str = ($_.EmailAddresses); $str.tolower().Contains($proxyAddress.tolower()) -eq $true} | foreach {get-MSOLUser -UserPrincipalName $_.MicrosoftOnlineServicesID | where {($_.LastDirSyncTime -eq $null)<AngularNoBind>}}</AngularNoBind>
Gli elementi che vengono restituiti dopo aver eseguito i comandi nel passaggio 3 e 4 rappresentano gli oggetti utente che non sono stati creati tramite la sincronizzazione delle directory e che dispongono di attributi che sono in conflitto con l'oggetto non è correttamente la sincronizzazione.

Dopo aver determinato i valori degli attributi in conflitto o non valido, è possibile risolvere il problema attenendosi alla procedura nel seguente articolo della Microsoft Knowledge Base:
2643629 Uno o piú oggetti non si sincronizzano utilizzando Azure Active Directory Sync
ULTERIORI INFORMAZIONI
I comandi di Windows PowerShell in questo articolo richiedono la Azure Active Directory Module per Windows PowerShell. Per ulteriori informazioni su Azure Active Directory Module per Windows PowerShell, visitare il seguente sito Web Microsoft:
Ulteriore assistenza? Vai al Community di Office 365 sito Web.

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 2647098 - Ultima revisione: 02/23/2015 21:55:00 - Revisione: 25.0

Microsoft Office 365, Microsoft Azure Active Directory, Office 365 Identity Management

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