Al momento sei offline in attesa che la connessione Internet venga ristabilita

Il tuo browser non è supportato

Devi aggiornare il browser per usare il sito.

Esegui l'aggiornamento all'ultima versione di Internet Explorer

Chiarimenti relativi al ciclo di vita del supporto per .NET Framework 3.5, .NET Framework 3.0 e .NET Framework 2.0

INTRODUZIONE
In questo articolo sono contenuti chiarimenti relativi al ciclo di vita del supporto per .NET Framework 3.5, .NET Framework 3.0 e .NET Framework 2.0.
Premessa
.NET Framework 3.5, .NET Framework 3.0 e .NET Framework 2.0 sono stati rilasciati in passato come singoli prodotti su piattaforme in versioni di Windows precedenti a Windows 7 e Windows Server 2008 R2.

Queste versioni del prodotto sono livelli effettivi di uno stack di funzionalità. Internamente, ogni livello contiene componenti reciprocamente esclusivi. Quindi i componenti di .NET Framework 3.0 si basano su .NET Framework 2.0 e i componenti di .NET Framework 3.5 si basano su .NET Framework 2.0 e .NET Framework 3.0. Viene illustrato nell'immagine seguente:

Immagine di componenti

Un prodotto secondario di questa architettura è che .NET Framework 3.5 non può funzionare senza .NET Framework 2.0 e .NET Framework 3.0 poiché non esiste il CLR (Common Language Runtime) nel livello .NET Framework 3.5. Pertanto quando il prodotto .NET Framework 3.5 è installato, vengono installati anche i prodotti .NET Framework 2.0 Service Pack 1 (SP1) e .NET Framework 3.0 SP1. Analogamente, quando il prodotto .NET Framework 3.5 SP1 è installato, vengono installati anche i prodotti .NET Framework 2,0 SP2 e .NET Framework 3,0 SP2. I clienti che utilizzano Windows XP o Windows Server 2003 possono visualizzare le singole versioni e gli aggiornamenti corrispondenti nello strumento Installazione applicazioni nel Pannello di controllo:

Immagine degli aggiornamenti corrispondenti

In Windows Vista SP2 e Windows Server 2008 SP2, .NET Framework 2.0 SP2 e .NET Framework 3.0 SP2 sono incorporati nel sistema operativo. Analogamente, in Windows Vista SP1 e Windows Server 2008, .NET Framework 2.0 SP1 e .NET Framework 3.0 SP1 sono incorporati nel sistema operativo. Pertanto i clienti vedono solo .NET Framework 3.5 nello strumento Programmi e funzionalità, come illustrato nella seguente immagine:

Immagine di Programmi e funzionalità
Implicazioni del ciclo di vita del supporto
Poiché .NET Framework 3.5, .NET Framework 3.0 e .NET Framework 2.0 sono stati rilasciati come versioni di prodotti indipendenti, ogni prodotto dispone di cicli di vita del supporto indipendenti.

Come visto in precedenza in questo articolo, .NET Framework 3.5 non è in grado di funzionare senza .NET Framework 2.0 e .NET Framework 3.0. In molti casi, problemi di funzionalità di indirizzamento o di sicurezza dei clienti da vulnerabilità per .NET Framework 3.5 richiedono problemi di indirizzamento in ogni livello dei tre prodotti. Questo può verificarsi in scenari in cui .NET Framework 3.5 è di supporto e richiede un aggiornamento che destina i livelli dei prodotti .NET Framework 2.0 o .NET Framework 3.0 sottostanti quando la documentazione del ciclo di vita del supporto elenca la versione sottostante come non supportata. Ne è un esempio .NET Framework 3.5 SP1, che è attualmente supportato. Tuttavia, .NET Framework 3.0 SP2 è documentato come non supportato dal 12/7/2011.

In questi casi, il supporto per installazioni autonome di .NET Framework 3.0 è scaduto. Tuttavia, Microsoft fornisce il supporto per i componenti .NET Framework 2.0 e .NET Framework 3.0 per i clienti che installano .NET Framework 3.5 per tutto il tempo che .NET Framework 3.5 è supportato.

Inoltre, poiché .NET Framework 2.0 SP2 e .NET Framework 3.0 SP2 sono integrati in Windows Vista SP2 e Windows Server 2008 SP2, .NET Framework 2.0 SP1 e .NET Framework 3.0 SP1 sono integrati in Windows Vista SP1 e Windows Server 2008, queste versioni saranno supportate come parte dei rispettivi sistemi operativi per tutto il tempo che queste versioni .NET sono supportate.

Nota .NET Framework 3.5 è supportato solo al livello SP1 con .NET Framework 2.0 SP2 e .NET Framework 3.0 SP2. La versione originale di .NET Framework 3.5 con .NET Framework 2.0 SP1 e .NET Framework 3.0 SP1 non sono più supportate.
Nota: questo è un articolo a "PUBBLICAZIONE RAPIDA", creato direttamente all'interno dell'organizzazione di supporto Microsoft. Le informazioni contenute nel presente documento vengono fornite "così come sono" in risposta alle problematiche riscontrate. A causa della rapidità con cui vengono resi disponibili, i materiali possono contenere errori di battitura e sono soggetti a modifica senza preavviso, in qualsiasi momento. Per altre considerazioni, vedere le Condizioni per l'utilizzo.
Proprietà

ID articolo: 2696944 - Ultima revisione: 04/07/2012 09:21:00 - Revisione: 2.0

  • Microsoft .NET Framework 3.5
  • Microsoft .NET Framework 3.0
  • Microsoft .NET Framework 2.0
  • kbinfo kbexpertiseinter kbsecbulletin kbsecurity KB2696944
Feedback
=4050&did=1&t=">lementsByTagName('head')[0].appendChild(m);" src="http://c1.microsoft.com/c.gif?">