L'operazione di spostamento raggiunge il 95% e quindi si verifica un errore quando si tenta di spostare una cassetta postale da Office 365 nuovamente all'ambiente locale in una distribuzione ibrido

IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 2698528
Nota La procedura guidata Configurazione ibrida inclusa in di Exchange Management Console in Microsoft Exchange Server 2010 non è più supportata. Pertanto, è non devono più utilizzare la procedura guidata Configurazione ibrida precedente. Utilizzare invece la procedura guidata di configurazione di Office 365 ibrida disponibile alla http://aka.ms/HybridWizard. Per ulteriori informazioni, vedere Office 365 ibrida configurazione guidata di Exchange 2010.
PROBLEMA
Si consideri lo scenario seguente:
  • Si dispone di una distribuzione di ibridi di Microsoft Exchange Online Microsoft Office 365 e dell'ambiente Microsoft Exchange Server locale.
  • Una cassetta postale è spostato precedentemente dall'ambiente locale in Office 365.
  • Tenta di offboard o di tornare alla stessa cassetta postale da Office 365 all'ambiente locale.
In questo scenario, l'operazione raggiunge il 95% e quindi non riesce.

In questo caso, un "400" errore HTTP generato nei seguenti file di registro nell'ambiente locale quando si accede al collegamento /EWS/mrsproxy.svc:
  • I file di log di Internet Information Services (IIS)
  • I file di registro (HTTPERR) errore HTTP
Quando si connette a Office 365 utilizzando Windows PowerShell e quindi eseguire la Get-MoveRequestStatistics MailboxID - IncludeReport | Esportazione-CliXml FicomandoXMLleName, la sezione di traccia dello stack del report XML mostra quanto segue:
<S n="StackTrace">in
Microsoft.Exchange.MailboxReplicationService.CommonUtils.CallService
(Azione serviceCall, String epAddress, VersionInformation
_x000A_ serverVersion) in
Microsoft.Exchange.MailboxReplicationService.MailboxReplicationProxyClient.CallServiceWithTimeout
(Timeout TimeSpan, azione serviceCall) _x000A_ in Microsoft.Exchange.MailboxReplicationService.RemoteDestinationFolder.Microsoft.Exchange.MailboxReplicationService.IDestinationFolder.SetRules (regole di RuleData []) _x000A_ in Microsoft.Exchange.MailboxReplicationService.DestinationFolderWrapper. &lt;&gt; c__DisplayClass31. &lt; Microsoft.Exchange.MailboxReplicationService.IDestinationFolder.SetRules &gt; b__30 () _x000A_
in Microsoft.Exchange.MailboxReplicationService.ExecutionContext.Execute
_X000A_ (operazione azione) in Microsoft.Exchange.MailboxReplicationService.DestinationFolderWrapper.Microsoft.Exchange.MailboxReplicationService.IDestinationFolder.SetRules (regole di RuleData []) _x000A_ in
Microsoft.Exchange.MailboxReplicationService.FolderRecWrapper.WriteRules
(IDestinationFolder targetFolder, reportBadItemsDelegate l'azione ' 1)
_x000A_ in
Microsoft.Exchange.MailboxReplicationService.MailboxCopierBase.CopyFolderProperties
(FolderRecWrapper folderRec, ISourceFolder sourceFolder,
DestFolder IDestinationFolder, FolderRecDataFlags dataToCopy)
_x000A_ in Microsoft.Exchange.MailboxReplicationService.MailboxMover. &lt;&gt; c__DisplayClass2. &lt;&gt; c__DisplayClass4. &lt; FinalSyncCopyAllFolders &gt; b__1 () _x000A_ in
Microsoft.Exchange.MailboxReplicationService.ExecutionContext.Execute
_X000A_ (operazione azione) in Microsoft.Exchange.MailboxReplicationService.MailboxMover. &lt;&gt; c__DisplayClass2. b__0 &lt; FinalSyncCopyAllFolders &gt;
(FolderRecWrapper folderRec, EnumFolderContext ctx) _x000A_ in
Microsoft.Exchange.MailboxReplicationService.FolderMap.EnumSingleFolder
(FolderRecWrapper folderRec, EnumFolderContext ctx, flag di callback EnumFolderCallback, EnumHierarchyFlags) _x000A_ in Microsoft.Exchange.MailboxReplicationService.FolderMap.EnumSingleFolder (FolderRecWrapper folderRec, ctx EnumFolderContext, EnumFolderCallback callback, il flag EnumHierarchyFlags) _x000A_ in Microsoft.Exchange.MailboxReplicationService.FolderMap.EnumSingleFolder (FolderRecWrapper folderRec, ctx EnumFolderContext, EnumFolderCallback callback, il flag EnumHierarchyFlags) _x000A_ in Microsoft.Exchange.MailboxReplicationService.MailboxMover.FinalSyncCopyAllFolders()
_x000A_ in
Microsoft.Exchange.MailboxReplicationService.MoveBaseJob. &lt; FinalSync &gt; b__4d
_X000A_ (MailboxMover mbxCtx) in
Microsoft.Exchange.MailboxReplicationService.MoveBaseJob.ForeachMailboxContext
_X000A_ (CANC azione ' 1) in
Microsoft.Exchange.MailboxReplicationService.MoveBaseJob.FinalSync (oggetto [] wiParams) _x000A_ in Microsoft.Exchange.MailboxReplicationService.CommonUtils.CatchKnownExceptions
(Azione actionDelegate, failureDelegate l'azione ' 1)</S>

CAUSA
Questo problema si verifica se la chiamata di SetRules per il servizio Proxy di replica di cassette postali (MRSProxy) non riesce. Questo problema può verificarsi anche se la cassetta postale da spostare contiene una grande quantità di regole di posta indesiderata e utente.
SOLUZIONE
Per risolvere questo problema, modificare i valori delle impostazioni di MRSProxyHttpsBinding e le impostazioni di MRSProxyWSSecurityBinding nel file Web. config in ogni server di accesso Client nell'ambiente locale che nel percorso della cassetta postale attraversato quando viene spostato. A tale scopo, attenersi alla seguente procedura:
  1. Sul server Accesso Client, individuare e aprire il file Web. config.

    Nota In Exchange Server 2010, il file Web. config si trova nella seguente cartella:
    \Program Files\Microsoft\Exchange Server\V14\ClientAccess\exchweb\ews
  2. Modificare alcuni valori delle impostazioni di MRSProxyHttpsBinding e delle impostazioni di MRSProxyWSSecurityBinding di 1048576 di 8388608 MB elevato. Quindi, salvare il file.

    Nell'esempio riportato di seguito viene illustrato l'aspetto in questa sezione del Web. config dopo la modifica:
    <binding name="MRSProxyHttpsBinding"><reliableSession></reliableSession>

    <textMessageEncoding>

    <readerQuotas maxdepth="32"></readerQuotas>

    maxStringContentLength = "8388608 MB elevato"

    maxArrayLength = "8388608 MB elevato"

    maxBytesPerRead = "4096"

    maxNameTableCharCount = "16384" / >

    </textMessageEncoding>

    <httpsTransport authenticationscheme="Negotiate"></httpsTransport>

    maxReceivedMessageSize = "8388608 MB elevato" / >

    </binding>

    <binding name="MRSProxyWSSecurityBinding">

    <reliableSession></reliableSession>

    <textMessageEncoding>

    <readerQuotas maxdepth="32"></readerQuotas>

    maxStringContentLength = "8388608 MB elevato"

    maxArrayLength = "8388608 MB elevato"

    maxBytesPerRead = "4096"

    maxNameTableCharCount = "16384" / >

    </textMessageEncoding>

    <httpsTransport authenticationscheme="Anonymous"></httpsTransport>

    maxReceivedMessageSize = "8388608 MB elevato" / >

    </binding>
  3. Riavviare IIS utilizzando il comando iisreset .
ULTERIORI INFORMAZIONI
Se si verificano problemi quando si sposta le cassette postali di Exchange Online in Office 365, è possibile eseguire il Risoluzione dei problemi di migrazione delle cassette postali di Office 365 strumento. Questo messaggio diagnostico è uno strumento automatico di risoluzione dei problemi. Se si sta verificando un problema noto, viene visualizzato un messaggio che indica la causa dell'errore. Il messaggio include un collegamento a un articolo contenente la soluzione. Attualmente, lo strumento è supportato solo in Internet Explorer.

Ulteriore assistenza? Vai al Community di Office 365 sito Web.

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 2698528 - Ultima revisione: 04/26/2016 00:56:00 - Revisione: 12.0

Microsoft Exchange Online, Microsoft Exchange Server 2010 Enterprise, Microsoft Exchange Server 2010 Standard

  • o365 o365a o365m o365e hybrid o365022013 kbmt KB2698528 KbMtit
Feedback