Al momento sei offline in attesa che la connessione Internet venga ristabilita

Works: Recupero di dati da un foglio di calcolo di Works danneggiato

Dichiarazione di non responsabilità per articoli della Microsoft Knowledge Base su prodotti non più supportati
Questo articolo è stato scritto sui prodotti per cui Microsoft non offre più supporto. L’articolo, quindi, viene offerto ‘così come è’ e non verrà più aggiornato.
Sommario
I file del Foglio di calcolo di Microsoft Works vengono salvati come file xlr. I file con questa estensione sono nel formato originale di Microsoft Excel. I file del Foglio di calcolo di Works danneggiati possono essere recuperati utilizzando Excel o uno dei metodi che sono risultati efficaci per il recupero dei dati da fogli di lavoro di Excel danneggiati. Tra tali metodi sono inclusi i seguenti:
  • Aprire il file in Microsoft Excel o in un altro programma di fogli di calcolo compatibile.
  • Aprire il file in Microsoft Word.
  • Aprire il file utilizzando Microsoft Excel 2000 Viewer 97.
Informazioni

Metodo 1: Aprire il file in Microsoft Excel (o in un altro foglio di calcolo compatibile)

Utilizzare questo metodo quando si desidera conservare le formule e la formattazione delle celle. Se è possibile aprire il file in Microsoft Excel, attenersi alla procedura seguente per recuperare i dati:
  1. Avviare Excel.
  2. Aprire il file xlr del Foglio di calcolo di Works danneggiato.
  3. Se il file si apre, correggere gli eventuali errori.
  4. Selezionare tutte le celle contenenti dati.
  5. Scegliere Copia dal menu Modifica.
  6. Avviare il Foglio di calcolo di Works e creare un nuovo foglio di lavoro.
  7. Selezionare la cella A1.
  8. Scegliere Incolla dal menu Modifica.
  9. Scegliere Salva dal menu File.
  10. Assegnare un nome al file, quindi scegliere Salva.
  11. Facoltativo: Passare a Excel e salvare il file.

Metodo 2: Aprire il file in Microsoft Word

Utilizzare questo metodo se non è possibile aprire il file xlr con Excel, se si sospetta che il problema possa essere causato da una formula danneggiata o se Excel non è disponibile.

Se è installato il convertitore per Excel, può essere possibile aprire il file del Foglio di calcolo di Works in Word. Se il file si apre in Word, non è possibile recuperare le formule delle celle, ma solo i risultati di tali formule attualmente presenti nelle celle. Verrà persa anche l'eventuale formattazione speciale.

SUGGERIMENTO: per determinare se il convertitore per Microsoft Excel è installato, scegliere Apri dal menu File di Word, quindi fare clic nella casella Tipo file. Se è elencato Foglio di lavoro Microsoft Excel, significa che il convertitore è installato.

Per aprire un foglio di calcolo di Works in Word, attenersi alla seguente procedura:
  1. Avviare Microsoft Word.
  2. Scegliere Apri dal menu File.
  3. Nella casella Tipo file selezionare Tutti i file.
  4. Nella casella Nome file selezionare il file del Foglio di calcolo di Works danneggiato.
  5. Scegliere Apri,

    Il file viene aperto come file di testo delimitato da virgole, ovvero come file in cui le celle sono separate da virgole.
  6. Scegliere Salva con nome dal menu File.
  7. Nella casella Tipo file selezionare Testo normale (*.txt).
  8. Assegnare un nome al file, quindi scegliere Salva.
  9. Avviare il Foglio di calcolo di Works.
  10. Scegliere Apri dal menu File.
  11. Nella casella Tipo file selezionare Testo (*.txt).
  12. Individuare il file desiderato, quindi scegliere Apri.

Metodo 3: Utilizzare Microsoft Excel Viewer

Utilizzare questo metodo se non è possibile aprire il file xlr con Excel, se si sospetta che il problema possa essere causato da una formula danneggiata o se Excel o Word non sono disponibili.

Se è installato Microsoft Excel Viewer, è possibile aprire il file del Foglio di calcolo di Works danneggiato in Excel Viewer, copiare le celle e incollarle in un nuovo foglio di calcolo. Non sarà tuttavia possibile recuperare le formule, ma solo i risultati delle formule attualmente contenuti nelle celle.

Per ulteriori informazioni su Excel Viewer, visitare il seguente sito Web:
works6 w_works works7
Proprietà

ID articolo: 271074 - Ultima revisione: 03/23/2007 17:50:17 - Revisione: 3.3

  • Microsoft Works 7.0 Standard Edition
  • Microsoft Works 6.0 Standard Edition
  • Microsoft Works Suite 2003 Standard Edition
  • Microsoft Works Suite 2001 Standard Edition
  • Microsoft Works Suite 2002 Standard Edition
  • kb3rdparty kbhowto kbinterop KB271074
Feedback