Sysprep ha esito negativo dopo aver rimosso o aggiornato le app di Microsoft Store che includono immagini Windows predefinite

Questo articolo illustra un problema che si verifica quando si rimuove o si aggiorna un'app di Microsoft Store sottoposta a provisioning usando Microsoft Store e quindi eseguendo sysprep nel computer.

Si applica a: Windows 10 - tutte le edizioni, Windows 11
Numero KB originale: 2769827

Introduzione

Sysprep è uno strumento per gli amministratori IT che vogliono preparare un'installazione di Windows per la duplicazione, il controllo e la distribuzione dei clienti. Le linee guida in questo articolo sono destinate all'uso da parte di agenti di supporto e professionisti IT. Se si è utenti privati che riscontrano problemi durante l'uso delle app di Microsoft Store, vedere Risolvere i problemi relativi alle app da Microsoft Store.

Diverse app di Microsoft Store sono integrate in immagini Windows. Queste app includono, tra le altre, le app Mail, Maps, Messaging, Bing, Travel e News. Queste app sono note come app di cui è stato effettuato il provisioning . Le app di cui è stato effettuato il provisioning vengono gestite nell'immagine e sono pianificate per l'installazione per ogni utente dell'immagine Windows al primo accesso. Oltre alle app predefinite, puoi caricare localmente le tue app line-of-business di Microsoft Store nell'immagine Windows senza doverle pubblicare in Microsoft Store. È possibile caricare i pacchetti tramite side-load Appx usando comandi di manutenzione online o offline disponibili in DISM.exe o tramite il modulo PowerShell di Gestione e manutenzione immagini distribuzione.

Sintomi

Si considerino gli scenari seguenti:

Scenario 1

  • Si sta creando un Windows 10 personalizzato o un computer di riferimento Windows 11 che si desidera sysprep e acquisire.
  • Si vuole rimuovere alcune delle app di Microsoft Store di cui è stato effettuato il provisioning (Appx pacchetti) da questo computer di riferimento.
  • dism -online /Remove-ProvisionedAppxPackage /PackageName:<packagename> Eseguire per effettuare il deprovisioning dei Appx pacchetti.

Quando si esegue l'operazione sysprep in questo scenario, l'operazione potrebbe non riuscire con l'errore seguente:

Strumento di preparazione del sistema 3.14
Errore irreversibile durante il tentativo di sysprep del computer

Scenario 2

  • Hai un'immagine Windows esistente e diverse app di Microsoft Store vengono caricate localmente nell'immagine.
  • Si vogliono rimuovere alcuni pacchetti caricati Appx lateralmente dall'immagine e personalizzarlo ulteriormente.
  • Si avvia nel computer di riferimento ed eseguire uno dei comandi di PowerShell seguenti per rimuovere il provisioning del Appx pacchetto:
    • Remove-AppxProvisionedPackage -PackageName <packagename>
    • Remove-ProvisionedAppxPackage -PackageName <packagename>

Quando si esegue l'operazione sysprep in questo scenario, l'operazione potrebbe non riuscire con l'errore seguente:

Strumento di preparazione del sistema 3.14
Errore irreversibile durante il tentativo di sysprep del computer

Scenario 3

  • Si sta creando un'immagine di riferimento Windows 10 o Windows 11.
  • Ci si connette a Microsoft Store e quindi si aggiornano le app predefinite di Microsoft Store usando Microsoft Store.

Quando si esegue l'operazione sysprep in questo scenario, l'operazione potrebbe non riuscire con l'errore seguente:

Strumento di preparazione del sistema 3.14 Errore irreversibile durante il tentativo di sysprep del computer

Inoltre, nel SetupErr.log è possibile notare le voci di errore seguenti:

<Data><e ora>, errore Pacchetto SYSPRP <PackageFullName> installato per un utente, ma non sottoposto a provisioning per tutti gli utenti. Questo pacchetto non funzionerà correttamente nell'immagine sysprep.
<Data><e ora>, errore SYSPRP Impossibile rimuovere le app per l'utente corrente: 0x80073cf2.
<Data><e ora>, errore SYSPRP Codice di uscita del thread RemoveAllApps 0x3cf2.
<Data><e ora>, errore [0x0f0082] SYSPRP ActionPlatform::LaunchModule: Errore durante l'esecuzione di 'SysprepGeneralize' da C:\Windows\System32\AppxSysprep.dll; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP ActionPlatform::ExecuteAction: Error in executing action; dwRet = 0x3cf2
<Date><Time>, Error SYSPRP ActionPlatform::ExecuteActionList: Error in execute actions; dwRet = 0x3cf2
<Data><e ora>, errore SYSPRP SysprepSession::Execute: Errore durante l'esecuzione di azioni da C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml; dwRet = 0x3cf2
<Data><e ora>, errore SYSPRP RunPlatformActions:Failed durante l'esecuzione delle azioni SysprepSession; dwRet = 0x3cf2
<Date><Time>, Error [0x0f0070] SYSPRP RunExternalDlls:Errore durante l'esecuzione delle DLL sysprep del Registro di sistema, arresto dell'esecuzione di sysprep. dwRet = 0x3cf2
<Date><Time>, Error [0x0f00a8] SYSPRP WinMain:Hit failure while processing sysprep generalize internal providers; hr = 0x80073cf2

Causa

Sysprep ha un provider aggiuntivo aggiunto in Windows per pulire Appx i pacchetti e generalizzare l'immagine. Il provider funziona solo se il Appx pacchetto è un pacchetto per utente o un pacchetto con provisioning per tutti gli utenti.

  • Il pacchetto per utente indica che il Appx pacchetto è installato per un determinato account utente e non è disponibile per altri utenti del computer.
  • Il pacchetto all-user indica che è stato effettuato il Appx provisioning nell'immagine in modo che tutti gli utenti che usano questa immagine possano accedere all'app.

Se un pacchetto per tutti gli utenti di cui è stato effettuato il provisioning nell'immagine è stato deprovisionizzato manualmente dall'immagine ma non è stato rimosso per un determinato utente, il provider riscontrerà un errore durante la pulizia del pacchetto durante sysprep. Il provider avrà esito negativo anche se un pacchetto di tutti gli utenti di cui è stato effettuato il provisioning nell'immagine è stato aggiornato da uno degli utenti nel computer di riferimento.

Risoluzione

Per risolvere questo problema, rimuovere il pacchetto per l'utente che esegue sysprep e rimuovere anche il provisioning. A tale scopo, attenersi alla seguente procedura.

Nota

Per impedire a Microsoft Store di aggiornare le app, scollegare la connessione Internet o disabilitare la Aggiornamenti automatica in modalità di controllo prima di creare l'immagine.

  1. Eseguire i cmdlet di PowerShell seguenti:

    Import-Module Appx
    Import-Module Dism
    Get-AppxPackage -AllUsers | Where PublisherId -eq 8wekyb3d8bbwe | Format-List -Property PackageFullName,PackageUserInformation
    

Nota

  • Nell'output di questo ultimo cmdlet controllare gli utenti per i quali il pacchetto viene visualizzato come Installato. Eliminare questi account utente dal computer di riferimento o accedere al computer usando questi account utente. Eseguire quindi il cmdlet nel passaggio 2 per rimuovere il Appx pacchetto.
  • Questo comando elenca tutti i pacchetti pubblicati da Microsoft e installati da qualsiasi utente del computer di riferimento. Poiché il computer deve essere sysprepped, si presuppone che questi profili utente non richiedano più il pacchetto.
  • Se sono state eseguite manualmente il provisioning di app appartenenti ad altri server di pubblicazione, eseguire il comando seguente per elencarle:

Get-AppxPackage -AllUsers | Format-List -Property PackageFullName,PackageUserInformation

  1. Rimuovere Appx il pacchetto eseguendo il cmdlet seguente:

    Remove-AppxPackage -Package <packagefullname>
    
  2. Rimuovere il provisioning eseguendo il cmdlet seguente:

    Remove-AppxProvisionedPackage -Online -PackageName <packagefullname>
    

Se si tenta di eseguire il ripristino da un problema di aggiornamento, è possibile effettuare nuovamente il provisioning dell'app dopo aver seguito questi passaggi.

Nota

Il problema non si verifica se si sta servendo un'immagine offline. In questo scenario, il provisioning viene automaticamente cancellato per tutti gli utenti. Questo include l'utente che esegue il comando.

Ulteriori informazioni

Per altre informazioni su come aggiungere e rimuovere app, vedere:

Raccolta dei dati

Se è necessaria l'assistenza del supporto tecnico Microsoft, si consiglia di raccogliere le informazioni seguendo i passaggi indicati in Raccogliere informazioni utilizzando TSS per le questioni relative alla distribuzione.