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Le richieste di interruzione oplock vengono ignorate da un client basato su Windows Server 2008 R2 o Windows 7

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Sintomi
Si consideri lo scenario seguente:
  • È possibile utilizzare un'applicazione per aprire i file eseguibili in rete da un computer client che esegue Windows 7 o Windows Server 2008 R2.
  • Questa applicazione consente di aprire anche altri file che consentono il blocco opportunistico (oplock) attraverso la rete.
  • Un altro processo tenta di accedere a un file condiviso che l'applicazione è già aperto in rete.
  • Il server richiede che il computer client interrompere l'oplock.
In questo scenario, il computer client non separa l'oplock. Di conseguenza, il file condiviso rimane aperto sul server e altri client non è possibile utilizzare il file.
Cause
Questo problema si verifica perché il gestore della memoria del computer client contiene oggetti eseguibili e non viene chiuso. Tuttavia, il server considera gli oggetti eseguibili da chiudere e riutilizza l'ID di file per un altro file. Ciò causa un conflitto di ID di file. Pertanto, quando viene emessa la richiesta di interruzione oplock, il computer client elabora del precedente oggetto eseguibile anziché il nuovo file.
Risoluzione

Informazioni sull'hotfix

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano il problema descritto in questo articolo. Su questo hotfix potranno essere eseguiti ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il prossimo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, esiste una sezione "Disponibilità del Download dell'Hotfix" nella parte superiore di questo articolo della Knowledge Base. Se questa sezione non viene visualizzato, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'hotfix.

Nota. Se si verificano ulteriori problemi o se occorrono attività di risoluzione, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo di numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft: Nota. Il modulo "Disponibilità del Download dell'Hotfix" Visualizza le lingue per cui è disponibile l'hotfix. Se non è disponibile la lingua, è perché non è disponibile alcun hotfix per tale lingua.

Prerequisiti

Per applicare questo hotfix, è necessario eseguire Windows 7 Service Pack 1 (SP1) o Windows Server 2008 R2 SP1.

Per ulteriori informazioni su come ottenere un Service Pack di Windows 7 o Windows Server 2008 R2, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
976932 Informazioni sul Service Pack 1 per Windows 7 e Windows Server 2008 R2

Informazioni sul Registro di sistema

Per applicare questo hotfix, è necessario apportare modifiche al Registro di sistema.

Richiesta di riavvio

Dopo avere applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.

Informazioni sui file

La versione globale di questo hotfix consente di installare file con gli attributi elencati nelle tabelle seguenti. Le date e le ore dei file sono elencate nell'ora UTC (Coordinated Universal Time). Le date e ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale (DST). Inoltre, le date e gli orari possono cambiare quando si eseguono determinate operazioni sui file.
Note informative relative al file Windows 7 e Windows Server 2008 R2
Importante. Aggiornamenti rapidi di Windows 7 e aggiornamenti rapidi di Windows Server 2008 R2 sono inclusi nel pacchetto stesso. Tuttavia, gli hotfix nella pagina Richiesta hotfix sono elencati in entrambi i sistemi operativi. Per richiedere il pacchetto di hotfix che si applica a uno o entrambi i sistemi operativi, selezionare l'hotfix elencato nella sezione "Windows 7 e Windows Server 2008 R2" della pagina. Fare riferimento sempre alla sezione "Si applica a" negli articoli per determinare il sistema operativo effettivo al quale si applica ogni hotfix.
  • I file che si applicano a un prodotto specifico, un'attività cardine (RTM, SPn), e il ramo del servizio (LDR, GDR) può essere identificato esaminando i numeri di versione del file come indicato nella tabella seguente:
    VersioneProdottoAttività cardineRamo del servizio
    6.1.760 1.22xxxWindows 7 e Windows Server 2008 R2SP1LDR
  • I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono elencati separatamente Nella sezione "ulteriori informazioni sui file per Windows 7 e Windows Server 2008 R2". I file MUM e MANIFEST e i file di catalogo (cat) di sicurezza associati sono fondamentali per mantenere lo stato del componente aggiornato. I file di catalogo di sicurezza, per i quali non sono elencati gli attributi, sono firmati mediante firma digitale Microsoft.
Per tutte le versioni x86 supportate di Windows 7
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Rdbss. sys6.1.7601.22276246,78408-Mar-201310:35x86
Per tutte le versioni x64 supportate di Windows 7 e Windows Server 2008 R2
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Rdbss. sys6.1.7601.22276315.39208-Mar-201303:05x64
Per tutte le versioni basate su IA-64 supportate di Windows Server 2008 R2
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Rdbss. sys6.1.7601.22276736,25608-Mar-201302:31IA-64
Status
Microsoft ha confermato che questo è un problema nei prodotti Microsoft elencati nella sezione "Si applica a".
Informazioni
Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Ulteriori informazioni sui file

Ulteriori informazioni sui file per Windows 7 e Windows Server 2008 R2

File aggiuntivi per tutte le versioni x86 supportate di Windows 7
Nome del fileX86_d95041acda5dc58fe305467f9bee6a03_31bf3856ad364e35_6.1.7601.22276_none_07c74556a70c889f.manifest
Versione del fileNon applicabile
Dimensione del file693
Data (UTC)11-Mar-2013
Ora (UTC)08:30
PiattaformaNon applicabile
Nome del fileX86_microsoft-windows-rdbss_31bf3856ad364e35_6.1.7601.22276_none_5c26e12ed8f827c2.manifest
Versione del fileNon applicabile
Dimensione del file21,803
Data (UTC)08-Mar-2013
Ora (UTC)13:28
PiattaformaNon applicabile
File aggiuntivi per tutte supportate versioni basate su x64 di Windows 7 e Windows Server 2008 R2
Nome del fileAmd64_d50863e477941c16f977bf1c89696966_31bf3856ad364e35_6.1.7601.22276_none_38c1c4948e57a278.manifest
Versione del fileNon applicabile
Dimensione del file697
Data (UTC)11-Mar-2013
Ora (UTC)08:30
PiattaformaNon applicabile
Nome del fileAmd64_microsoft-windows-rdbss_31bf3856ad364e35_6.1.7601.22276_none_b8457cb2915598f8.manifest
Versione del fileNon applicabile
Dimensione del file21,809
Data (UTC)08-Mar-2013
Ora (UTC)13:16
PiattaformaNon applicabile
File aggiuntivi per tutte le versioni basate su IA-64 supportate di Windows Server 2008 R2
Nome del fileIa64_f14c1128638c6525958b8bdd8aa6e0a2_31bf3856ad364e35_6.1.7601.22276_none_7bb8fda7dee22245.manifest
Versione del fileNon applicabile
Dimensione del file695
Data (UTC)11-Mar-2013
Ora (UTC)08:30
PiattaformaNon applicabile
Nome del fileIa64_microsoft-windows-rdbss_31bf3856ad364e35_6.1.7601.22276_none_5c288524d8f630be.manifest
Versione del fileNon applicabile
Dimensione del file21,806
Data (UTC)08-Mar-2013
Ora (UTC)13:19
PiattaformaNon applicabile

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Proprietà

ID articolo: 2824408 - Ultima revisione: 04/09/2013 22:12:00 - Revisione: 1.0

Windows 7 Service Pack 1, Windows Server 2008 R2 Service Pack 1

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