Al momento sei offline in attesa che la connessione Internet venga ristabilita

Durante l'importazione, l'esportazione o il collegamento di file in Access 2002 o in Access 2003 viene visualizzato il messaggio di errore "Impossibile trovare ISAM installabile" o alcuni tipi di file risultano mancanti

Il supporto per Office 2003 è terminato

Il supporto Microsoft per Office 2003 è terminato l Ulteriori informazioni su come continuare a essere protetti.

Questo articolo è stato precedentemente pubblicato con il codice di riferimento I283881
Importante In questo articolo sono contenute informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, eseguire una copia di backup e assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986 Descrizione del Registro di sistema di Microsoft Windows
Difficoltà media: sono richieste conoscenze di base di creazione di macro, gestione di codice e di interoperabilità.

Le informazioni contenute in questo articolo si applicano ai database di Microsoft Access (mdb) e ai progetti di Microsoft Access (adp).

Per la versione di questo articolo relativa a Microsoft Access 2000, vedere 209805.
Per la versione di questo articolo relativa a Microsoft Access 97, vedere 90111.
Sintomi
Quando si importano, esportano o collegano i file in Access, alcuni tipi di file risultano mancanti nella casella di riepilogo Tipo file della finestra di dialogo Importa, Esporta o Collega. Se si tenta di importare, esportare o collegare un file utilizzando un driver ISAM (Indexed Sequential Access Method), è possibile che venga visualizzato un messaggio di errore se il driver ISAM non è disponibile.
Cause
I driver ISAM vengono utilizzati da Access per aggiornare i formati di file diversi dai propri. Se il Registro di sistema di Windows non contiene un percorso valido per il driver ISAM o se il driver non esiste, è possibile che venga visualizzato uno dei seguenti messaggi di errore:

Messaggio di errore 1
Impossibile trovare ISAM installabile
Messaggio di errore 2
Impossibile accedere alle informazioni nel file '<nomepercorso>'. Verificare che il file esista e che abbia il formato corretto.
Risoluzione
Avviso L'errato utilizzo dell'editor del Registro di sistema può causare gravi problemi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la risoluzione di problemi causati dall'errato utilizzo dell'editor del Registro di sistema. I rischi correlati all'utilizzo dell'editor del Registro di sistema sono di esclusiva responsabilità dell'utente.

Per risolvere il problema, è necessario correggere l'eventuale percorso errato nel Registro di sistema e installare o sostituire il file che genera l'errore.

Se viene visualizzato il primo messaggio di errore, il nome del file è direttamente correlato all'operazione tentata.

Se viene visualizzato il secondo messaggio di errore, il nome del file è riportato nel testo del messaggio.
  1. Individuare il file appropriato nella tabella seguente.
    Nome fileISAM di importazione/esportazione per:Registro di sistema di Windows
    Msexcl40.dllMicrosoft ExcelHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Excel
    Msexch40.dllMicrosoft ExchangeHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Exchange
    Msrd2x40.dllMicrosoft Jet 2.xHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Jet 2.x
    Msrd3x40.dllMicrosoft Jet 3.xHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Jet 3.x
    Msltus40.dllLotus 1-2-3HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Lotus
    Mspbde40.dllImprise ParadoxHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Paradox
    Mstext40.dllTextHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Text
    Msxbde40.dlldBaseHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\4.0\Engines\Xbase
  2. Per cercare il file, utilizzare Esplora risorse.
  3. Se il file viene trovato, prendere nota del percorso. In caso contrario, procedere con il passaggio 9.
  4. Avviare l'editor del Registro di sistema.
  5. Individuare la sottochiave del Registro di sistema indicata nella tabella e verificare la correttezza del percorso.
  6. Se errato, correggere il nome del percorso. Se corretto, procedere come illustrato di seguito.
  7. Chiudere l'editor del Registro di sistema. Se il nome del percorso è stato modificato, ripetere la procedura che ha generato l'errore.
  8. Se l'errore persiste o se il nome del percorso era corretto nel passaggio 6, rinominare il file.
  9. Avviare lo strumento Installazione applicazioni.
  10. Fare clic sul pulsante Cambia accanto alla voce del programma di installazione di Office in Installazione applicazioni per avviarlo, quindi selezionare l'opzione per ripristinare o reinstallare Office.
Riferimenti
Per ulteriori informazioni sulla modifica del Registro di sistema, digitare Registro di sistema nell'Assistente di Office, quindi scegliere Cerca per visualizzare gli argomenti restituiti.
prb 1 2 3 123 can't can t cannot not could couldn find installable ISAM ACC2002 ACC2003 Files of type
Proprietà

ID articolo: 283881 - Ultima revisione: 10/18/2005 17:01:30 - Revisione: 5.2

  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
  • kbupdateissue kberrmsg kbprb KB283881
Feedback