Al momento sei offline in attesa che la connessione Internet venga ristabilita

PowerPoint non può caricare un componente aggiuntivo quando ridurre la macro protezione

Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell’utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell’utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.

285470
Sintomi
Quando si ridurre il livello di protezione macro in Microsoft PowerPoint e quindi aprire il file di un componente aggiuntivo per PowerPoint (* ppa), non è possibile applicare il nuovo livello di protezione macro, ed è il file del componente aggiuntivo non può essere eseguito come previsto. Il componente aggiuntivo è elencato come un componente aggiuntivo disponibile nella finestra di dialogo Aggiuntivi , ma la casella di controllo non è selezionata e riceverai un messaggio di errore analogo al seguente quando si tenta di selezionare la casella di controllo:
PowerPoint Impossibile caricare il componente aggiuntivo del file name.
Cause
È possibile che questo problema si verifichi se sono vere tutte le seguenti condizioni:
  1. Si tenta di aprire un file del componente aggiuntivo di PowerPoint utilizzando il comando Apri dal menu file , in quando il livello di protezione macro è impostato su alta .
  2. È ridurre l'impostazione di protezione a livello di macro.
  3. Si apre il PowerPoint stesso componente aggiuntivo file scegliendo Apri dal menu file .
Quando si tenta di aprire un file aggiuntivo e il componente aggiuntivo non viene caricato a causa di protezione macro, PowerPoint memorizza temporaneamente (cache) le informazioni di errore di caricamento PowerPoint questo componente aggiuntivo Impossibile caricare il componente - in dopo impostare la protezione macro un livello fino a quando non si risolve le informazioni memorizzate nella cache.
Workaround
Per risolvere questo problema, eliminare le informazioni memorizzate nella cache e quindi caricare il componente aggiuntivo seguendo uno dei seguenti metodi dopo aver modificato l'impostazione di protezione a livello di macro.

Metodo 1: Chiudere e riavviare PowerPoint

  1. Uscire dall'applicazione.
  2. Riavviare PowerPoint.
  3. Aprire il file aggiuntivo.
  4. Fare clic sui "AGREE I" per caricare il componente aggiuntivo.

Metodo 2: Installazione e aggiungere il componente aggiuntivo

Per rimuovere e aggiungere il componente aggiuntivo in PowerPoint 2002, attenersi alla seguente procedura:
  1. Dal menu Strumenti , scegliere componenti Aggiuntivi .
  2. Nell'elenco Aggiuntivi disponibili , fare clic sul componente aggiuntivo e quindi scegliere Rimuovi .
  3. scegliere il pulsante Aggiungi , selezionare il componente aggiuntivo, fare clic su OK , infine "AGREE I" per caricare il componente aggiuntivo e quindi fare clic su Chiudi .
Per rimuovere il componente aggiuntivo in PowerPoint 2007, attenersi alla seguente procedura:
  1. Fare clic sul Pulsante Microsoft Office , fare clic su Opzioni di PowerPoint e quindi scegliere componenti Aggiuntivi .
  2. Nell'elenco Gestione , selezionare componente aggiuntivo componenti aggiuntivi di PowerPoint e quindi fare clic su Vai .
  3. Nell'elenco Aggiuntivi disponibili , selezionare il componente aggiuntivo che si desidera rimuovere, fare clic su Rimuovi e quindi fare clic su Chiudi .
Componente aggiuntivo in PowerPoint 2007, attenersi alla seguente procedura:
  1. Fare clic sul Pulsante Microsoft Office , fare clic su Opzioni di PowerPoint e quindi scegliere componenti Aggiuntivi .
  2. Nell'elenco Gestione , fare clic su componente aggiuntivo componenti aggiuntivi di PowerPoint e quindi fare clic su Vai .
  3. Nella finestra di dialogo Aggiuntivi , fare clic su Aggiungi .
  4. Nella finestra di dialogo Aggiungi nuovo componente aggiuntivo di PowerPoint , cercare il componente aggiuntivo che si desidera aggiungere e quindi fare clic su OK .
  5. Viene visualizzato un avviso di protezione. Se si è certi che il componente aggiuntivo proviene da una fonte attendibile, fare clic su Attiva macro e quindi fare clic su Chiudi .
Status
Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".
Informazioni

Procedura per riprodurre il problema

PowerPoint 2007

  1. Avviare PowerPoint 2007.
  2. Nella scheda Developer , fare clic su Protezione Macro nel gruppo codice .
    Nota Per impostazione predefinita, la scheda sviluppo non potrebbe essere visualizzato. Per visualizzare la scheda sviluppo , fare clic sul Pulsante Microsoft Office , fare clic su Opzioni di PowerPoint , selezionare Mostra scheda Sviluppo sulla barra multifunzione in Opzioni principali per l'utilizzo di PowerPoint , quindi fare clic su OK .
  3. Nella pagina Centro , in Impostazioni Macro , selezionare Disattiva tutte le macro con notifica e quindi fare clic su OK .
  4. Scegliere Apri dal menu di Office .
  5. Nella casella a discesa Tipo file fare clic sulla freccia, selezionare PowerPoint Add-Ins(*.ppam;*.ppa) , selezionare il componente aggiuntivo e quindi fare clic su Apri .

    Nota Il componente aggiuntivo non viene caricata come previsto.
  6. Nella scheda Developer , fare clic su Protezione Macro nel gruppo codice .
  7. Nella pagina Centro , selezionare Attiva tutte le macro (scelta non consigliata; venire eseguito codice pericoloso) in Impostazioni Macro e quindi fare clic su OK .
  8. Scegliere Apri dal menu di Office .
  9. Nella casella a discesa Tipo file fare clic sulla freccia, selezionare PowerPoint Add-Ins(*.ppam;*.ppa) , selezionare il componente aggiuntivo e quindi fare clic su Apri .

    Nota Non viene chiesto di attivare o disattivare la macro. Inoltre, il componente aggiuntivo ancora non carica.

PowerPoint 2002

  1. Avviare PowerPoint.
  2. Scegliere macro dal menu Strumenti , quindi protezione .
  3. Nella scheda Livello di protezione , fare clic su alta .
  4. Nel menu file , fare clic su Apri .
  5. Nella casella Tipo file fare clic sulla freccia, selezionare Aggiuntivi di PowerPoint , selezionare il componente aggiuntivo e quindi fare clic su Apri .

    Nota : il componente aggiuntivo non viene caricata come previsto.
  6. Scegliere macro dal menu Strumenti , quindi protezione .
  7. Nella scheda Livello di protezione , fare clic su medio .
  8. Nel menu file , fare clic su Apri .
  9. Nella casella Tipo file fare clic sulla freccia, selezionare Aggiuntivi di PowerPoint , selezionare il componente aggiuntivo e quindi fare clic su Apri .

    Nota : non è richiesto per attivare o disattivare la macro e il problema persiste.
Macro protezione componente aggiuntivo di PowerPoint caricare PPT2007

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 285470 - Ultima revisione: 01/29/2007 06:25:45 - Revisione: 3.2

  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Office PowerPoint 2007
  • kbmt kbbug kberrmsg kbpending KB285470 KbMtit
Feedback