Al momento sei offline in attesa che la connessione Internet venga ristabilita

Esecuzione del codice di esempio per i programmi di Office XP contenuto negli articoli della Knowledge Base

Questo articolo è stato precedentemente pubblicato con il codice di riferimento I290140
Questo articolo è stato archiviato. L’articolo, quindi, viene offerto “così come è” e non verrà più aggiornato.
Per la versione di questo articolo relativa a Microsoft Office 2000, vedere 212536.
Per la versione di questo articolo relativa a Microsoft Office 97, vedere 173707.
Per la versione di questo articolo relativa a Microsoft Office 2001 per Mac, vedere 274703.
Per la versione di questo articolo relativa a Microsoft Office 98 per Macintosh, vedere 181058.
Sommario
Nella Microsoft Knowledge Base sono disponibili numerosi articoli contenenti codice di esempio per le macro di Visual Basic, Applications Edition. Molte di queste macro illustrano i concetti di base della programmazione in Visual Basic per le diverse applicazioni di Office XP. In questo articolo vengono fornite istruzioni su come utilizzare il codice di esempio per creare una nuova macro e come eseguire tale macro.
Informazioni
Microsoft fornisce esempi di programmazione a scopo puramente illustrativo, senza alcuna garanzia di qualsiasi tipo, sia espressa che implicita, ivi incluse, senza limitazioni, le garanzie implicite di commerciabilità o idoneità per uno scopo particolare. In questo articolo si presume che l'utente conosca il linguaggio di programmazione in questione e gli strumenti utilizzati per creare ed eseguire il debug delle procedure. Gli esperti Microsoft sono autorizzati a fornire spiegazioni in merito alla funzionalità di una particolare procedura, ma in nessun caso a modificare questi esempi per fornire funzionalità aggiuntive o a creare procedure atte a soddisfare specifiche esigenze. Per utilizzare il codice di esempio da un articolo della Knowledge Base, è necessario aggiungere una nuova macro di Visual Basic o selezionarne una esistente. Dopodiché sarà possibile copiare e incollare o digitare il codice di esempio in questa macro utilizzando uno dei seguenti metodi.

Per creare una nuova macro

  1. Aprire o creare un modello nel programma di Office utilizzato.
  2. Scegliere Macro dal menu Strumenti, quindi fare clic su Macro.
  3. Nella casella di riepilogo Macro in selezionare il modello di Word o il documento nel quale si desidera salvare la macro.
  4. Nella casella Nome macro digitare un nome per la macro.
  5. Fare clic su Crea per aprire Visual Basic Editor.
  6. Effettuare una delle seguenti operazioni:
    • Digitare il codice della macro tra la riga Sub Macroname() e la riga End Sub.
      Sub macroname()    Type your macro code hereEnd Sub
      Oppure
    • Copiare e incollare il codice di esempio nella macro procedendo come segue:
      Sub macroname() End Sub						
      1. Passare al programma utilizzato per visualizzare l'articolo della Microsoft Knowledge Base, ad esempio Microsoft Internet Explorer.
      2. Per selezionare il codice di esempio, tenere premuto CTRL e fare clic una volta sul codice.
      3. Scegliere Copia dal menu Modifica.
      4. Passare a Visual Basic Editor.
      5. Nella finestra di Visual Basic Editor selezionare il codice esistente da Sub Macroname() a End Sub.
      6. Scegliere Incolla dal menu Modifica.

        NOTA: quando si incolla il testo, il codice esistente verrà sostituito dal codice copiato dall'articolo della Knowledge Base.
  7. Dopo avere digitato o incollato il codice per la macro, scegliere Chiudi e torna a Microsoft programma dal menu File dove programma è il programma di Microsoft Office XP utilizzato.


NOTA: utilizzare TAB per far rientrare il testo. Le righe che iniziano con un apostrofo (') sono commenti e non sono necessarie per l'esecuzione della macro. Tuttavia potrebbe essere utile inserirle nella macro per comprenderne più facilmente il significato.

Per aggiungere il codice di esempio a un modulo

Per aggiungere il codice a un modulo, è necessario disporre di un modulo esistente o crearne uno nuovo. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Aprire o creare un modello nel programma di Office utilizzato.
  2. Scegliere Macro dal menu Strumenti, quindi fare clic su Visual Basic Editor.
  3. Nella finestra del progetto di Visual Basic Editor, che in base all'impostazione predefinita si trova nell'angolo superiore sinistro, fare clic sull'icona del progetto con lo stesso nome del modello o del documento. Se il modello o il documento non è ancora stato salvato, il nome del progetto sarà simile a Project(Documento1) o TemplateProject(Modello1).

    NOTA PER GLI UTENTI DI WORD: per memorizzare la macro nel modello generale predefinito Normal.dot, fare doppio clic sul progetto Normal.
  4. Se il progetto selezionato non contiene una cartella denominata Moduli, scegliere Modulo dal menu Inserisci.
  5. Fare clic in un punto qualsiasi della finestra del codice del modulo che si desidera creare. La finestra del codice si trova di solito nell'angolo superiore destro della finestra di Visual Basic Editor.
  6. Digitare o incollare il codice di esempio esattamente come è visualizzato nell'articolo della Knowledge Base, incluse le righe Sub Macroname() e End Sub.

    NOTA: per ulteriori informazioni su come digitare o incollare codice delle macro, vedere la sezione "Per creare una nuova macro" in questo articolo.
Dopo avere digitato o incollato il codice per la macro, scegliere Chiudi e torna a Microsoft programma dal menu File

dove programma è il programma di Microsoft Office XP utilizzato.

Per eseguire la macro

  1. Scegliere Macro dal menu Strumenti, quindi fare clic su Macro.
  2. Selezionare il nome della macro nell'elenco Nome macro, quindi fare clic su Esegui.
Riferimenti
La Guida di ognuno dei programmi di Office contiene vari argomenti sull'utilizzo delle macro. La Guida di Visual Basic fornisce informazioni esaustive sulla scrittura di codice personalizzato.
OfficeKBHowTo vba vbe visual basic inf OFFXP XP OFF
Proprietà

ID articolo: 290140 - Ultima revisione: 12/06/2015 00:45:06 - Revisione: 3.3

  • Microsoft Excel 2002 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • kbnosurvey kbarchive kbfaq kbhowto kbmacro kbprogramming KB290140
Feedback