Come determinare dove pubblicare un modulo personalizzato di Outlook

Il supporto per Office 2003 è terminato

Il supporto Microsoft per Office 2003 è terminato l'8 aprile 2014. Questa modifica ha interessato gli aggiornamenti software e le opzioni di sicurezza. Ulteriori informazioni su come continuare a essere protetti.

IMPORTANTE: il presente articolo è stato tradotto tramite un software di traduzione automatica di Microsoft ed eventualmente revisionato dalla community Microsoft tramite la tecnologia CTF (Community Translation Framework) o da un traduttore professionista. Microsoft offre articoli tradotti manualmente e altri tradotti automaticamente e rivisti dalla community con l’obiettivo di consentire all'utente di accedere a tutti gli articoli della Knowledge Base nella propria lingua. Tuttavia, un articolo tradotto automaticamente, anche se rivisto dalla community, non sempre è perfetto. Potrebbe contenere errori di vocabolario, di sintassi o di grammatica. Microsoft declina ogni responsabilità per imprecisioni, errori o danni causati da una traduzione sbagliata o dal relativo utilizzo da parte dei clienti. Microsoft aggiorna frequentemente il software e gli strumenti di traduzione automatica per continuare a migliorare la qualità della traduzione.

Clicca qui per visualizzare la versione originale in inglese dell’articolo: 290802
Per una versione di Microsoft Outlook 97 di questo articolo, vedere 264117.
Per una versione di Microsoft Outlook 98 di questo articolo, vedere 264118.
Per una versione di Microsoft Outlook 2000 di questo articolo, vedere 257796.
Sommario
In questo articolo vengono descritti alcuni degli aspetti da tenere in considerazione se si sta tentando di decidere dove pubblicare un modulo personalizzato di Outlook.

Informazioni
In Outlook, moduli personalizzati vengono in genere pubblicati in una libreria in modo che solo una copia di un modulo viene memorizzata nel computer in uso. I singoli elementi contengono un campo classe messaggio che indica il modulo da utilizzare per visualizzare i dati contenuti nell'elemento. Quando si pubblicano moduli personalizzati in una libreria, computer basati su Microsoft Exchange Server e Outlook utilizzare notevolmente meno larghezza di banda e risorse perché il modulo stesso non deve necessariamente essere memorizzati all'interno di ogni singolo articolo.

Soluzioni di moduli di Outlook possono variare notevolmente, soprattutto perché Outlook dispone di un numero di diversi tipi di moduli standard. Spesso è difficile determinare la posizione migliore per pubblicare un modulo e vi sono molti i fattori da prendere in considerazione quando si prende la decisione.

Dove è possibile pubblicare i moduli

Moduli possono essere pubblicati in tre posizioni. Riportate nella tabella riportata di seguito.

PosizioneDescrizione
Una cartella (o Libreria moduli della cartella)Per le soluzioni di form basata su più cartelle, è possibile pubblicare il modulo nella cartella in modo che sia disponibile quando si utilizza la cartella. Se si pubblica il modulo in una cartella pubblica, il modulo è disponibile per tutti gli utenti possono accedere alla cartella. Se si pubblica il modulo in una delle cartelle personali, è disponibile solo per l'utente quando si utilizza tale cartella. Moduli di contatto, Post, attività e giornale di registrazione sono esempi di tipi di moduli che sono in genere associati a una cartella. Un vantaggio per la pubblicazione di un modulo in una cartella è che il modulo è disponibile nel menu Azioni quando trovano nella cartella.
Libreria moduli organizzazioneSe si desidera renderlo disponibile a tutti gli utenti nell'organizzazione un modulo per ferie, pubblicare il modulo alla raccolta. Questa libreria viene spesso utilizzata per i moduli dei messaggi di posta elettronica perché in genere non sono basati su una cartella specifica. Quando si desidera utilizzare lo stesso modulo personalizzato in più di una cartella, è possibile pubblicare un modulo nella libreria moduli organizzazione. Quando si esegue questa operazione, è possibile gestire un solo modulo pubblicato. Moduli pubblicati in questa libreria sono accessibili a tutti gli utenti dell'organizzazione come utenti che dispongono delle autorizzazioni per la libreria dall'amministratore. La libreria è memorizzata nel computer che esegue Microsoft Exchange Server. L'amministratore deve assegnare le autorizzazioni per la pubblicazione nella libreria moduli organizzazione. Questa autorizzazione viene in genere concessa solo ad alcuni utenti o un reparto che gestisce il computer basato su Exchange Server.
Libreria moduli personaliModuli salvati in questa libreria accessibili solo all'utente. Quando si pubblica un modulo nella libreria moduli personali, il modulo viene memorizzato come elemento nascosto nella cartella principale della cassetta postale o del file delle cartelle personali (pst), ovvero la posizione di recapito di posta elettronica predefinito. Come i moduli vengono memorizzati nella libreria moduli organizzazione, questi moduli possono essere aperti utilizzando il comando Scegli modulo . Salvare il modulo in questa libreria quando si crea un modulo per uso personale, ad esempio un modulo di messaggio di posta elettronica standard preindirizzato ai destinatari.

È inoltre possibile archiviare un modulo di Outlook come file nel file system o come un elemento in una cartella di Outlook. Si consiglia di evitare entrambi questi approcci, tuttavia, poiché il modulo sarà un modulo one-off. Per ulteriori informazioni sui moduli one-off, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base:
290657 Descrizione delle definizioni dei moduli e dei moduli unici in Outlook 2002
È possibile salvare un modulo di Outlook nel file System come file modello Outlook (oft). Consente di allegare il modulo a un messaggio di posta elettronica e quindi inviare il modulo a un altro utente. Inoltre, è possibile utilizzare il file con estensione oft come una copia di backup del modulo. Per salvare un modulo come file OFT:
  1. Scegliere Salva con nome dal menu File .
  2. Nella casella Nome File digitare un nome per il modulo.
  3. Nella casella tipo fare clic su Modello Outlooke quindi fare clic su Salva.
È inoltre possibile salvare il modulo come un elemento nella cartella corrente. Tuttavia, Microsoft consiglia di eseguire questa operazione per i seguenti motivi:
  • È facile eliminare accidentalmente il modulo.
  • Tende a ridurre la distinzione tra moduli ed elementi e il risultato tipico è una cartella che viene riempita con diversi elementi che contengono versioni diverse dello stesso modulo. Non si tratta in genere buona norma durante la progettazione di moduli di Outlook.
  • Gli elementi archiviati in una cartella in genere sono dati associati e in genere non si desidera che i dati associati al modulo. Pertanto, si consiglia di non aprire un elemento in una cartella e quindi attivare la modalità di progettazione; Aprire una nuova istanza del modulo e quindi la modalità di progettazione.
  • I moduli vengono memorizzati come elementi sono moduli "one-off" e presentano effetti collaterali indesiderati.
Per salvare un modulo nella cartella corrente, scegliere Salva dal menu File .

Considerazioni per decidere dove pubblicare un modulo

Esistono molte domande da prendere in considerazione quando si decide dove pubblicare un modulo:
  • Il modulo è basato su una soluzione di cartella o è un modulo di messaggio di posta elettronica è stato progettato per essere inviato ai destinatari?
  • Si sta utilizzando un computer basato su Exchange Server? Se si utilizza un computer basato su Exchange Server, è possibile pubblicare il modulo nella libreria moduli organizzazione o nell'organizzazione sono state definite restrizioni relative ai tipi di form possono essere memorizzati?
  • Quante persone devono poter accedere al modulo?
  • Sarà possibile aggiornare il modulo spesso, pertanto è importante avere solo una copia del modulo distribuito in modo centralizzato?
  • Il modulo deve essere disponibile non in linea?
  • Se si tratta di un modulo di messaggio di posta elettronica, verrà utilizzata solo all'interno dell'organizzazione o inviato ad altri destinatari esterni all'organizzazione?
  • Come verrà aperto il nuovo modulo?

Come decidere dove pubblicare moduli basati su cartella

Quando si crea una soluzione basata su cartella dove l'obiettivo primario del modulo sia per visualizzare gli elementi in una singola cartella, è consigliabile pubblicare il modulo nella cartella stessa. Quando si pubblica il modulo nella cartella, la cartella è un'entità indipendente e il modulo è disponibile nel menu Azioni .

Tuttavia, esistono scenari in cui non è possibile pubblicare un modulo basato su cartella tipico in una cartella. Se si utilizza un modulo in più di una cartella e ciascuna cartella utilizza sempre la stessa versione del modulo, è consigliabile pubblicare il modulo nella libreria moduli organizzazione o nella libreria moduli personali. Quando si esegue questa operazione, è solo una copia del modulo pubblicato ed è più semplice per l'aggiornamento se è necessario apportare modifiche. Se si è l'unica persona che deve accedere a questo modulo, pubblicare il modulo nella libreria moduli personali. Se altri utenti devono poter accedere al form e la maschera è tipica in una cartella pubblica in un computer basato su Exchange Server, provare a utilizzare o meno è possibile pubblicare il modulo nella libreria moduli organizzazione. Un potenziale svantaggio di questo approccio è che il modulo non sarà disponibile nel menu Azioni a meno che non si è pubblicato nella cartella. Tuttavia, se il modulo predefinito per la cartella, come avviene in genere, ciò non rappresenterà una quantità eccessiva di una differenza perché o utenti possono utilizzare un pulsante della barra degli strumenti per aprire nuovi elementi.

Come decidere dove pubblicare moduli basati su messaggi

Se il modulo è basato su un messaggio di posta elettronica e viene utilizzato da è e solo un paio di altri utenti, pubblicare il modulo nella libreria moduli personali per tutti gli utenti. Tuttavia, se si desidera creare nuovi elementi basati su questo modulo, è possibile pubblicarlo nella posta in arrivo, in modo che sia accessibile dal menu Azioni . Se il modulo dovrà essere utilizzato da molte persone all'interno di un'organizzazione, pubblicarlo nella libreria moduli organizzazione in modo che solo una copia del modulo per gestire e tutti gli utenti possano accedervi. Questo approccio, tuttavia, può creare il form più difficili da aprire.

Considerazioni e opzioni per l'apertura di moduli

La tabella seguente descrive la modalità di apertura standard a seconda di dove sono memorizzati i moduli di Outlook:

Tipo di moduloDove deve essere aperta
Moduli della cartellaSe si apre la cartella che contiene i moduli, i moduli sono disponibili nel menu Azioni .
Libreria moduli organizzazione

- e -

Libreria moduli personali
Moduli memorizzati nella libreria moduli organizzazione e Libreria moduli personali sono progettati per essere accessibili tramite la finestra di dialogo Scegli modulo . Per accedere a questi moduli, scegliere Nuovo dal menu File e quindi fare clic su Scegli modulo.

È possibile utilizzare i metodi seguenti per rendere più accessibile agli utenti i moduli.

Aggiungere il comando "Scegli modulo" sulla barra degli strumenti

Outlook 2007 e Outlook 2003

Per ridurre il numero di passaggi necessari per accedere al comando Scegli modulo , aggiungere il comando alla barra degli strumenti in modo da visualizzare nella finestra di dialogo con un solo clic del mouse.
  1. Dal menu Visualizza , scegliere barre degli strumentie quindi fare clic su Personalizza.
  2. Fare clic sulla scheda comandi nella finestra di dialogo Personalizza .
  3. Nella casella categorie , assicurarsi che il File sia selezionata.
  4. Nella casella comandi , individuare il comando Scegli modulo e quindi trascinarlo nella posizione la barra degli strumenti desiderata.
  5. Fare clic su Chiudi.

2013 Outlook e Outlook 2010

Per ridurre il numero di passaggi necessari per accedere al comando Scegli modulo , aggiungere la scheda sviluppo alla barra multifunzione in modo da visualizzare nella finestra di dialogo Scegli modulo con un paio di clic del mouse.
  1. Destro del mouse sulla barra multifunzione di Outlook e quindi fare clic su Personalizza barra multifunzione.
  2. Nell'elenco delle Schede principale, selezionare Developere quindi fare clic su OK.
Nella scheda sviluppo sulla barra multifunzione di Outlook, si dovrebbe vedere Scegli modulo visualizzato.

Aprire una maschera utilizzando Visual Basic, Applications Edition o un componente aggiuntivo COM

Per ulteriori informazioni sull'utilizzo di Visual Basic, Applications Edition per aprire un modulo da un menu o barra degli strumenti, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base:
290803 OL2002: Come aprire un modulo da un pulsante della barra degli strumenti

Pubblicare il modulo in una cartella

Se un modulo viene pubblicato nella libreria moduli personali o nella libreria moduli organizzazione, è possibile pubblicarlo in una cartella in modo che venga visualizzato nel menu Azioni . Tuttavia, se la maschera viene aggiornata, assicurarsi che il modulo sia installato in modo da non creare problemi con i moduli di Outlook. Per ulteriori informazioni sulla cache dei moduli, fare clic sui numeri per visualizzare gli articoli della Microsoft Knowledge Base:
290806 Descrizione di Outlook 2002 cache dei moduli

Salvataggio di un File OFT sul Desktop o Menu Start

Sebbene Microsoft sconsigli in genere salvando un file OFT sul desktop o dal menu di avvio , è possibile salvare un file modello Outlook (oft) posizione. Gli elementi creati in questo modo contengono moduli "one-off" che generano solitamente effetti collaterali indesiderati in base alla progettazione del form e come utilizzarlo.

Per ulteriori informazioni sui moduli one-off, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base:
290657 Descrizione delle definizioni dei moduli e dei moduli unici in Outlook 2002
Riferimenti
Per ulteriori informazioni sulle risorse disponibili e le risposte alle domande frequenti sulle soluzioni di Microsoft Outlook, fare clic sul numero dell'articolo per visualizzare l'articolo della Microsoft Knowledge Base:
287530 Domande frequenti sui moduli personalizzati e soluzioni di Outlook
OfficeKBHowTo OutSol OutSol2002

Avviso: questo articolo è stato tradotto automaticamente

Proprietà

ID articolo: 290802 - Ultima revisione: 05/04/2015 01:15:00 - Revisione: 6.0

Microsoft Outlook 2013, Microsoft Outlook 2010, Microsoft Office Outlook 2007, Microsoft Office Outlook 2003

  • kbforms kbhowto kbmt KB290802 KbMtit
Feedback